No sound over HDMI on Ubuntu 18.04 and 19.10

Post Reply
Nerox
Posts: 3
Joined: Tue Apr 21, 2020 2:22 am
languages_spoken: english
ODROIDs: Odroid H2
Has thanked: 0
Been thanked: 1 time
Contact:

No sound over HDMI on Ubuntu 18.04 and 19.10

Post by Nerox » Tue Apr 21, 2020 2:27 am

Hello,

I freshly installed Ubuntu 18.04 and 19.10. Both do not give me any sound over HDMI. After reboot, the right Output is selected (HDMI), but no sound is present. When I click "Test speakers", nothing happens. When I switch the sound to SPDIF and then try to switch back to HDMI, a dummy output is created. So far nothing I tried worked.

I tried all of this, didn't do anything:
https://www.linuxuprising.com/2018/06/f ... ue-in.html


Kind regards

User avatar
odroid
Site Admin
Posts: 34195
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 701 times
Been thanked: 625 times
Contact:

Re: No sound over HDMI on Ubuntu 18.04 and 19.10

Post by odroid » Tue Apr 21, 2020 9:48 am

I'm running Ubuntu 19.10 with Kernel 5.3.0-46 and HDMI & DP sound works fine. Show us your "aplay -l" output.

Code: Select all

odroid@h2:~$ uname -a
Linux h2 5.3.0-46-generic #38-Ubuntu SMP Fri Mar 27 17:37:05 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

odroid@h2:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Nerox
Posts: 3
Joined: Tue Apr 21, 2020 2:22 am
languages_spoken: english
ODROIDs: Odroid H2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: No sound over HDMI on Ubuntu 18.04 and 19.10

Post by Nerox » Wed Apr 22, 2020 3:30 am

I am getting the exact same output, except it says ALC662 rev3 Analog [ALC662 rev3 Analog]

I am trying to make heads and tails out of this. The sound _worked_ in Ubuntu 18.04 LTS from time to time, but now, it crashed for good. I thus have tried upgrading to 19.10, but I have not gotten a single tone via hdmi out of the device.

I am a complete novice with Ubuntu and I am trying to use the device as a media computer. Can you guide me how to start troubleshooting here?

Sound via the 3,5mm Audio Jack works without any problems...

User avatar
odroid
Site Admin
Posts: 34195
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 701 times
Been thanked: 625 times
Contact:

Re: No sound over HDMI on Ubuntu 18.04 and 19.10

Post by odroid » Wed Apr 22, 2020 9:33 am

Can you see HDMI/DP output option in Settings -> Sound menu something like this?
Sound.png
Sound.png (152.33 KiB) Viewed 889 times
Also try connecting other TVs or monitors to narrow down root causes.

Nerox
Posts: 3
Joined: Tue Apr 21, 2020 2:22 am
languages_spoken: english
ODROIDs: Odroid H2
Has thanked: 0
Been thanked: 1 time
Contact:

Re: No sound over HDMI on Ubuntu 18.04 and 19.10

Post by Nerox » Thu Apr 23, 2020 1:27 am

I am afraid I found the cause for the problem: its the hass.io docker container.

https://community.home-assistant.io/t/a ... r/178858/5
https://github.com/home-assistant/plugi ... /issues/12

Stopping the container does solve the problem and the audio is back on track. Weird, but I will need to dig into this if I want home automation and sound via HDMI I'm afraid.

Thanks for your help and sorry for the trouble, just thought I let everybody know.
These users thanked the author Nerox for the post:
odroid (Thu Apr 23, 2020 9:22 am)

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 1 guest