Linux Kernel 3.8.13.2 For Debian?

Post Reply
Tuigje
Posts: 60
Joined: Thu Jun 20, 2013 1:00 am
languages_spoken: english dutch german
ODROIDs: Odroid X2
Contact:

Linux Kernel 3.8.13.2 For Debian?

Unread post by Tuigje » Thu Jun 20, 2013 4:57 am

Hello all,

My Odroid-X2 board just arrived, so I'm trying use the latest and greatest kernel.
I've tried the binaries from
http://forum.odroid.com/viewtopic.php?f ... 6&start=20
But I've had no luck yet.

The testing I've done so far is:
Both the 3.8 kernel from the link above, and one cross-compiled from git (using odroidx2_defconfig) don't seem to boot on my system.
A cross-compiled 3.0 kernel works fine. I've tried the given .scr, and a modified one which skips the ramdisk.
Both .scr's work with 3.0, but not with 3.8

The rootfs is the debian U2 image, upgraded to debian-testing.

After booting 3.8, the first blue LED keeps pulsing two short blimps, with some pause inbetween.

Does someone have a hint on what I could do ?

User avatar
memeka
Posts: 4220
Joined: Mon May 20, 2013 10:22 am
languages_spoken: english
ODROIDs: XU rev2 + eMMC + UART
U3 + eMMC + IO Shield + UART
Contact:

Re: Linux Kernel 3.8.13.2 For Debian?

Unread post by memeka » Thu Jun 20, 2013 8:18 am

Modify /etc/X11/xorg.conf and change /dev/fb6 to /dev/fb1

I think the kernel works, just that you don't get any video out :)

Tuigje
Posts: 60
Joined: Thu Jun 20, 2013 1:00 am
languages_spoken: english dutch german
ODROIDs: Odroid X2
Contact:

Re: Linux Kernel 3.8.13.2 For Debian?

Unread post by Tuigje » Thu Jun 20, 2013 2:56 pm

Thanks for the hint.
At this moment, X is not installed at all, it's ssh-access only.
Neither the onboard eth0, nor the usb-wlan adapter come up, so I suspect that the rootfs might not get mounted.
I'm wondering if there's anything I can test without the serial-console cable (which I don't have).
I checked the 3.8 kernel, and it has ext4 support built-in, so I don't see what could go wrong..

mdrjr
Site Admin
Posts: 11698
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Contact:

Re: Linux Kernel 3.8.13.2 For Debian?

Unread post by mdrjr » Thu Jun 20, 2013 9:29 pm

Tuigje wrote:Thanks for the hint.
At this moment, X is not installed at all, it's ssh-access only.
Neither the onboard eth0, nor the usb-wlan adapter come up, so I suspect that the rootfs might not get mounted.
I'm wondering if there's anything I can test without the serial-console cable (which I don't have).
I checked the 3.8 kernel, and it has ext4 support built-in, so I don't see what could go wrong..
Debian eh?

remove the /etc/smsc95xx_mac_addr file
reboot the board
it will change the mac address and ip..
You'll be able to access it.

Tuigje
Posts: 60
Joined: Thu Jun 20, 2013 1:00 am
languages_spoken: english dutch german
ODROIDs: Odroid X2
Contact:

Re: Linux Kernel 3.8.13.2 For Debian?

Unread post by Tuigje » Fri Jun 21, 2013 1:27 am

remove the /etc/smsc95xx_mac_addr file
Awesome, thanks!
3.8 now works, custom compiled, without initrd.

Note: Only thing I needed to do further to make wireless work was:
http://wiki.debian.org/rtl819x#Debian_7.0_.22Wheezy.22

Tuigje
Posts: 60
Joined: Thu Jun 20, 2013 1:00 am
languages_spoken: english dutch german
ODROIDs: Odroid X2
Contact:

Re: Linux Kernel 3.8.13.2 For Debian?

Unread post by Tuigje » Sat Jun 22, 2013 3:30 am

The hdmi-output is still a challenge though.

from /var/log/Xorg.0.log:
[ 2715.896] (EE) module ABI major version (11) doesn't match the server's version (12)
[ 2715.896] (II) UnloadModule: "mali"
[ 2715.896] (II) Unloading mali
[ 2715.896] (EE) Failed to load module "mali" (module requirement mismatch, 0)
I've tried:
http://dn.odroid.com/MALI400_R3P2/20130222/
and
http://dn.odroid.com/MALI400_R3P2/20130 ... rg-1.13.3/

Which are version 11 and 13, respectively.
Does someone know where I can get version 12 of the mali drivers, either in source or binary ?

Edit 1: One part seems to be:
http://malideveloper.arm.com/develop-fo ... ce-code-2/

Edit 2: Ahh, will try this:
http://linux-sunxi.org/Binary_drivers#I ... ry_drivers
Mmm, stil gives version 11 version 12 error, but it probably doesn't help that I compiled the mali driver straight into the kernel,
instead of it being a module...

Post Reply

Return to “Other OS”

Who is online

Users browsing this forum: No registered users and 1 guest