19"rack mount NAS with my N1

Post Reply
jit
Posts: 112
Joined: Mon Mar 30, 2015 4:10 pm
languages_spoken: english, french
ODROIDs: one odroid-w, two C0, one C1, two C1+, one C2, one XU4, one N1, four HC1
Contact:

19"rack mount NAS with my N1

Unread post by jit » Wed Aug 29, 2018 6:20 am

Hello all,

I finally finished my NAS with the fantastic N1 board (3rd layer from the top on the photo below) ;)
It's a 19" rack mount NAS that provides:
- one 5.25" drive bay
- one 3.5" drive bay
- some space for a 2.5 hdd or SSD.
- 2 activity leds in front

I know that the N1 is dead, but it is working very well for me !

If any interest, you can see more on my blog : http://www.bluemind.org/odroid-n1-enhanced-nas-19-rack/
20180527_230921.jpg
20180527_230921.jpg (233.93 KiB) Viewed 597 times

User avatar
rooted
Posts: 6079
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Contact:

Re: 19"rack mount NAS with my N1

Unread post by rooted » Wed Aug 29, 2018 9:57 am

Very nice set-up jit :)

Did you enable performance mode instead of powersave?

Code: Select all

echo performance | sudo tee /sys/module/pcie_aspm/parameters/policy

User avatar
mad_ady
Posts: 5096
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: 19"rack mount NAS with my N1

Unread post by mad_ady » Wed Aug 29, 2018 2:43 pm

Very nice indeed! What are you using for software? (kernel/uboot/os)? I'm having some reboot hangs with mine and it can't quite move into production because of this yet.

jit
Posts: 112
Joined: Mon Mar 30, 2015 4:10 pm
languages_spoken: english, french
ODROIDs: one odroid-w, two C0, one C1, two C1+, one C2, one XU4, one N1, four HC1
Contact:

Re: 19"rack mount NAS with my N1

Unread post by jit » Wed Aug 29, 2018 5:30 pm

@rooted : yes , I user performance mode over powersave for pci_aspm

@mad_ady: I use the provided uboot, a kernel I compiled myself from the official git repo and archlinuxarm. You can see all details on the blog post.

So far, it runs since several weeks now (24/7), very fast, stable, no crash (nfs, samba, docker, nightly disk mirroring).

Next step is to put ELK on it to manage all my docker's logs... but I need to finish my hc1 swarm cluster before :)

Post Reply

Return to “Projects”

Who is online

Users browsing this forum: No registered users and 1 guest