USB 3.0 port doesn't work after reboot/warm-boot.

Test and fix the Kernel 4.14 features
Post Reply
User avatar
odroid
Site Admin
Posts: 30015
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by odroid » Thu Nov 30, 2017 2:18 pm

When we do "reboot" command, the USB 3.0 hub controller is not detected from time to time.
"lsusb -t" output doesn't show

Code: Select all

|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/2p, 5000M
Cold-boot or power-cycle doesn't show this problem.
After cold-boot and plugging a USB device, there is no problem.

We are trying to fix this issue by adding a virtual USB power reset function in the kernel driver now.

If your USB device doesn't work with hot-plug, you have to do shutdown and turn it on as a workaround.

User avatar
odroid
Site Admin
Posts: 30015
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by odroid » Fri Dec 01, 2017 6:56 pm

We've fixed this issue.
https://github.com/hardkernel/linux/com ... f0c0d1c56d

Next kernel update package will include it.

rncwnd
Posts: 34
Joined: Tue Apr 11, 2017 11:18 pm
languages_spoken: english, german
ODROIDs: XU4
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by rncwnd » Tue Dec 05, 2017 4:55 pm

odroid wrote:We've fixed this issue.
https://github.com/hardkernel/linux/com ... f0c0d1c56d

Next kernel update package will include it.
Nice, will that be backported to 4.9?

User avatar
odroid
Site Admin
Posts: 30015
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by odroid » Tue Dec 05, 2017 5:10 pm

Kernel 4.9 had no such issue.

rncwnd
Posts: 34
Joined: Tue Apr 11, 2017 11:18 pm
languages_spoken: english, german
ODROIDs: XU4
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by rncwnd » Mon Dec 11, 2017 3:53 am

odroid wrote:Kernel 4.9 had no such issue.
I have it on every warm reboot on kernel 4.9.

User avatar
odroid
Site Admin
Posts: 30015
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by odroid » Mon Dec 11, 2017 9:22 am

Sorry. I didn't know that.

Please consider using Kernel 4.14 since we won't support 4.9 anymore.
viewtopic.php?f=29&t=28895

Kernel 4.14.4 release has included the patch.

pcfe
Posts: 3
Joined: Fri Mar 01, 2019 2:42 am
languages_spoken: english
ODROIDs: seven ODROID-HC2 used with Ceph Luminous
Contact:

Re: USB 3.0 port doesn't work after reboot/warm-boot.

Unread post by pcfe » Tue Mar 05, 2019 4:14 am

odroid wrote:
Fri Dec 01, 2017 6:56 pm
We've fixed this issue.
https://github.com/hardkernel/linux/com ... f0c0d1c56d

Next kernel update package will include it.
Has this fix been submitted and accepted upstream?

I'm on 4.20.11 and experience the issue.

Post Reply

Return to “Linux Kernel 4.14 Debugging Party”

Who is online

Users browsing this forum: No registered users and 1 guest