LibreELEC 7.0.2 - Kodi Jarvis 16.1 - Archived - LE Tips HERE

Moderators: mdrjr, odroid, Raybuntu, wrxtasy

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Sat Jun 11, 2016 7:31 am

wrxtasy wrote:Ok I have now seen the approx. 10 second lag in video startup with Audio Playing in the background, this fixed it for me:

Settings > System > Audio Output > Keep Audio Device Alive > Do NOT select "Always" ;)


Sweet thanks for that.
Also changed the other settings you mentioned.

Seems to of sorted the 10sec in issue.

Thanks
Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Sat Jun 11, 2016 7:32 am

I can confirm it too :) - another check
Well done hehe
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby infinity85 » Sat Jun 11, 2016 8:13 am

wrxtasy wrote:Ok I have now seen the approx. 10 second lag in video startup with Audio Playing in the background, this fixed it for me:

Settings > System > Audio Output > Keep Audio Device Alive > Do NOT select "Always" ;)


haha so easy! thanks :D
infinity85
 
Posts: 337
Joined: Tue May 24, 2016 4:26 am
languages_spoken: english, german
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Sat Jun 11, 2016 12:15 pm

wrxtasy wrote:Ok I have now seen the approx. 10 second lag in video startup with Audio Playing in the background, this fixed it for me:

Settings > System > Audio Output > Keep Audio Device Alive > Do NOT select "Always" ;)

I tried this before, unfortunately the fix doesn't work on my setup. Video still starts around the 7-second mark.

Update: Since wrxtasy's recommendation seemed to work for some, this piqued my interest. I decided to try a few different videos to see if I could replicate the fix that others were enjoying. I'm using CinemaVision to play four separate movie trailers and two bumpers before the feature film. Here is what I discovered:

1. The movie trailers that gave me problems after the first post-fix test were encoded in AAC (from http://www.hd-trailers.net/page/1/). With "Keep Audio Device Alive" disabled they still all skipped to 7 seconds.

2. I decided to try out movie trailers encoded in AC3 (from http://thedigitaltheater.com/index.php/ ... iler-list/). With "Keep Audio Device Alive" disabled the AC3-encoded trailers play perfectly from the very beginning. I thought I had it figured out -- the problem was somehow related to AAC.

3. I removed the AC3 trailers and decided to try the AAC trailers again to make sure it was indeed the AAC (transcoding perhaps?) that was the root of the problem. But this time the first 3 AAC trailers played perfectly with the 4th trailer skipping ahead 7 seconds. Odd. Equally as odd is the fact that regardless of the "Keep Audio Device Alive" setting my 20-second AAC bumpers always play perfectly fine from the very beginning.

4. I tried the AAC trailers again, this time with Stereo Upmix disabled. All four AAC movie trailers play from the very beginning but I have no audio (except from the AAC-encoded 20-second bumpers. Odd).

Looks like I need to stick with AC3-encoded trailers for now until the AAC issue is resolved. I can live with that. :)

Thanks wrxtasy, keep up the good work.
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sat Jun 11, 2016 2:39 pm

I'm also using AC3 Transcoding to play 5.1 AAC video content I have..and have no issues with playing any AAC that way.

I don't use Stereo Upmix ever when Transcoding. The Audio Channels selector is missing anyway for this Upmix option so its useless.
In fact I will probably remove that Upmix option altogether for the C2 at the moment to avoid confusion.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Sat Jun 11, 2016 2:47 pm

Any idea why disabling Stereo Upmix results in no audio for the AAC trailers?
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sat Jun 11, 2016 3:20 pm

Suggestion: Go down the bottom of the Audio Settings and "Reset above settings to default" and go back in the GUI settings one Menu level to ensure they are saved.

Then only reselect:
- Keep Audio device Alive - OFF
- Enable Passthrough
- Dolby Digital (AC3) capable receiver
- Enable Dolby Digital (AC3) Transcoding

The other thing to check is when a AAC audio / video is playing, pull up the Audio OSD and make sure the standard settings are in there, as you would have seen with Kodi on very first use. Save as default for all videos if you have to.

If that fails something strange is going on with your individual setup, as I'm unable to reproduce the AAC audio problem with the fix outlined and the previous posts.

I'm about to release a LE 7.0.2 with a bunch of tweaks, additions and bug fixes.

@peakock,
Hardware deinterlacing on AML is all Automatic when Hardware decoding video using amcodec. Interlaced DVD playback was always an issue on AML with Kodi, I just disable hardware decoding for mpeg2 DVD's and use High Quality, Full motion YADIFx2 deinterlacing for 480/576i Interlaced mpeg2 DVD's. The other benefit is old problematic 480/576i Interlaced mpeg2 TV Rips in .mkv containers (or any other) can be configured to use YADIFx2 as well. Its a win win. :D

YADIFx2 deinterlacing quality is virtually indistinguishable from AML Hardware deinterlacing.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby silashack » Sat Jun 11, 2016 3:47 pm

wrxtasy wrote:
I'm about to release a LE 7.0.2 with a bunch of tweaks, additions and bug fixes.



MANY MANY thanks for the effort and time you are providing, much appreciated.. Will this version have the sql fix/options? I have a few niggles with myslq and shared libraries and would like to mess with the options you described.

Cheers
silashack
 
Posts: 15
Joined: Sat May 21, 2016 11:08 pm
languages_spoken: english
ODROIDs: C2, HC1

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby peak3d » Sat Jun 11, 2016 4:09 pm

wrxtasy wrote:Hardware deinterlacing on AML is all Automatic when Hardware decoding video using amcodec. Interlaced DVD playback was always an issue on AML with Kodi, I just disable hardware decoding for mpeg2 DVD's and use High Quality, Full motion YADIFx2 deinterlacing for 480/576i Interlaced mpeg2 DVD's. The other benefit is old problematic 480/576i Interlaced mpeg2 TV Rips in .mkv containers (or any other) can be configured to use YADIFx2 as well. Its a win win.


OK; great info, thx. I was asking, because deinterlace driver was NOT correctly configured in the device tree for at least C1 in hk's linux 3.10 kernel. The frame receiver was simply not existing.
Do you use hk's kernels for your fork?

[Edit:] Maybe you have already seen, that wetek pushes the deinterlace driver at boot time into the vfm map, right before the amlplayer.
If there are issues regarding deinterlace (and I have read some in previous posts) it would be interesting to see, if aml's deinterlacer s really in the render path.
cat /sys/class/vfm/map while playing the interlaced video would be interesting to see.
peak3d
 
Posts: 267
Joined: Wed Jan 28, 2015 8:12 pm
languages_spoken: english,german
ODROIDs: XU3,C1

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Emilot » Sun Jun 12, 2016 2:34 am

Hello,

Is there an option in LibreElec(boot.ini ?) for output full or limited RGB color space?

Thank you for your wonderful job guys.

:D
Emilot
 
Posts: 5
Joined: Fri Dec 11, 2015 3:18 am
languages_spoken: english

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby luke265 » Sun Jun 12, 2016 5:21 am

Hi,

I'm using this External USB Sound Card and when enabling audio passthrough, the audio starts to stutter quite frequently. I've tested that card on my laptop and desktop pc, it works just fine. Tried all options in "Audio ouput" settings, nothing helps.

Thanks!
luke265
 
Posts: 3
Joined: Wed Jun 01, 2016 9:24 pm
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Sun Jun 12, 2016 7:51 am

wrxtasy wrote:Suggestion: Go down the bottom of the Audio Settings and "Reset above settings to default" and go back in the GUI settings one Menu level to ensure they are saved.

Then only reselect:
- Keep Audio device Alive - OFF
- Enable Passthrough
- Dolby Digital (AC3) capable receiver
- Enable Dolby Digital (AC3) Transcoding

The other thing to check is when a AAC audio / video is playing, pull up the Audio OSD and make sure the standard settings are in there, as you would have seen with Kodi on very first use. Save as default for all videos if you have to.

Done. Same issue, if Stereo Upmix is disabled then I hear no audio from the AAC trailers (and it also turns out that one of them still started at around the 7-second mark).

Here is another issue I noticed -- I can't hear any MP3 music playing if Stereo Upmix is disabled. It's playing, but no sound. While it's playing I went into settings and enabled Stereo Upmix and I could hear the music almost immediately.

I think Stereo Upmix is something you may want to leave in the next release for those of us who benefit from it.
Last edited by MidnightWatcher on Sun Jun 12, 2016 4:00 pm, edited 2 times in total.
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sun Jun 12, 2016 1:02 pm

luke265 wrote:Hi,

I'm using this External USB Sound Card and when enabling audio passthrough, the audio starts to stutter quite frequently. I've tested that card on my laptop and desktop pc, it works just fine. Tried all options in "Audio output" settings, nothing helps.

Thanks!

@Everyone,
Comprehensive support for externally connected Hardware such as DVB's, USB Sound Cards etc will NOT be provided by LibreELEC.

Its impossible to provide such support when:
a) a developer does not have the actual Hardware.
b) the Linux Kernel used in AML devices is now pretty old compared to Intel or the RPi series of devices. :cry:
c) I frankly do not wish to get involved in such time consuming Hardware support for an old Linux Kernel.

Some individual users may have drivers already modded or backported. If that is the case and a clean patch is provided for the v3.14 C2 Kernel, then drivers can be incorporated.

HardKernel HiFi Shield and HK USB DAC support has already been pulled out of the v3.14 Kernel used for LE to get HD Audio Passthrough to work properly with Kodi. I doubt it will be going back in either, unless someone wants to sit down and mod. Kodi specifically for such support with working HDMI Audio passthrough.

LibreELEC is using pretty much the same Linux Kernel and drivers as Ubuntu on the C2.
If drivers or Hardware are not working properly then users need to open up a thread in the C2 Issues Sub-Forum and ask for driver support from HardKernel themselves OR sit down and compile their own modded LibreELEC from my GitHub sources.

---------------

If anyone has a working USB --->> S/PDIF setup then it would help if they can post up the Exact Hardware they are using with LE for the benefit of others. Open up a new thread and title it "USB --->> S/PDIF working Hardware with LE"
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Sun Jun 12, 2016 5:22 pm

rokapet wrote:
agbart wrote:
rokapet wrote:@agbart

My remote is configured as Microsoft MCE-Keyboard, exactly as you say. The only thing missing is the copy from the post you linked:

Code: Select all
ssh root@ip.address.of.C2
Password -->  le
cp /etc/lirc/lircd.conf.rpi /storage/.config/lircd.conf
reboot


Thank you for the hint, will try it tonight, when I get home from work. :)


Don't set your remote up as a MCE-keyboard, just add a new device and make it a Media Centre PC (Microsoft Windows Media Centre). MyHarmony will flag it as a software application and go on about needing a brand and model number but just ignore that. Then just use that as if it's the C2 when you create your activity in MyHarmony, run that bit of code above and you should be sweet. All that other stuff is not necessary.


Man, you rock! :D
Works like a charm! I owe you a beer. ;)


Really would like to use my Microsoft media center remote.

Running the above command via putty, gives me most of the remote buttons but not all.
While playing a vid, pressing the OK button acts as pause. .
With OE it would bring up the menu with pause, stop fast forward ect....

Anyone had any luck with this particular remote?
model: 1039

Thanks
Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Dave-Kay » Sun Jun 12, 2016 5:42 pm

richpags wrote:
Really would like to use my Microsoft media center remote.

Running the above command via putty, gives me most of the remote buttons but not all.
While playing a vid, pressing the OK button acts as pause. .
With OE it would bring up the menu with pause, stop fast forward ect....

Anyone had any luck with this particular remote?
model: 1039

Thanks
Richie


only way i know is the one that is described in a link at first post with lircd.conf and even with that, it's not possible to get the same config that you have with a miniPC like NUC or similar.
Dave-Kay
 
Posts: 19
Joined: Thu May 05, 2016 7:02 pm
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sun Jun 12, 2016 6:16 pm

Please read Post #1 again as this bit will very likely help:
Having remote control issues ? >>> revert the custom HK IR Remote control map back to Kodi Jarvis standard:

REQUEST from this point onwards to all users:

Can individual problems from now on be asked in specific New threads now we have a dedicated LibreELEC Subforum.
Its become too difficult to track specific issues in this large thread and I will now start Moderating and removing any general problems posted here in this thread.

Also: when posting problems I need the name of the .tar file users used when updating or flashing to SD/eMMC, so we know which version everyone is talking about. (The Kodi Log only gives the build date)

I will use this thread for tests versions of LibreELEC and to announce major Bug Fixes.
Thank You.

W.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Tue Jun 14, 2016 1:08 pm

LibreELEC 7.0.2 - Kodi Jarvis 16.1 released !

W.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.2 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 29, 2016 2:49 pm

A bunch of new AML SRC code patches and a 23.976fps reverted patch is in this test update, users may have better 23.976fps video sync results with it:
(Thanks hephooey)

Also Backported libCEC (AML v3.1.0 Firmware v5) from Kodi Krypton, modded by Gerald Dachs :)

Kodi > Settings > System > Inputs > Peripherals >

This greatly improves HDMI-CEC remote button repeat signalling and noticeably improves usability:

Withdrawn due to a Vsync Kernel commit causing Overheating / freezing issues.

W.

Current LibreELEC version is LE 7.1.0 with many improvements to Kodi, drivers and the Linux Kernel

This thread kept for references purposes.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Previous

Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 5 guests