Page 15 of 20

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Fri May 27, 2016 4:47 pm
by Raybuntu
@wrxtasy: let's move the conversation to slack.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Fri May 27, 2016 6:04 pm
by wrxtasy
stefg wrote:I can't get any other resolution than 1280x720 with the 7.0.0 and 7.0.1 build.

---
Never mind. After reading up i understand, that this the GUI only and that the hardware does not support resolution switching within Kodi.
Resolution switching is supported in Kodi when playing 720p<<<-->>>1080p<<<-->>> 2160p video.

Kodi LE and the current OE for that matter are Hardcoded to only look for certain resolutions when doing a EDID handshake on startup. These are Resolutions for TV's only and what would be happening is Kodi does not recognise what your LG Monitor is telling it so defaults to 1280x720p only, the default setting.
I did experiment with Dynamic display modes read directly from a display's EDID info, but it broke so many things I abandoned it.
The boot.ini file needs a Major re-edit. All those display modes, apart from 720p, 1080i/p and 2160p you see listed are only applicable to Ubuntu and should actually be removed for LibreELEC.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Fri May 27, 2016 9:24 pm
by envagyok

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Fri May 27, 2016 11:21 pm
by deren81
wrxtasy wrote: @deren81, If iscsi support means more than just adding modules in the Kernel config or simple instructions like the above then you will have to compile your own version of LE. I can easily add these to the Kernel config if that is all that is needed ?
https://github.com/hardkernel/linux/blo ... nfig#L1614
As I can see in /proc/config.gz there is kernel support already, but no open-iscsi package build in, which is part of LibreELEC for other platforms, or at east for some reason command iscsistart isn't working.

Theoretically is you have option iscsi set to yes (line 151):
https://github.com/LibreELEC/LibreELEC. ... EC/options
it should compile open-iscsi package in.

If you could check it would be nice

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Fri May 27, 2016 11:50 pm
by xblackdemonx
Sorry, i'm a bit noob when it comes to Linux. Is there a way to easily overclock LibreElec on the C2?
Thanks

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 12:36 am
by wrxtasy
Don't know of an Overclock. In fact the C2 runs in Performance mode already and would likely cook if pushed any further unless some really good cooling is used. Plus Kernel mods would be needed for very little gain.

@deren81, yes LE is compiled with the standard iscsi option. Ive also enabled the iscsc modules in the Kernel with the following build:

Lets try DTS-HD Audio passthrough again shall we, thanks to envagyok for the Tip. I'm pretty confident this DTS-HD update will work this time around as I've traced the code. A simple tiny update to an existing Kodi patch I have would have fixed it as well !

LibreELEC-Odroid_C2.aarch64-7.0.1.DTS-HD.tar

Enjoy :)
W.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 1:04 am
by jurand
Hey, it WORKS! I've tried all the files I have with DTS-HD MA and haven't noticed a problem. :D :D :D

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 1:59 am
by Pienoet
Hi wrxtasy,

Are there already krypton builds for the C2?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 2:29 am
by wrxtasy
I would not get your hopes up for any decent Krypton test releases yet. I had a chat about amcodec with Codesnake from WeTek this afternoon and Krypton has removed the master clock and there is new rendering loop logic = Trouble for AMLogic devices causing no A/V sync and High CPU loads.

Codesnake and Wetek and re-writing an old AML decoder and a new AML renderer to work with Krypton, progress is slow. PVR's and mpeg2 is Kaput at the moment and there are video playback issues with other codecs.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 2:39 am
by mlask
I'll ask again: what about wifi drivers? On most distributions based on latest hardkernel's kernel wireless devices on Realtek RTL8192CU (eg. TP-Link TL-WN823N) are working good (with average transfers ~100Mbit/s). But in LibreELEC, wireless is very unstable (completely loses connection after few minutes of work) and with transfers slower than 1Mbit. What's going on? Are you at least trying to fix it?
And second thing - I tried to use Hyperion/Boblight with Arduino Uno (as "adalight"/"momo" device) and... again, nothing worked - connection to device is opened but nothing is transferred correctly. Exactly the same Arduino connected to Rpi2 worked perfectly, so it's not a problem.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:05 am
by infinity85
wrxtasy wrote:Don't know of an Overclock. In fact the C2 runs in Performance mode already and would likely cook if pushed any further unless some really good cooling is used. Plus Kernel mods would be needed for very little gain.

@deren81, yes LE is compiled with the standard iscsi option. Ive also enabled the iscsc modules in the Kernel with the following build:

Lets try DTS-HD Audio passthrough again shall we, thanks to envagyok for the Tip. I'm pretty confident this DTS-HD update will work this time around as I've traced the code. A simple tiny update to an existing Kodi patch I have would have fixed it as well !

LibreELEC-Odroid_C2.aarch64-7.0.0.DTS-HD.tar

Enjoy :)
W.
THIS IS JUST AWESOME!! Works like a charm... AFAIK this is the first SBC which can passthrough dts-hd on OpenELEC/LibreELEC!! Thank you so much wrxtasy!

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:17 am
by MidnightWatcher
wrxtasy wrote:Lets try DTS-HD Audio passthrough again shall we, thanks to envagyok for the Tip. I'm pretty confident this DTS-HD update will work this time around as I've traced the code. A simple tiny update to an existing Kodi patch I have would have fixed it as well !

LibreELEC-Odroid_C2.aarch64-7.0.1.DTS-HD.tar

Enjoy :)
W.
Yes, yes, we will! :) Great job wrxtasy getting this added in so quickly, and tip of the hat to envagyok for the heads up and afl1 for the patch. This is the Open Source community at its best.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:26 am
by mlask
mlask wrote:I'll ask again: what about wifi drivers? On most distributions based on latest hardkernel's kernel wireless devices on Realtek RTL8192CU (eg. TP-Link TL-WN823N) are working good (with average transfers ~100Mbit/s). But in LibreELEC, wireless is very unstable (completely loses connection after few minutes of work) and with transfers slower than 1Mbit. What's going on? Are you at least trying to fix it?
And second thing - I tried to use Hyperion/Boblight with Arduino Uno (as "adalight"/"momo" device) and... again, nothing worked - connection to device is opened but nothing is transferred correctly. Exactly the same Arduino connected to Rpi2 worked perfectly, so it's not a problem.
I checked few more wireless adapters and on every single one there's something wrong - even those based on Realtek RTL8188EUS or Ralink RT3072 doesn't work correctly. So, it's definitely something wrong with this system.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:50 am
by wrxtasy
I will try and look into it soon.... there will be a test version for you shortly. I suspect the packaged LE RTL Drivers are clashing with the ones in the Kernel and need to be taken out. That i have done for your RTL8192CU.... test version soon...uploading

TEST: LibreELEC-Odroid_C2.aarch64-7.0.1.RTL8812CU.tar

I hope this next bit works...;)
[ 1561.371819] buf=2
[ 1561.371823] IEC958_mode_raw=2
[ 1561.371844] IEC958_mode_codec= 4, IEC958 type DD+
[ 1561.371848] last mode 2,now 4

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:00 am
by milanp
Hello,
Is anybody experiencing audio delay with recent builds ?
As long as hardware acceleration is active,I have no problems.
But I need software deinterlacing for DVB-C tv-streams from my MythTV server.
Most of the streams are SD,PAL,50Hz, interlaced.
With the default setting for MPEG2, Accelerate 720p and up I have audio out of sync (needs to be delayed to have lips-sync).
I have also activated Adjust display refresh rate (Always) + Sync playback to display (on).
Deinterlace video->auto
Deinterlace method->auto select
Video scaling method->Bilinear
These settings proved as best for me for the TV-streams in the previous builds.
The last build that works w/o audio issues for me is, and has perfect audio/video for me is:
LibreELEC-Odroid_C2.aarch64-7.0.0.Add.CEC.remote.ms.options
The problem is not on the Mythtv server-side, because I have raspbery PI3, macs mini's
, custom intel I5 pc's, chromebox, and none of them have the problem with audio.
If I turn of Adjust display refresh rate+ Sync playback to display, it looks like
there are no problems.
It seems that there's something changed in the software deinterlacing code...
@wrxtasy, any ideas what to check ?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:01 am
by ecab21
wrxtasy wrote:I would not get your hopes up for any decent Krypton test releases yet. I had a chat about amcodec with Codesnake from WeTek this afternoon and Krypton has removed the master clock and there is new rendering loop logic = Trouble for AMLogic devices causing no A/V sync and High CPU loads.

Codesnake and Wetek and re-writing an old AML decoder and a new AML renderer to work with Krypton, progress is slow. PVR's and mpeg2 is Kaput at the moment and there are video playback issues with other codecs.
Thanks for the update. DTS-HD finally working.

About the amlgrabber doesn't work with HEVC files, do you know anything about that?
Who should I ask about that?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:13 am
by odronew
wrxtasy wrote:
Lets try DTS-HD Audio passthrough again shall we, thanks to envagyok for the Tip. I'm pretty confident this DTS-HD update will work this time around as I've traced the code. A simple tiny update to an existing Kodi patch I have would have fixed it as well !

Enjoy :)
W.
Yes! I also confirm that DTS-HD and TrueHD now work perfect (tested with Pioneer HTP-073)!

You are so great!

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:14 am
by mlask
wrxtasy wrote:I hope this next bit works...;)
Nothing changed. Still A LOT of dropped packets and very unstable connection.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:23 am
by deren81
wrxtasy wrote: yes LE is compiled with the standard iscsi option. Ive also enabled the iscsc modules in the Kernel with the following build...
Modules are there but still no iscsistart command.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:25 am
by wrxtasy
@mlask, Kernel Log Needed:

Code: Select all

dmesg | paste
Post up the URL and I will get the HK or LE Kernel guys to look into it. Signing off for the day..

EAC3 (DD+) test build:
LibreELEC-Odroid_C2.aarch64-7.0.1.EAC3.tar

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:40 am
by dAlexis
First of all, thanks, 2 wrxtasy it's working! Just moved from Pi2. My experience is ~2 hours only and I have simple equipment indeed - old 40" Samsung 40C530 (no receivers, DTS\DD, USB audio, etc).

Several questions\remarks:
1. Simple IPTV client is needed. Was searching in default repos, but nothing. Please, advice, if using it, where 2 find workable one.
2. If moving from Pi and using Yatse - please, have in mind, that http port is different and username is needed in Yatse host setup. Arrows & power buttion in Yatse are working w\o correct host settings, no mind, how and why it happens...
3. Installed on SD (UHS\16GB) - was not sure, that my old cardreader will manage to write emmc. Sometimes I have black screen in menus with large number of items (like searching addons). SSH is workable during this, reboot command is OK ;) Was not looking in fstab (what's inside), looks like temp files (or swap?) issue. C2 is now off until next morning MSK, will investigate tomorrow. Please, advice, if the solution is known
4. Default YouTube is working OK (needed 2 install from zip on Pi)

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 4:46 am
by Pienoet
wrxtasy wrote:I would not get your hopes up for any decent Krypton test releases yet. I had a chat about amcodec with Codesnake from WeTek this afternoon and Krypton has removed the master clock and there is new rendering loop logic = Trouble for AMLogic devices causing no A/V sync and High CPU loads.

Codesnake and Wetek and re-writing an old AML decoder and a new AML renderer to work with Krypton, progress is slow. PVR's and mpeg2 is Kaput at the moment and there are video playback issues with other codecs.
Thanks for the update!

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 5:19 am
by jurand
wrxtasy wrote: EAC3 (DD+) test build:
LibreELEC-Odroid_C2.aarch64-7.0.1.EAC3.tar
sorry, doesn't work. Here is my log:
http://sprunge.us/LbUh

Edit: in this log there is also a record of kodi not responding to CEC..

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 10:59 am
by xblackdemonx
wrxtasy wrote:Don't know of an Overclock. In fact the C2 runs in Performance mode already and would likely cook if pushed any further unless some really good cooling is used. Plus Kernel mods would be needed for very little gain.
Enjoy :)
W.
I added a fan and it runs at 37C on Idle and 45C on full load :)

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 12:44 pm
by blackride
wrxtasy wrote:@milanp, Nice work there, yes I made a bit of a typo with the location of the blacklist ;)

@blackride, Based on milanp's work I would try adding this to an autostart.sh file:

Code: Select all

nano .config/autostart.sh
Add:

Code: Select all

modprobe aml_i2c
hwclock -s
CTRL-X to exit
Then:

Code: Select all

chmod +x .config/autostart.sh
reboot
If you type:

Code: Select all

lsmod
You can see if the rtc_pcf8563 (RTC Shield) and aml_i2c modules are loaded after a reboot.
Instructions from here:
http://odroid.com/dokuwiki/doku.php?id=en:pcf8563rtc
Thank you. But system time after reboot recovering from UTC time. I checked UTC time (check comand hwclock -u) and it coincides with the time that is set after a reboot.
How i can disable UTC time? :(

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:14 pm
by wrxtasy

Code: Select all

hwclock --help
and play around with the options and find one that should go back into the autostart.sh script.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 3:15 pm
by envagyok
wrxtasy wrote:
Enjoy :)
W.
Little bit off-topic. How can I make nand image file to my beelink minimx (s905) from your libreelec version?
It's serious, or easy?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 5:41 pm
by pandaadnap
Hi

Does 2160p work in 7.0.1?

7.0.0 works for me (if I put interface in 2160p it works and plays vide well), but 7.0.1 does not.
Whenever the display has to be 2160p (changing interface, or starting video) my screen stays black
Logs of launching video

Code: Select all

08:39:19 T:547593089024  NOTICE: DVDPlayer: Opening: /var/media/UNTITLED/videoplayback.mp4
08:39:19 T:547593089024 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
08:39:19 T:546526195936  NOTICE: Creating InputStream
08:39:19 T:546526195936  NOTICE: Creating Demuxer
08:39:19 T:546526195936  NOTICE: Opening stream: 0 source: 256
08:39:19 T:546526195936  NOTICE: Creating video codec with codec id: 28
08:39:19 T:546526195936   ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
08:39:19 T:546526195936 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
08:39:19 T:546526195936  NOTICE: Creating video thread
08:39:19 T:546526195936   ERROR: Get - failed to get stream
08:39:19 T:544772976864  NOTICE: running thread: video_thread
08:39:19 T:546526195936 WARNING: CDVDMessageQueue(audio)::Put MSGQ_NOT_INITIALIZED
08:39:19 T:544772976864 WARNING: Previous line repeats 1 times.
08:39:19 T:544772976864  NOTICE:  fps: 29.970030, pwidth: 3840, pheight: 2160, dwidth: 3840, dheight: 2160
08:39:19 T:544772976864  NOTICE: Display resolution ADJUST : 3840x2160 @ 60.00 - Full Screen (27) (weight: 0.001)
08:39:19 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::SetNativeResolution to 3840x2160@60.000000
08:39:19 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::SetDisplayResolution to 2160p60hz
08:39:20 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::DealWithScale Scaling interfaces of size 1920x1080 to full screen
08:39:20 T:547593089024   ERROR: EGL error in CreateSurface: 3003
08:39:20 T:547593089024  NOTICE: CreateWindow: Could not create a surface. Trying with a fresh Native Window.
08:39:20 T:547593089024  NOTICE: Using GL_TEXTURE_2D
08:39:20 T:547593089024  NOTICE: GL: Using BYPASS render method
08:39:20 T:547593089024  NOTICE: GL: NPOT texture support detected

Logs of changing interface

Code: Select all

08:40:22 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::SetNativeResolution to 3840x2160@60.000000
08:40:22 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::SetDisplayResolution to 2160p60hz
08:40:22 T:547593089024  NOTICE: CEGLNativeTypeAmlogic::DealWithScale Scaling interfaces of size 1920x1080 to full screen
08:40:22 T:547593089024   ERROR: EGL error in CreateSurface: 3003
08:40:22 T:547593089024  NOTICE: CreateWindow: Could not create a surface. Trying with a fresh Native Window.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 7:44 pm
by Raybuntu
jurand wrote:
wrxtasy wrote: EAC3 (DD+) test build:
LibreELEC-Odroid_C2.aarch64-7.0.1.EAC3.tar
sorry, doesn't work. Here is my log:
http://sprunge.us/LbUh

Edit: in this log there is also a record of kodi not responding to CEC..
It was happening while pushing buttons during startup? I've made a few more commits to mitigate that issue. @wrxtasy are the fixes i've send you in that release jurand was using? If not I have a few more in my git. I can also just send you a patch if you want.

EDIT: I'm starting to get the feeling you have a hardware issue somehow. Could also be a TV issue or Cable issue. I can't reproduce it. I've stressed my chip with endless parallel while loops sending a lot of CEC msgs and never had a timeout or busy state. I even got my old onkyo from the basement and I can't get the same state.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 7:52 pm
by 4c1t
DTS-HD works perfect! Thanks for all the work!

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 10:42 pm
by wrxtasy
@pandaadnap,This test version includes a different way of signalling 2160p modes that was present in v7.0.0.

Also included is Raybuntu's HDMI-CEC patches for those that need them:

LibreELEC-Odroid_C2.aarch64-7.0.1.HDMI-CECv1.tar

NOTE: SMB may be playing up with this version, or I'm having a local Hiccup problem.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 10:48 pm
by Raybuntu
wrxtasy wrote:@pandaadnap,This test version includes a different way of signalling 2160p modes that was present in v7.0.0.

Also included is Raybuntu's HDMI-CEC patches for those that need them:

LibreELEC-Odroid_C2.aarch64-7.0.1.HDMI-CECv1.tar
@jurand Can you please test to reproduce both issues with cecf and not cec7! Please attach a debug log if CEC goes deaf again.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sat May 28, 2016 11:13 pm
by pandaadnap
@wrxtasy

I tried the CECv1 version and it works well (both UI in 2160p and autoswitch when playing 4k video).
Thanks

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 4:03 am
by BoofDroid
I want to switch my android OS to this but I had a few quick questions.

Is it possible to back up my addons and repositories? So I don't have to redo everything.

Also I noticed in the one I installed this on for a friend, it doesn't ask for 2.1, 5.1, etc. Does it automatically detect this? I also noticed there is HD sound receiver capability options that are not in my android OS kodi?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 7:10 am
by jurand
Raybuntu wrote:
wrxtasy wrote:@pandaadnap,This test version includes a different way of signalling 2160p modes that was present in v7.0.0.

Also included is Raybuntu's HDMI-CEC patches for those that need them:

LibreELEC-Odroid_C2.aarch64-7.0.1.HDMI-CECv1.tar
@jurand Can you please test to reproduce both issues with cecf and not cec7! Please attach a debug log if CEC goes deaf again.
Tested with cec7 and cecf - no switch back now. Thanks for the fix!
Cannot reproduce the deaf CEC problem - maybe it is somehow related to the SoC temperature. Now I can see some relation between some tests I run / SoC temperature and this problem. I have to get a temperature probe, because I suspect the reported temp. is incorrect. Or my C2 is defect :(

EDIT: Replacing the cable and power supply were my first steps.. I have some more toys to connect: none of them have CEC problems with the cables / AVR / TVs I use for tests.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 1:11 pm
by wrxtasy
Good to hear, yes please get a IR Temp probe. I have wanted someone to see how accurate the AML Thermal readout actually is as I suspect it is slightly off.

I seriously doubt CEC control has anything to do with temperature.

@BoofDroid, yes you can backup all your Addons, LE settings etc with the inbuilt LibreELEC backup.

Confluence Skin > System > LibreELEC > Create System and Kodi Backup
Then connect via SMB and copy the .tar file from the Backup folder to a PC.

As for Audio, LE has far more working HD Audio options than any other AML S905 OE/LE distribution from anywhere. Yes the Channels selector is hidden and its all Automatic for AC3 / DTS 5.1 and 7.1 Audio passthrough once you have selected the appropriate Audio passthrough options.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 5:48 pm
by Raybuntu
[quote="jurand"
Tested with cec7 and cecf - no switch back now. Thanks for the fix!
Cannot reproduce the deaf CEC problem - maybe it is somehow related to the SoC temperature. Now I can see some relation between some tests I run / SoC temperature and this problem. I have to get a temperature probe, because I suspect the reported temp. is incorrect. Or my C2 is defect :(
.[/quote]

It's not unlikely to be a temp problem. What I can see in your log is that the problem starts when an interrupt has a timeout after that your TX is stuck in a busy state. Could be a hardware issue or a timing issue in the chip. Keep testing. If it happens again just give me the log and I see what I can change.

@wrxtasy: Is the patch you applied the one I've send you in slack or just the two commits from before? Just checking to see what helped so I can prepare a PR for HK.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 6:36 pm
by wrxtasy
4 of them included starting from:
[aocec] don't init node while hal_flag is set

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Sun May 29, 2016 8:29 pm
by Raybuntu
Perfect wrxtasy. Thanks.

Edit: PR is pending for HK.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 12:29 am
by Marvin27
Hi. LibreELEC support i2ctools or i2c gpio custom or i2c pcf8574 for LCDproc ?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 12:46 am
by dunghnguyen
wrxtasy wrote:Don't know of an Overclock. In fact the C2 runs in Performance mode already and would likely cook if pushed any further unless some really good cooling is used. Plus Kernel mods would be needed for very little gain.

@deren81, yes LE is compiled with the standard iscsi option. Ive also enabled the iscsc modules in the Kernel with the following build:

Lets try DTS-HD Audio passthrough again shall we, thanks to envagyok for the Tip. I'm pretty confident this DTS-HD update will work this time around as I've traced the code. A simple tiny update to an existing Kodi patch I have would have fixed it as well !

LibreELEC-Odroid_C2.aarch64-7.0.1.DTS-HD.tar

Enjoy :)
W.
Awesome ! It works perfectly! DTS HD MA appeared on my receiver ! Tks for your efforts to make it out !

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 12:51 am
by wrxtasy
@marvin27
Not that I know of, I would say you would:

1) Have to have a look at what is or can be configured in the Kernel itself
https://github.com/hardkernel/linux/blo ... _defconfig
2) Ask HardKernel themselves if Hardware is actually supported
3) Probably write custom display modes into the Kodi code as currently they only support standard TV display modes
4) Be a DIY kinda guy !!!

I have no LCD Hardware here.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 1:17 am
by Marvin27
wrxtasy wrote:@marvin27
Not that I know of, I would say you would:

1) Have to have a look at what is or can be configured in the Kernel itself
https://github.com/hardkernel/linux/blo ... _defconfig
2) Ask HardKernel themselves if Hardware is actually supported
3) Probably write custom display modes into the Kodi code as currently they only support standard TV display modes
4) Be a DIY kinda guy !!!

I have no LCD Hardware here.
Thanks. I found in line 2085:

Code: Select all

# CONFIG_INPUT_PCF8574 is not set
line 2305

Code: Select all

# CONFIG_GPIO_PCF857X is not set
and maybe line 2084:

Code: Select all

# CONFIG_INPUT_GPIO is not set
For working the alphanumeric LCD HD44780.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 1:37 am
by wrxtasy
Ok Cheers, that will have to be for a test version tomorrow, in the meantime.....

I believe the C2 does output 32bpp Color, so updated the Kernel today including this interesting patch:
https://github.com/hardkernel/linux/com ... e2cbbcf0ae

I not sure but the color ouput may look more saturated.
Went delving into Koying's old 3D MVC Archives today and plugged that in as well, ISO's supported. Appears to be working when looking at the logs.
No 3D TV to test tho. Outputs as Top/Bottom, Half Resolution if I'm not mistaken.

Fixed up 3D scaling in 2160p mode as well.

MySQL users will be happy as an old Davilla aka MrMC aka Sly Ol' Fox patch went in to drag configuration in from the dark ages from using the advancedsettings.xml file to configuration using the much friendlier Kodi GUI (found under Services). :)

LibreELEC-Odroid_C2.aarch64-7.0.1.3D.MVC.ISO.tar

W. :)

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 4:23 am
by joostrm
Hi
I'm using LE on a C2 and it's working gret. I compared with a PI, and with Android and Ubuntu on the C2. But clearly this OS is the best by far. Thanks for all the work.
The only thing I miss is use of the GPIO-pins. Looking in the Kernel-config referenced above I've found this:

Code: Select all

#
# Pin controllers
#
CONFIG_PINMUX=y
CONFIG_PINCONF=y
# CONFIG_DEBUG_PINCTRL is not set
# CONFIG_PINCTRL_CAPRI is not set
# CONFIG_PINCTRL_MSM8X74 is not set
# CONFIG_PINCTRL_SINGLE is not set
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_ARCH_REQUIRE_GPIOLIB=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_DEVRES=y
CONFIG_OF_GPIO=y
# CONFIG_DEBUG_GPIO is not set
CONFIG_GPIO_SYSFS=y

#
# Memory mapped GPIO drivers:
#
# CONFIG_GPIO_GENERIC_PLATFORM is not set
# CONFIG_GPIO_PL061 is not set
# CONFIG_GPIO_SCH311X is not set
# CONFIG_GPIO_TS5500 is not set
# CONFIG_GPIO_GRGPIO is not set
Does it mean GPIO is supported? If yes, how can I use them? On the PI I use RPi.GPIO to be able to run scripts. Is there something similar available or planned for the C2 in LE? That's the only thing I miss to make it available for my wife and kids. For them I need a 1-button power on/off for the complete chain: Kodi-Receiver-TV-remote.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 6:49 am
by jurand
Raybuntu wrote: It's not unlikely to be a temp problem. What I can see in your log is that the problem starts when an interrupt has a timeout after that your TX is stuck in a busy state. Could be a hardware issue or a timing issue in the chip. Keep testing. If it happens again just give me the log and I see what I can change.
Now I got CEC deaf without touching a key, but after restart with hot SoC (>70 reported)

http://sprunge.us/QEQe

Edit: What temps do you have when kodi is idle?

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 8:13 am
by infinity85
Marvin27 wrote:Hi. LibreELEC support i2ctools or i2c gpio custom or i2c pcf8574 for LCDproc ?
Not sure whether I can answer your question completely, but I have this OLED I2C display (SSD1311 controller) successfully running on my Odroid C2: http://www.ebay.com/itm/IIC-I2C-2004-20 ... 1877058866

But I had to compile the driver (modified HD44780 driver to suit the SSD1311 controller) on the Odroid C2. The Raspberry Pi 2 driver did not work.

After linking to the compiled driver (modified HD44780 driver) and choosing it in LibreELEC configuration tab, I installed LCDproc out of the standard repository and it displays everything fine and also dims and so on as specified in the LCDproc addon settings. May be this info helps you somehow.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 12:43 pm
by wrxtasy
@Everyone,
Its impossible to do Kodi development work AND provide specific Hardware and Kernel support for the C2 when developers does not even have the required Hardware. This is HardKernel's job.

Users need to do investigations on their own and ask questions over in other C2 Subforums and then come back with Exact specific modules that may need adding. I have no Idea what Hardware is actually supported as Hardkernel do not regularly publish a list of what drivers are added disappointingly. No idea either what most of the modules in the Kernel even support :(
We are all stumbling around in the dark.

LibreELEC is NOT a full blown Ubuntu OS, a lot has been pulled out to make it run as fast as possible. C2 ARM64 is very new for both LibreELEC and Kodi. The RPi3 by comparison is still running a 32bit OS and the regular old drivers.

GPIO IR, I2C_GPIO has the module enabled and is already working, the config and conversation starts from this Post onwards:
http://forum.odroid.com/viewtopic.php?f ... 50#p143360

@Marvin27 , Yes I can enable those modules in the next test version I put out. That would be where my support stops however.
A whole new thread just based on GPIO Mods Itself would be a VERY good idea for you guys to swap ideas in.

In fact I'm going to start a companion LE DIY Hardware thread (unsupported) just to list working Hardware compatible with LE as this thread is too large and unwieldy to track working setups.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 3:56 pm
by jurand
Looking for build howto for C2.
Should I use PROJECT=Odroid_C2 ARCH=aarch64 ?
https://wiki.libreelec.tv/index.php?title=Compile does not cover this.

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Posted: Mon May 30, 2016 4:02 pm
by Raybuntu
jurand wrote:
Raybuntu wrote: It's not unlikely to be a temp problem. What I can see in your log is that the problem starts when an interrupt has a timeout after that your TX is stuck in a busy state. Could be a hardware issue or a timing issue in the chip. Keep testing. If it happens again just give me the log and I see what I can change.
Now I got CEC deaf without touching a key, but after restart with hot SoC (>70 reported)

http://sprunge.us/QEQe

Edit: What temps do you have when kodi is idle?
I've no more idea's to be honest. Could be a hardware issue. I've to talk to HK about your problem. It's working fine for you and happening after a while right?
I'm also seeing this:

Code: Select all

cec_ll_rx(): CEC: rx msg len: 13   dat: 01 01 01 01 01 01 01 01 01 01 01 01 01
Either your TV is sending a really really bad message (that doesn't exist) or there is a bug in the chip or your board is faulty.