LibreELEC 7.0.2 - Kodi Jarvis 16.1 - Archived - LE Tips HERE

Moderators: mdrjr, odroid, Raybuntu, wrxtasy

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Apr 20, 2016 11:14 pm

archa wrote:what I have:
- ODROID-C2
- IconBIT XDS1003D (Realtek RTD1186DD)
- AVR Pioneer VSX-528
- TV Sony 55W807

All devices connect like this: ODROID to BD input AVR, IconBIT to DVR input AVR, AVR output to TV ark input. All the devices support CEC. When i connect ODROID with libCEC all devices stop working with CEC, when i disconnect ODROID, IconBIT - AVR - TV works perfect with CEC. While we had the HK kernel cec driver, all devices worked perfect.

On the C1, any ARC HDMI cables or ones with Ethernet channels in them caused problems with HDMI and CEC.
Use a regular non ARC cable from the AVR to a non-ARC HDMI connector on the TV.
Remove any ARC related stuff from the HDMI chain completely and retest.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Thu Apr 21, 2016 3:11 am

@archa: I think I found the bug. TX_BUSY was not handled right by the kernel driver. I don't have a AVR so I can't test it.

https://github.com/Raybuntu/linux/tree/c2_new_cec_driver

That's still work in progress and I'm not sure if I can work that bug out without someone to test it.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby mentin » Thu Apr 21, 2016 5:21 am

Raybuntu wrote:Looks like you're trying to access it before the cec node is even initialized. Probably while your TV is off it can't check if CEC is supported and since it does not have any hdmi it can't initialize cec. Same problem probably existed with the original cec driver I guess. What is your TV brand?
Does it work if you turn on your TV then power on your odroid?


Can you attach the whole dmesg output not just the grep?



Here ist the dmesg log #### CEC NOT WORKING ####

Constellation: Just Odroid via HDMI to LG NO AVR
Attachments
dmesg.txt
(136.8 KiB) Downloaded 72 times
mentin
 
Posts: 7
Joined: Sat Mar 12, 2016 5:06 am
languages_spoken: english, german
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Thu Apr 21, 2016 5:50 am

Looks intressting mentin. That helps alot i hope i can fix it tomorrow.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby archa » Thu Apr 21, 2016 4:11 pm

Raybuntu wrote:@archa: I think I found the bug. TX_BUSY was not handled right by the kernel driver. I don't have a AVR so I can't test it.

https://github.com/Raybuntu/linux/tree/c2_new_cec_driver

That's still work in progress and I'm not sure if I can work that bug out without someone to test it.

I'm ready to test all what will need
archa
 
Posts: 15
Joined: Sat Apr 16, 2016 3:31 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby gdachs » Thu Apr 21, 2016 5:34 pm

Raybuntu wrote:@archa: I think I found the bug. TX_BUSY was not handled right by the kernel driver. I don't have a AVR so I can't test it.

https://github.com/Raybuntu/linux/tree/c2_new_cec_driver

That's still work in progress and I'm not sure if I can work that bug out without someone to test it.

That is an ugly piece of code I left out, because it seemed not necessary and I am not sure that it will work with both wetek play and core. Maybe I have time to try it this evening.
I have an AVR, but I don't have the problem, so I only can test whether the change will break something that was working before.

Gerald
gdachs
 
Posts: 46
Joined: Fri Dec 26, 2014 7:58 am
languages_spoken: english, german
ODROIDs: Odroid-C1 hopefully soon

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Thu Apr 21, 2016 10:49 pm

I'm not sure if that's even the problem. From the logs it starts to fail when the TX get's busy so I assumed there is something wrong with that. Even with the change it works for me.

Also very interesting is that I have a different value for P_AO_RTI_PIN_MUX_REG than you @archa and @mentin.

Code: Select all
amlogic_cec_open(): P_AO_RTI_PIN_MUX_REG:2013370369


I have something like 103xxx (don't remember).
@wrxtasy I assume you haven't changed the dts file from HK?

@archa and @mentin did you change your dtb file somehow?

Can we collect some P_AO_RTI_PIN_MUX_REG values from people without any problems? Maybe pin mux is failing. I've just copied the code from the original platform driver.

EDIT I checked my old logs. While I was porting Gerald's driver I had the same P_AO_RTI_PIN_MUX_REG value when I haven't implemented Pin Ctrl. My value is 104449.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Pienoet » Fri Apr 22, 2016 2:21 am

Raybuntu wrote:Can we collect some P_AO_RTI_PIN_MUX_REG values from people without any problems? Maybe pin mux is failing. I've just copied the code from the original platform driver.


Sure i would like to help..

how do i get my P_AO_RTI_PIN_MUX_REG values?
Pienoet
 
Posts: 375
Joined: Sun May 10, 2015 10:04 pm
languages_spoken: english Dutch

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby gdachs » Fri Apr 22, 2016 3:30 am

Pienoet wrote:how do i get my P_AO_RTI_PIN_MUX_REG values?

Code: Select all
journalctl | grep P_AO_RTI_PIN_MUX_REG


Gerald
gdachs
 
Posts: 46
Joined: Fri Dec 26, 2014 7:58 am
languages_spoken: english, german
ODROIDs: Odroid-C1 hopefully soon

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Fri Apr 22, 2016 3:41 am

But wrxstasy disabled amlogic_cec_debug_flag so you need to enable it and then start cec-client:

run as root not sudo:
Code: Select all
echo 1 > /sys/devices/virtual/amhdmitx/amhdmitx0/amlogic_cec_debug_config
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Fri Apr 22, 2016 4:21 am

@ Raybuntu dts file is unchanged from HK sources.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Fri Apr 22, 2016 3:28 pm

I had a long talk with gdachs and we are not going to use that TX_BUSY code and it won't work anyway. So please do not use that code yet.
At the moment I think that pinctrl is failing for some of you guys but I can't explain why since the code is the same as with the old cec driver.
I hate the kind of error's I can't reproduce. I'll have to study your complete dmesg logs.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby MeNext » Sat Apr 23, 2016 5:37 am

Hi guys great job.

I have 2 issues one that is annoying and one that is just not workable.

I have a C2, HDHomerun and MythTV.

MythTV with a Raspberry PI works great. With my C2 and LibreELEC devel-20160415140342-r1 I have regular caching pauses on playback of live TV. Pausing for a couple of seconds and playing makes it all go away. Playing recorded shows has absolutely no issues.

The other issue is the NIC gets disabled when powered down. I need to swap out my SD card for Ubuntu in order for LibreELEC to see it again. I am not sure if I have the latest image. I tried LibreELEC-Odroid_C2.aarch64-6.95.6.Ethernet.img but that doesn't help and adds a sound problem.
MeNext
 
Posts: 11
Joined: Mon Mar 21, 2016 2:43 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sat Apr 23, 2016 6:16 am

Tweak advanced settings:
http://kodi.wiki/view/Advancedsettings.xml
http://kodi.wiki/view/HOW-TO:Modify_the_video_cache

This is mine for Live TV, placed in directory /storage/.kodi/userdata/
Code: Select all
<advancedsettings>
     <network>
       <buffermode>1</buffermode>
       <cachemembuffersize>157286400</cachemembuffersize>
       <readbufferfactor>20</readbufferfactor>
     </network>
     <pvr>
        <minvideocachelevel>10</minvideocachelevel>
        <minaudiocachelevel>15</minaudiocachelevel>
     </pvr>
</advancedsettings>
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Sat Apr 23, 2016 6:45 pm

JFYI:
I currently have two C2s at home, both used with mSD card. One of them works just fine, including Ethernet connection. The second doesn't see Ethernet at all (tried both initial version from the 1-st post and the last one) while the network works ok under Android. Probably the different hardware versions, in spite of the fact both devices were bought at once.
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sun Apr 24, 2016 4:38 pm

Yes I and others have seen this. I don't know if its a HardKernel Kernel issue itself with the MMC code or a C2 SD card reader Hardware issue I have.
I'm basically unable to test Ethernet with SD cards as all Android, Linux and LibreELEC images are unusable with SD cards on the Developer board I have. :(

eMMC Flash works fine here - Android and Linux. No crashes, I get Ethernet activity and LibreELEC Reboots properly.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby crashoverride » Sun Apr 24, 2016 5:22 pm

wrxtasy wrote:I don't know if its a HardKernel Kernel issue itself with the MMC code or a C2 SD card reader Hardware issue I have.

Please post an explicit link to an image that is up to date and will not change so that its frozen for testing purposes and guaranteed to be the same for everyone testing. I will download the image and write it to a SD card to see if I can reproduce the issue.

[Edit]
I downloaded and installed the image linked of the first page to a SD card and did not experience any SD card issues. I verified with a SSH session and "dmesg" there were no errors. Additionally, I unplugged and re-plugged ethernet without any issue verified by ping and streaming test video. I did experience issues with starting the board without ethernet and then later connecting it; however, this appears to be an OpenELEC issue since the board was able to obtain an IP address via DHCP.
crashoverride
 
Posts: 3104
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Sun Apr 24, 2016 6:35 pm

@crashoverride
That means you've the "right" board, that's it.
As I stated, I have two with different behavior. One works just fine, on the other the Ethernet looks as if it's dead (no connection indication, no LED blinking, nothing -- as if the cable was absent). I thought the phy was dead but reinstalled Android and got the network working. I believe the kernel are different in ELEC and android... and on some board revision only android's is operational.
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sun Apr 24, 2016 6:42 pm

Cheers Crash, thanks for testing, thats the .img I have issues with on all SD cards as well. In fact all .img's for me.
Let LibreELEC run a bit longer and play around with the settings so data is actually written to the SD card, this is where I run into R/W problems.
Also have a good look via dmesg at the Kernel Log for any obvious errors.

Code: Select all
ssh root @ip.address.of.c2
Password - libreelec or just le

Can you connect via SMB now and throw the following .tar into the Update folder and see if Ethernet connectivity improves with a SD card, especially after a Reboot pls.

LibreELEC-Odroid_C2_aarch64-6.95.6-Ethernet.tar

EDIT: The other suggestion I have for Ethernet connectivity is to go into LibreELEC settings and Find the option 'Wait for Network Connectivity before starting Kodi" and enable that, then reboot.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby crashoverride » Sun Apr 24, 2016 8:26 pm

I connected via SMB (Samba) and transferred a 3GB media file to the SD card "Video" folder. There were no errors during transfer and no errors reported in "dmesg" via SSH.

My current hypothesis regarding this issue is that its caused by the "resize" script that is run at first boot. Improper/invalid partition data would explain the symptoms and account for the anomalies due to different kernel patches causing size changes and therefore layout changes on the filesystem resulting in different symptoms (this was seen in past Archlinux images). CHS and LBA information differs between storage devices, so the SD cards with the problem may be reporting an unexpected geometry that the eMMC does not. For example, the .img file may have geometry assumptions that becomes invalid on a SD card. Since I can not reproduce the issue, someone else will need to take a SD card that presents the issue and inspect its partition and filesystem data. Particularly, the starting offsets need to be checked that they do not collide with the uboot variable area or have not become aligned on different sector size boundaries.
crashoverride
 
Posts: 3104
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sun Apr 24, 2016 10:55 pm

Sounds plausibile but I get the exact same R/W errors flashing an HardKernel supplied Android v1.3 image with three different SD cards that are know to work.
I also seem to be the only one with this problem, so strongly suspect a SD reader Hardware problem.
Thanks for testing.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby blackride » Tue Apr 26, 2016 11:08 am

ultra-precise clocks and online time when power is turned off for Raspberry Pi2
Image

http://ru.aliexpress.com/item/DS3231-Memory-Module-Precision-RTC-Module-for-Raspberry-Pi-NEW/32527452983.html?spm=2114.30010708.3.10.xbDILf&ws_ab_test=searchweb201556_7,searchweb201602_4_10034_507_10032_508_10020_10017_10005_10006_10021_10022_10009_10008_10018_10019,searchweb201603_6&btsid=6052c4f7-35b7-4d53-ace1-967814cdcfa1

Go to ssh with, for example, Putty:

Code: Select all
mount -o remount,rw /flash
nano /flash/config.txt


at the end of file add:
Code: Select all
dtoverlay=i2c-rtc,ds3231


Code: Select all
mount -o remount,ro /flash
reboot


Check through off, catering and consumer off. Power ON
If the time is shifted by time zone, go to the console through, for example, the Putty:
Code: Select all
hwclock -l

And Reboot.

For raspberri pi 2 it works.
What must change for our odroid?
1, 3, 5, 7, 9 pins identical rapberry pi 2.

I can not trying because only yesterday ordered an odroid c2.
- mount -o remount,rw /flash - is it true name "flash" partition in odroid?
- nano /flash/config.txt - what is name config file in odroid?

Thank you

Upd. Find theme viewtopic.php?f=139&t=20001&p=137874#p137874
How to make for openelec?
Oroid C2/LibreELEC 7
User avatar
blackride
 
Posts: 49
Joined: Thu Feb 11, 2016 2:32 am
languages_spoken: english & russian
ODROIDs: Odroid C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby seba1970 » Tue Apr 26, 2016 4:06 pm

is it possible to create dual boot configuration android on emmc and LibreELEC on microsd ??? selectable OS without removing emmc module each time i want to run LibreELEC?
seba1970
 
Posts: 8
Joined: Sat Apr 02, 2016 4:20 pm
languages_spoken: english
ODROIDs: odroid C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby crossover » Tue Apr 26, 2016 5:20 pm

@blackride
I really hope wrxtasy will open his Github soon to make a custom kernel.
crossover
 
Posts: 106
Joined: Wed Jul 22, 2015 2:23 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, USB-IO, Tinkering kits

SD Card and Ethernet...

Unread postby maxodoble » Tue Apr 26, 2016 6:51 pm

For me, the only version working is the first Image, that wrxtsy posted:
https://mega.nz/#!P8snmY5I!5UInRfS19rFV ... HAe4xoJ_Ns

As soon as i update (or make a fresh image install) to a later Version (even the one labeled "Ethernet"), i get no Ethernet whatsoever. No Led Blinking. Ethernet seems dead. No poweroff poweron sequence or changing ethernet ports changes the "dead ethernet".

When i reflash the first version (the one without working Refreshrate-Changes): Ethernet is alive and well an working reliably.

So -for my symptoms- this definitely doesn't sound like a hardware problem, but some bug(s) triggering a failing or better nonexistant ethernet connection. the bugs seem to be brought in with the changes AFTER the first posted LIbreelec Version.

Cheers,
Max
maxodoble
 
Posts: 17
Joined: Wed Jul 30, 2014 5:41 pm
languages_spoken: english

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Wed Apr 27, 2016 3:00 pm

It looks to me much like a race condition or something like that, rather than a 'bug'. This could explain why different instances behave differently: some part's speed may slightly differ causing not being in time with h/w init or whatever.
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby daggs » Wed Apr 27, 2016 3:35 pm

Greetings,

a question, does the code of this LE flavor can be viewed somewhere?

UPDATE:
to answer myself, https://github.com/lrusak/LibreELEC.tv/ ... -odroid-c2 correct?
daggs
 
Posts: 196
Joined: Tue Mar 22, 2016 6:34 pm
languages_spoken: english, spanish
ODROIDs: odroid c2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Apr 28, 2016 2:35 am

Update
LibreELEC 7.0.0 Kodi Jarvis 16.1 Final is up on Page #1 :)
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Dez » Thu Apr 28, 2016 3:42 am

Great!! Thanks.

I'll try it out when I get home tonight.
Dez
 
Posts: 30
Joined: Sat Mar 12, 2016 9:17 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby daggs » Thu Apr 28, 2016 4:13 am

I'm trying to build libreelec from the link below but it seems to fail donwloading opengl-mason.

any ideas where I can find it?
daggs
 
Posts: 196
Joined: Tue Mar 22, 2016 6:34 pm
languages_spoken: english, spanish
ODROIDs: odroid c2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby ecab21 » Thu Apr 28, 2016 9:54 am

wrxtasy wrote:Update
LibreELEC 7.0.0 Kodi Jarvis 16.1 Final is up on Page #1 :)

Thanks for the image, but for me the problems continue.
Passthrough DTS and DD work, but with droupouts every few seconds.
DTS-HD, Dolby True doesn't work, even when activate on the menu.
HDMI-CEC doesn't work on my LG TV.

I'm starting to wonder if the passthrough problem is a software issue or a hardware issue.
ecab21
 
Posts: 83
Joined: Sat Apr 02, 2016 12:49 am
languages_spoken: english, portuguese
ODROIDs: Odroid C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Veube » Thu Apr 28, 2016 5:17 pm

ecab21 wrote:I'm starting to wonder if the passthrough problem is a software issue or a hardware issue.


DTS and DD passthrough can be forced to work with HK's official Android software, so the hardware CAN do it. The same workaround doesn't work for Linux, so we just need to work out which of the differences between the Android and Linux kernel enable the workaround. From there it should be straight forward to fix the problem.
Veube
 
Posts: 14
Joined: Tue Mar 08, 2016 12:35 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Thu Apr 28, 2016 5:45 pm

wrxtasy wrote:Update
LibreELEC 7.0.0 Kodi Jarvis 16.1 Final is up on Page #1 :)

Still no Ethernet...
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Apr 28, 2016 7:30 pm

Confirming this is with a SD card only ?
Are these both the same mSD cards ?

And have you selected in LibreELEC settings, the "Wait for Network before starting Kodi" option ?
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Dez » Thu Apr 28, 2016 7:41 pm

I have no problems with ethernet (using eMMC).

Just cannot access the TVheadend webpage (4.0 or 4.2) after installing from the LE repository.
This is after first uninstalling any other version before installing.

No problems accessing the Kodi webpage (8080).

EDIT: Manually loaded earlier versions of backend and client and now working fine again.

Seems the versions at the LE repository don't seem to work for some reason.
Does anyone else have this problem?
Last edited by Dez on Thu Apr 28, 2016 8:02 pm, edited 2 times in total.
Dez
 
Posts: 30
Joined: Sat Mar 12, 2016 9:17 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby maxodoble » Thu Apr 28, 2016 7:47 pm

wrxtasy wrote:Confirming this is with a SD card only ?
Are these both the same mSD cards ?

And have you selected in LibreELEC settings, the "Wait for Network before starting Kodi" option ?


Same thing for me: Ethernet: dead. Using SD Card only.

* Had a working version (the first one you posted).
* Then updated to 7.0
* After update at first ethernet worked.
* Then shut down the c2, moved to another room.
* Turn on c2: Ethernet is dead: no LED Activitity on Eth Port visible.
(Ethernet port at switch in new room tested with another device: working without problems).
* Going back to first room: turn on c2: Ethernet also dead in the water :-(

Wait for Network: activated.

Cheers,
Max
maxodoble
 
Posts: 17
Joined: Wed Jul 30, 2014 5:41 pm
languages_spoken: english

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Apr 28, 2016 8:28 pm

Dez wrote:I have no problems with ethernet (using eMMC).

Just cannot access the TVheadend webpage (4.0 or 4.2) after installing from the LE repository.
This is after first uninstalling any other version before installing.

No problems accessing the Kodi webpage (8080).

EDIT: Manually loaded earlier versions of backend and client and now working fine again.

Seems the versions at the LE repository don't seem to work for some reason.
Does anyone else have this problem?

I tried to cheat a bit with the Repo and its not working by the looks of it !
Here is v4.2 of the TvHeadend Server:
https://dl.dropboxusercontent.com/u/276 ... .0.102.zip

And v4.09:
https://dl.dropboxusercontent.com/u/276 ... .0.101.zip

I may have to withdraw the LibreELEC Repo if its not working properly.

-----------------------------------------------------------

Also I've Reverted all HardKernel Odroid C2 custom audio usb-spdif and HiFi Shield additions from the Kernel and also pulled out Oversuns Kodi Audio patches for the regular AML ones, here is a test Kodi Jarvis Final version with Alternate Audio:
LibreELEC-Odroid_C2_aarch64-7.0.0-Kodi-Jarvis-Final.Alternate.Audio.tar
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Thu Apr 28, 2016 8:42 pm

wrxtasy wrote:Confirming this is with a SD card only ?
Are these both the same mSD cards ?

And have you selected in LibreELEC settings, the "Wait for Network before starting Kodi" option ?

Yes, yes... and yes. I don't have eMMC so I can't check this option. Probably I shall buy one with the next order...
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Apr 28, 2016 9:54 pm

Reverted lrusak's U-Boot patch, so those with Ethernet bootup issues please test this version:

LibreELEC-Odroid_C2_aarch64-7.0.0-Kodi-Jarvis-Final.Revert.U-Boot.patch.tar
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby cert_ » Thu Apr 28, 2016 10:26 pm

Can i play back 720p/1080i/1080p videos in 2160p display mode?
cert_
 
Posts: 21
Joined: Sun Mar 20, 2016 9:16 pm
languages_spoken: english

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Apr 28, 2016 10:49 pm

Yes
480i/576i/720p/1080p/1080i resolutions, up-scale, play and Refresh Switch properly to 2160p @ 24/25/30/50/60Hz, and play smoothly on my TV :)

The one minor annoyance is you need to select 2160p in Kodi settings first as currently the C2 will not autoswitch the TV's Resolution from 1080p<--> 2160p.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Fri Apr 29, 2016 12:46 am

@wrxtasy
Yeah, the network is back! But no localization now -- English is the only option :)

UPD: However the language is installable via Add-ons -> install from repository.
UPD2: ...but it picks up wrong time/date (-27hr (?!)) unless the ntp server is set.
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby mentin » Fri Apr 29, 2016 1:22 am

ecab21 wrote:
wrxtasy wrote:Update
LibreELEC 7.0.0 Kodi Jarvis 16.1 Final is up on Page #1 :)

Thanks for the image, but for me the problems continue.
Passthrough DTS and DD work, but with droupouts every few seconds.
DTS-HD, Dolby True doesn't work, even when activate on the menu.
HDMI-CEC doesn't work on my LG TV.

I'm starting to wonder if the passthrough problem is a software issue or a hardware issue.


Installed the new final version
CEC still dont work :´( with first version it works good

Edit: Sometimes when CEC works i press down and he goes back. If I press back its going left, this is the oddest I ever seen :D
Last edited by mentin on Fri Apr 29, 2016 4:51 am, edited 1 time in total.
mentin
 
Posts: 7
Joined: Sat Mar 12, 2016 5:06 am
languages_spoken: english, german
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby kanyck » Fri Apr 29, 2016 1:32 am

For me CEC works on every release I tried but on my set (Panaconic 50st30) it often doubles the keystrokes, which is very annoying. I wander if there is a way to adjust CEC timing somehow? (I've probably seen how-to for the usb remote somewhere but unfortunately can't recall where and not sure it's applicable to CEC)
Oh! And now I gave a C2 to a friend with st50 Panasonic and he's complaining that the lover block (start stop rewind ff next previous) works occasionally while navigation keys are rock solid. I may look into logs when I'm there to see if there is some error messages.
kanyck
 
Posts: 28
Joined: Fri Mar 04, 2016 5:49 pm
languages_spoken: english russian
ODROIDs: ODROID C1+ C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby maxodoble » Fri Apr 29, 2016 3:30 am

wrxtasy wrote:Reverted lrusak's U-Boot patch, so those with Ethernet bootup issues please test this version:

LibreELEC-Odroid_C2_aarch64-7.0.0-Kodi-Jarvis-Final.Revert.U-Boot.patch.tar


Yes, Yes, Yes!!! :-)
With this version ethernet is working for me too.

Thanks for this beautiful LibreElec Build, i am truly impressed by the quality (overall stability and video-quality is superb) of LibreElec on the C2.

Cheers,
Max
maxodoble
 
Posts: 17
Joined: Wed Jul 30, 2014 5:41 pm
languages_spoken: english

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby dblade » Fri Apr 29, 2016 3:52 am

Can anyone assist on an audio issue?
viewtopic.php?f=138&t=20841
dblade
 
Posts: 38
Joined: Tue Jan 26, 2016 9:05 am
languages_spoken: english
ODROIDs: C1+

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Raybuntu » Fri Apr 29, 2016 4:12 am

kanyck wrote:For me CEC works on every release I tried but on my set (Panaconic 50st30) it often doubles the keystrokes, which is very annoying. I wander if there is a way to adjust CEC timing somehow? (I've probably seen how-to for the usb remote somewhere but unfortunately can't recall where and not sure it's applicable to CEC)
Oh! And now I gave a C2 to a friend with st50 Panasonic and he's complaining that the lover block (start stop rewind ff next previous) works occasionally while navigation keys are rock solid. I may look into logs when I'm there to see if there is some error messages.


have a look at my post:
http://forum.odroid.com/viewtopic.php?f=138&t=20415&start=100#p136605
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1203
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Fri Apr 29, 2016 4:55 am

dblade wrote:Can anyone assist on an audio issue?
viewtopic.php?f=138&t=20841

I would ask HardKernel themselves if support is actually in the Kernel for this device.

Be aware, the version of LibreELEC I'm distributing, especially the last few test versions has had HardKernels USB-S/PDIF and HiFi Shield modifications pulled back out of the C2 Kernel itself.

Why, well its the only way to get Dolby Digital and DTS to passthrough over HDMI without dropouts.
Noggin has now confirmed DD/DTS is working properly over here:
http://forum.kodi.tv/showthread.php?tid ... pid2323150
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby Veube » Fri Apr 29, 2016 6:07 am

wrxtasy wrote:Why, well its the only way to get Dolby Digital and DTS to passthrough over HDMI without dropouts.
Noggin has now confirmed DD/DTS is working properly over here:
http://forum.kodi.tv/showthread.php?tid ... pid2323150


Genius! Thanks wrxtasy!

So far DD and DTS working here without dropouts using the alternate audio update. I'd all but given up on it ever working properly.
Veube
 
Posts: 14
Joined: Tue Mar 08, 2016 12:35 am
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.0 - Kodi Jarvis 16.1

Unread postby wrxtasy » Fri Apr 29, 2016 6:11 am

I suspected those HK Audio mods were the cause all along. I bet if I do the same Reverts to the C1 Kernel I will get similar results.
I cannot test here but would be interested to know if any 7.1 Audio Passthrough is working ?
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

PreviousNext

Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 3 guests