Black screen for 1-2 seconds when stopping video

Post Reply
KnightAzul
Posts: 5
Joined: Sun Sep 22, 2019 5:44 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Black screen for 1-2 seconds when stopping video

Unread post by KnightAzul » Sun Sep 22, 2019 5:55 pm

Hi,

Just installed CoreELEC 9.2.0 on my Odroid C2. It is a vanilla install with no add-ons and using the default Estuary skin.
I have noticed that there is a bit of a delay when stopping a video and getting back to the Videos Wide list view. The screen goes black for 1-2 seconds.I have tried with many different types of videos (from HD to 4K, HEVC, H264, etc.) and it always seems to happen.
The Odroid C2 is connected to a NAS with SAMBA share for the videos. The display output video resolution is set to 1280x720p in Kodi.

I never had this delay on LibreELEC 8.2.5 on my RPI with exactly the same setup, and the RPI has worse hardware specs.

Is this normal?

Thanks for any help!
KnightAzul

butmonkeh
Posts: 14
Joined: Sun Oct 01, 2017 8:13 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by butmonkeh » Sun Sep 22, 2019 11:53 pm

Yes & No, is my answer!

Where my odroid is setup now (with CoreElec latest build) on a recent-ish Sony TV, there is the same 1-2 second gap when starting and stopping playback. I'm guessing this is either a resolution change, or similar. We recently took it to our boat and had it setup there, on a fairly old 12v LCD TV, it showed the same changing behaviour, but was within a second. Kodi is set to native output on both TV's (1920x1080)

I've never used old builds of CoreElec, as I used to use the full Ubuntu image. So i'd say that yes it's normal, but the length of pause you get is dependant on your TV. Kodi running on Ubuntu didn't have this issue, but did have screen tearing issues and various stability problems. CoreElec is much smoother in playback, but yes, there's a pause going to video from menus and back.

Hope that helps.

User avatar
cdu13a
Posts: 186
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by cdu13a » Mon Sep 23, 2019 3:01 am

@KnightAzul

It's very likely that it is a refresh rate / video mode change that this is the cause of the 1-2 second black screen. Most TV's can't instantly change their settings so this results in a short duration black screen while the mode is changed.

So this should be considered normal behavior.

The difference between LibreELEC on the RPI and CoreELEC on the C2 that you noted, is that CoreELEC defaults to having "set display refresh rate" enabled on start/stop. If this bothers you it's possible to turn off this feature (look in Settings/Player/Video for "set display refresh rate") However disabling it can result in video playback not being as smooth, which is why it's the default to have it enabled.

KnightAzul
Posts: 5
Joined: Sun Sep 22, 2019 5:44 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by KnightAzul » Sat Sep 28, 2019 2:56 am

Thanks for the replies!

I had actually set the "set display refresh rate" to off and the display output video resolution is set to 1280x720p @50Hz, and I still get that delay. The TV is 720p native (...and no I don't live in a cave! :D :D ) and according to these settings should not be changing its refresh rate / video mode.

Not the end of the world, just was curious to know why this might the case with the Odroid on CoreELEC 9.2.0 and it doesn't happen with the RPI on LibreELEC 8.2.5.

KnightAzul

User avatar
rooted
Posts: 6675
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 138 times
Been thanked: 33 times
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by rooted » Sun Sep 29, 2019 7:20 pm

Is your display actually native 1366x768, most 720p TV's are.

KnightAzul
Posts: 5
Joined: Sun Sep 22, 2019 5:44 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by KnightAzul » Mon Sep 30, 2019 12:18 am

True, technically it is native 1366x768. You are right.
But with CoreELEC "set display refresh rate" set to off and the display output video resolution is set to 1280x720p @50Hz, there shouldn't be any display mode changing. It seems to be worse on some videos than others.
RPI with LibreELEC and same settings didn't exhibit this behaviour with the same videos.

KnightAzul

User avatar
rooted
Posts: 6675
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 138 times
Been thanked: 33 times
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by rooted » Mon Sep 30, 2019 4:04 am

It was just an idea to set the resolution as 1366x768 and see if anything changes.

User avatar
cdu13a
Posts: 186
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by cdu13a » Mon Sep 30, 2019 10:13 am

Just a minor note, you can't really directly compare the behavior of LibreELEC 8.2.5 and CoreELEC 9.2.0 since different major versions of kodi. LibreELEC 8.2.5 was Krypton and CoreELEC 9.2.0 is Leia. There was a lot of changes between the two that could effect the behavior in this situation.

@KnightAzul if you ssh into the device and run the dispinfo utility once before playback and once during playback it help provide some insight into what is happening. dispinfo is a debugging tool in CoreELEC that collects all the current display info and posts them on a pastebin sight for easy posting/viewing of the information collected,

KnightAzul
Posts: 5
Joined: Sun Sep 22, 2019 5:44 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by KnightAzul » Wed Oct 02, 2019 12:10 am

@cdu13a Just to check, if I run the dispinfo utility first and then again a few minutes later should the information on the pastebin site get immediately updated? I say this as the output doesn't seem to include any log time and date. It looks like the dispinfo output was exactly the same before playback and during playback and also the utility gave the same URL both times. Just wanted to check before posting the outputs.

Thanks,
KnightAzul

User avatar
cdu13a
Posts: 186
Joined: Tue Jan 20, 2015 3:33 pm
languages_spoken: english
ODROIDs: C1, C2, XU4, HC1, N2
Has thanked: 0
Been thanked: 11 times
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by cdu13a » Wed Oct 02, 2019 2:58 am

If there is no change in the output then the pastebin site will think you are pushing same file and just point you at the existing file. so you end up with same url.
This isn't really a problem since you can tell immediately by getting the same url that nothing changed, and that the output was identical.

KnightAzul
Posts: 5
Joined: Sun Sep 22, 2019 5:44 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Black screen for 1-2 seconds when stopping video

Unread post by KnightAzul » Wed Oct 02, 2019 6:01 pm

Ok, thanks for the information. Looks like it's not the changing of the video mode then.
Will keep digging around and see if I can nail it down to something.

KnightAzul

Post Reply

Return to “CoreELEC/LibreELEC - Kodi Project for C1/C2”

Who is online

Users browsing this forum: No registered users and 3 guests