Usb DAC audio issue (crackling, pops, clicks)

Moderators: mdrjr, odroid, Raybuntu, wrxtasy

Usb DAC audio issue (crackling, pops, clicks)

Unread postby fdef » Thu Nov 23, 2017 5:29 am

Hi all

I need to known if there are some Libreelec devs here, cause my question is for them.

I use "LibreELEC-Odroid_C2.aarch64-8.2.1.tar" and I have the same issue which is describe here:

- https://forum.odroid.com/viewtopic.php?f=141&t=25434

The kernel patch was availlable here but it seem it's not be import to this last version of Libreelec :-(
- https://github.com/hardkernel/linux/commit/5b39258a76be9cd385ea7b45a8a21e08992eb6e5

I can't play videos without clicks, so I hope anyone can help usb dac audio users ;)

Code: Select all
lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 1: Dev 5, If 1, Class=Audio, Driver=snd-usb-audio, 12M
        |__ Port 1: Dev 5, If 3, Class=Audio, Driver=snd-usb-audio, 12M
        |__ Port 3: Dev 4, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 3: Dev 4, If 1, Class=Wireless, Driver=btusb, 12M


Thx
Attachments
nuforce2.txt
lsusb -v
(9.73 KiB) Downloaded 23 times
fdef
 
Posts: 5
Joined: Thu Nov 23, 2017 4:59 am
languages_spoken: french

Re: Usb DAC audio issue (crackling, pops, clicks)

Unread postby 5kyy » Wed Dec 13, 2017 1:34 am

Hello,

i have also the C2 running with current official LibreElec. I have also Audio Clicks and quick disconnects.

At first i setup in my living room the Odroid and recognized the Audio Issues.
I have http://www.hardkernel.com/main/products/prdt_info.php?g_code=G140081048224 Odroid USB-SPDIF Converter to get an optical digital signal.

Now i tried the same setup in my working room. I use a D-A Signal Converter to get the Optical Digital Signal into Analog Audio and go into my PC Line In.
http://amzn.to/2jBhuqu

The Odroid is in on both setups in a Gigabit LAN.

In the working room connected to the PC Audio there are no clicks or other Audio Issues.
Only in the Living room?

Some Ideas or explanations?
5kyy
 
Posts: 16
Joined: Sun Dec 04, 2016 5:17 pm
languages_spoken: english


Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 3 guests