C2 on boot does strange colors with VU7+

Post Reply
facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

C2 on boot does strange colors with VU7+

Post by facotl »

Hello,
I use an Odroid C2 with a VU7+ screen for a small amount of a product (300 units a year) starting on Q2 2018.

I have a problem, during the first 2 seconds of boot, i have 2 strange colored screens. My client doesn't accept that and wants me to change target if i cannot correct that. Is there any way to fix that please ? Am i alone with this issue ?

I identified that it happend during the first sequence of :

set hdmitx VIC = 16
hdmitx phy setting done
set hdmitx VIC = 16
hdmitx phy setting done

Thank you for your help.



U-Boot 2015.01 (Sep 26 2017 - 00:56:33)

DRAM: 2 GiB
Relocation Offset is: 76f31000
-------------------------------------------------
* Welcome to Hardkernel's ODROID-C2
-------------------------------------------------
CPU : AMLogic S905
S/N : HKC213254DFDE2BB
MAC : 00:1e:06:34:2f:3b
BID : HKC2211703
-------------------------------------------------
register usb cfg[1][0] = 0000000077f95190
register usb cfg[0][1] = 0000000077f951b0
vpu detect type: 5
vpu clk_level = 7
set vpu clk: 666667000Hz, readback: 666660000Hz(0x300)
MMC: aml_priv->desc_buf = 0x0000000073f29d30
aml_priv->desc_buf = 0x0000000073f2bec0
SDIO Port C: 0, SDIO Port B: 1
[mmc_init] mmc init success
In: serial
Out: serial
Err: serial
----------------------------------
MMC Size : 16 GB
----------------------------------
reading boot-logo.bmp.gz
118837 bytes read in 6 ms (18.9 MiB/s)
hpd_state=1
[CANVAS]addr=0x3f800000 width=3840, height=1440

set hdmitx VIC = 16
hdmitx phy setting done
set hdmitx VIC = 16
hdmitx phy setting done
Net: Meson_Ethernet
Hit [Enter] key twice to stop autoboot: 0
reading boot.ini

User avatar
odroid
Site Admin
Posts: 34943
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 959 times
Been thanked: 775 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by odroid »

Which OS image do you use?
What happens if you use a 1080p screen?
Can you share a video about the strange colour issue during the first 2 seconds of boot?

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,
Thank you for your help.
Ubuntu image (ubuntu64-16.04.3-mate-odroid-c2-20170927.img)
I don't have the right cable to test on another 1080p screen, i will try to get one.
Video is at http://leolab-dev.fr/shared/20171211_154842.mp4

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Hi facotl,
I've tried the same issue but I couldn't.
Could you share your boot.ini and your logo image size information? (width and height)

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,
Info, troubles are before (in time) boot ini parse.
Files URL are
http://leolab-dev.fr/shared/boot.ini
http://leolab-dev.fr/shared/boot-logo.bmp.gz

Thank you for your help

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Hi.
Thank you for your feedback.
Let me check it with your environment.

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,
Info. I use an emmc for system.

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,
Did you found Something please ?

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello, i tested on another board / screen couple an i got the same issue. Without any solution I have to leave Odroid solution.

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Really sorry for late response.
I will feedback you in a couple of hours.

This issue is the one that has been already fixed.
I will find a solution.

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

1. strange color issue
I've tried the strange color issue using your boot.ini and logo image
but, I couldn't.
no strange color issue before showing logo image. :(

Did you adjust u-boot code?
I will also think over reason for the difference.

2. logo image is gone during booting
And one more thing, is it ok that the logo image is gone during booting?

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

I found it.
I think you use an external USB power for VU7+, not connecting C2 USB port.
Same issue here.

In my case, I connect the VU7+ USB power to C2 USB port.
Try it, then you can see there is no problem.

And now I will try to remove the strange color when using external USB power.
Let me check it for a couple of hours.

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Hello facotl,
I found it's related to DVI switching issue and adjusted u-boot routine.

Still I need to make a common approach to cover both of hdmi and dvi
but, first I wanna check if the strange color issue is fixed by your side, too.

So, could you help me?
Please find an attachment, c2_test_uboot_vu7+splash.tar.gz.

Copy the file in FAT file system of C2 emmc card ( /media/boot ).
Then extract items and write using dd.

Code: Select all

(copy tar.gz file in /media/boot and boot the C2 system)
# cd /media/boot
# tar xvfz c2_test_uboot_vu7+splash.tar.gz 
# cd ./sd_fuse
# ./sd_fusing.sh /dev/mmcblk0
(reboot)
The u-boot version is

Code: Select all

odroidc2#ver

U-Boot 2015.01-00001-g1dad487-dirty (Dec 17 2017 - 12:01:37)
aarch64-linux-gnu-gcc (crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09) 4.9.2 20140904 (prere
lease)
GNU ld (crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09) 2.24.0.20140829 Linaro 2014.09
If you need more information, please let me know.

(Updated)
And you should modify logoopt section as following.
Add setenv.

Code: Select all

# set logoopt
setenv logoopt "osd1,loaded,0x3f800000,${m}"
Attachments
c2_test_uboot_vu7+splash.tar.gz
(301.98 KiB) Downloaded 125 times

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,

Thank you soo much for your help. It's better.

I have some logo blinks remaining. (please see this video)
http://leolab-dev.fr/shared/20171217_103547.mp4

Bonus question, how to keep the logo when kernel is launched (here screen goes black until my application is launched) ?

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Hello,

Thank you for your feedback.

The blink during an initial stage of kernel loading is caused by kernel hdmi driver initialization.
We can't fix it that is need to adjust the whole display initial process on u-boot and kernel driver. :(
It's a long term job.

And about keeping boot logo, we don't have a better solution so far.
It's related to X start.
Maybe plymouth splash screen setting can be helpful.
I don't have much knowledge about that, so need to check it more.

joy
Posts: 1336
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X
Has thanked: 147 times
Been thanked: 163 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by joy »

Hello,
I found a link we can refer to.
http://www.recantha.co.uk/blog/?p=799

I've adjusted the guide and tried it on ODROID-C2.
Even though it's not perfect, it looks better.

1. install fbi

Code: Select all

# apt-get install fbi
2. copy your logo image into /etc/
3. make "asplashscreen" in /etc/init.d/

Code: Select all

#! /bin/sh
### BEGIN INIT INFO
# Provides:          asplashscreen
# Required-Start:
# Required-Stop:
# Should-Start:      
# Default-Start:     S
# Default-Stop:
# Short-Description: Show custom splashscreen
# Description:       Show custom splashscreen
### END INIT INFO

do_start () {

    echo 0 > /sys/class/graphics/fbcon/cursor_blink
    /usr/bin/fbi -T 1 -noverbose -a /etc/splash.png
    exit 0
}

case "$1" in
  start|"")
    do_start
    ;;
  restart|reload|force-reload)
    echo "Error: argument '$1' not supported" >&2
    exit 3
    ;;
  stop)
    # No-op
    ;;
  status)
    exit 0
    ;;
  *)
    echo "Usage: asplashscreen [start|stop]" >&2
    exit 3
    ;;
esac

Code: Select all

# chmod a+x /etc/init.d/asplashscreen
4. update-rc.d to run the script at startup

Code: Select all

# update-rc.d asplashscreen start 2
I've tried (1) add script command in /etc/rc.local and /etc/init.d/rcS , (2) register [Startup Application] menu,
but all don't work.
Only the method update-rc.d activates boot logo splash.

Still for a couple of seconds, black screen is shown but try it.

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Ok i will try.

Thank you for your help.

facotl
Posts: 51
Joined: Tue Mar 24, 2015 5:06 pm
languages_spoken: english, francais
ODROIDs: C1
Has thanked: 0
Been thanked: 0
Contact:

Re: C2 on boot does strange colors with VU7+

Post by facotl »

Hello,

I migrated to Ubuntu 18 minimal image and i get the colors again. Is fix compatible with this version ?

Thank you

User avatar
odroid
Site Admin
Posts: 34943
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 959 times
Been thanked: 775 times
Contact:

Re: C2 on boot does strange colors with VU7+

Post by odroid »

Try this guide. It worked with 18.04.
https://wiki.odroid.com/odroid-c2/appli ... e_with_vu7

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: Rmiino and 1 guest