mssing libQt6Core.so.6

Post Reply
ngdias
Posts: 4
Joined: Sat Sep 16, 2017 8:39 pm
languages_spoken: english
ODROIDs: c2
Has thanked: 1 time
Been thanked: 0
Contact:

mssing libQt6Core.so.6

Post by ngdias »

I'm running Ubuntu Mate 20.04.

An application installed from a .deb package for Debian/Ubuntu (AARCH64) is exiting with an error about missing libQt6Core.so.6.

I searched around Qt6 for aarch64 and all I could find is cross-compile guides.

First, why so many results about cross-compilation, can't I compile Qt6 directly on my device?

Second, if I just need libraries for runtime, is there a package containing just the Qt6 runtime stuff?

What is the best way to provide the files necessary to run the application?

Thanks.

User avatar
mctom
Posts: 4135
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polski
ODROIDs: XU4, M1, H3+, SP3, N2L, M1S, N2
Location: Gdańsk, Poland
Has thanked: 609 times
Been thanked: 828 times
Contact:

Re: mssing libQt6Core.so.6

Post by mctom »

How about..

sudo apt install libqt6core6

EDIT: I should have explained, apt by default will install a proper binary version of whatever you're after, so no need to worry about aarch64 stuff if it's in there.
These users thanked the author mctom for the post:
ngdias (Thu Apr 04, 2024 11:19 pm)
Punk ain't no religious cult, punk means thinking for yourself!
OpenUPS
PiStackMon

ngdias
Posts: 4
Joined: Sat Sep 16, 2017 8:39 pm
languages_spoken: english
ODROIDs: c2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: mssing libQt6Core.so.6

Post by ngdias »

Sadly the command

Code: Select all

sudo apt install libqt6core6
ends with the error
E: Unable to locate package libqt6core6
I should have mentioned I installed and updated apt-file and ran

Code: Select all

apt-file search libQt6Core.so.6
and that turned out empty.

This page
https://launchpad.net/ubuntu/+search?text=libqt6core6

indicates that the package you mention is part of qt6-base and this is available in jammy, mantic and noble. So not focal...

Also there is a weird reference to a sky generation program Stellarium which I don't understand in the context of a general purpose Qt package?

User avatar
rooted
Posts: 10627
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 822 times
Been thanked: 736 times
Contact:

Re: mssing libQt6Core.so.6

Post by rooted »

What application did you install that needs QT6?

User avatar
mctom
Posts: 4135
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polski
ODROIDs: XU4, M1, H3+, SP3, N2L, M1S, N2
Location: Gdańsk, Poland
Has thanked: 609 times
Been thanked: 828 times
Contact:

Re: mssing libQt6Core.so.6

Post by mctom »

Yeah, Ubuntu inherently runs on outdated packages and that's why I avoid it.

Your best chance is to trust a PPA with Qt6 backport to Focal.
https://launchpad.net/~okirby/+archive/ ... lter=focal

I am also interested in knowing what application you're attempting to run.
Perhaps a snap/flatpak/appimage exists, those are bundled with all dependencies by design.
Punk ain't no religious cult, punk means thinking for yourself!
OpenUPS
PiStackMon

ngdias
Posts: 4
Joined: Sat Sep 16, 2017 8:39 pm
languages_spoken: english
ODROIDs: c2
Has thanked: 1 time
Been thanked: 0
Contact:

Re: mssing libQt6Core.so.6

Post by ngdias »

The library was installed by the .deb. After some digging, turns out the executable couldn't find it and the reason seems to be my old and incompatible 20.04 kernel that is below the requirements for Qt6.

Thanks for the help, I think this can be closed.

User avatar
mctom
Posts: 4135
Joined: Wed Nov 11, 2020 4:44 am
languages_spoken: english, polski
ODROIDs: XU4, M1, H3+, SP3, N2L, M1S, N2
Location: Gdańsk, Poland
Has thanked: 609 times
Been thanked: 828 times
Contact:

Re: mssing libQt6Core.so.6

Post by mctom »

"couldn't find it" possibly was a PATH issue. Perhaps telling us what the app was and trying to run it from a terminal would help explain it.
There's no such thing as 20.04 kernel and Qt website does not list any requirements towards kernel version.
Punk ain't no religious cult, punk means thinking for yourself!
OpenUPS
PiStackMon

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests