OdroidC2 - RJ45/Ethernet wont get detected

Post Reply
DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello,
I am having few odroid C2 boards.
I am facing the issue that randomly the RJ45/Ethernet not gets detected.
Is there any debug steps to find out the issue. OR it is damaged.
OS I am using is Ubuntu 16.04LTS.

Please guide.

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

When did you purchase the problematic(?) C2 boards?

Anyway, we will let you know some debug steps tomorrow.

DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello

REV0.2 20171114
This I found on odroidC2 board.
Waiting for debug steps !!
I will let you know the purchase date soon.

DEV

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

If you bought C2 boards recently, there is a possible root cause by defective RJ45 jack components.
Our RJ45 jack supplier told us some portion of '2019 29th week production had a bad pin contact issue due to their wrong length tolerance control.

Please check the production LOT ID number on the RJ45 jack.
If you have "1929" like this picture, we will replace your boards quickly.
rj45_defective.png
rj45_defective.png (217.16 KiB) Viewed 2198 times

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

If you have a different LOT ID, you need to capture "dmesg" output when you meet the random detecting problem.
Also try the latest Ubuntu 18.04 with Kernel 3.16.75.

mad_ady
Posts: 8311
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, C4, N1, N2, H2, Go, Go Advance
Location: Bucharest, Romania
Has thanked: 573 times
Been thanked: 431 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by mad_ady »

Are you still selling (or testing ethernet in particular) on the unsold boards from this shipment?

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

mad_ady wrote:
Thu Nov 07, 2019 9:50 pm
Are you still selling (or testing ethernet in particular) on the unsold boards from this shipment?
Nope.
These users thanked the author odroid for the post:
mad_ady (Fri Nov 08, 2019 3:29 pm)

DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello,

The Lot ID number we have is 1917.

DEV

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

In that case, you might have a different root cause.
With the problematic LOT 1929 RJ45 jacks, the connection speed was always 100Mbps instead of 1000Mbps.
It didn't lost the connection though.

Please try to capture the dmesg output when you meet the network device detection problem.
It is also very worth to try the latest Ubuntu 18.04.3 image to narrow down root causes.

DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello,
Ouput of dmesg with good odroidc2 board & bad odroidc2 board.

This is the output of good board---------

[ 0.544368] mtdoops: mtd device (mtddev=name/number) must be supplied
[ 0.553557] libphy: stmmac: probed
[ 0.553576] eth0: PHY ID 001cc916 at 0 IRQ POLL (stmmac-0:00) active
[ 0.553581] eth0: PHY ID 001cc916 at 7 IRQ POLL (stmmac-0:07)
[ 0.553958] usbcore: registered new interface driver cdc_ether
[ 0.554019] usbcore: registered new interface driver cdc_ncm
[ 0.554129] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.554134] ehci-h20ahb: H20AHB-EHCI Host Controller driver
[ 0.554221] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.554302] usbcore: registered new interface driver cdc_acm
[ 0.554306] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 0.554341] usbcore: registered new interface driver usb-storage
[ 0.554427] usbcore: registered new interface driver usbserial
[ 0.554451] usbcore: registered new interface driver usbserial_generic
[ 0.554474] usbserial: USB Serial support registered for generic
[ 0.554736] mousedev: PS/2 mouse device common for all mice
[ 0.555035] i2c /dev entries driver
[ 0.555695] ledtrig-cpu: registered to indicate activity on CPUs
[ 0.555744] hidraw: raw HID events driver (C) Jiri Kosina
[ 0.555891] usbcore: registered new interface driver usbhid
[ 0.555895] usbhid: USB HID core driver
[ 0.556059] ==uart0 reg addr = ffffff80002244c0
[ 0.556086] c81004c0.serial: ttyS0 at MMIO 0xc81004c0 (irq = 225, base_baud = 1500000) is a meson_uart
[ 0.601832] 00ffffffffffff0017101000010000003218010380160c783a7c119e59479b27
105054210800010101010101010101010101010101017820567251001e306e28
550010090000001e023a801871382d40582c450010090000001e000000fc0043
48414c4b2d313030310a2020000000fd003b3d0f2e08000a202020202020018a


and this as the bad output:

[ 0.542832] mtdoops: mtd device (mtddev=name/number) must be supplied
[ 0.546339] libphy: stmmac: probed
[ 0.546344] eth0: No PHY found
[ 0.602069] 00ffffffffffff0017101000010000003218010380160c783a7c119e59479b27
105054210800010101010101010101010101010101017820567251001e306e28
550010090000001e023a801871382d40582c450010090000001e000000fc0043
48414c4b2d313030310a2020000000fd003b3d0f2e08000a202020202020018a

Dev

User avatar
odroid
Site Admin
Posts: 34839
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 924 times
Been thanked: 755 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by odroid »

The Ethernet PHY IC initialization seems to be failed.

Please try this latest Ubuntu 18.04 image with newer Kernel 3.16 instead of the old Kernel 3.14 in Ubuntu 16.04.
https://wiki.odroid.com/odroid-c2/os_images/ubuntu/v3.1

User avatar
tobetter
Posts: 5480
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 215 times
Been thanked: 638 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by tobetter »

@DEV, do you see any LED is on at the RJ45 connector when a cable is attached and Ubuntu is running? The faulty connection error happens all the time or occasionally?
Which power supply do you use with them?

DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello,

No any LED is seen once it starts detecting faulty connection.
Barrel power input is given.


Dev

User avatar
tobetter
Posts: 5480
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 215 times
Been thanked: 638 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by tobetter »

DEV wrote:
Sat Nov 09, 2019 1:09 pm
Hello,

No any LED is seen once it starts detecting faulty connection.
Barrel power input is given.


Dev
If any LED is on and based on the kernel log you attached, One thing, if you can can into U-boot through serial connection, please do ping in U-boot. I think they have defected somehow. I guess RTL8211F is damaged or not abled to proved by CPU.

When did you purchase them?

DEV
Posts: 14
Joined: Tue Aug 06, 2019 3:14 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by DEV »

Hello ,
As per suggestion, I have prepare the SD card with latest UBUNTU mate 18.04.
This SD card is used with OdroidC2 on which ethernet wont get detected.
Done the IP setting, still ethernet wont get detected / connected.

Attached the logs of dmesg.

DEV
Attachments
dmesg_18.04.txt
(56.45 KiB) Downloaded 30 times

User avatar
tobetter
Posts: 5480
Joined: Mon Feb 25, 2013 10:55 am
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1
Location: Paju, South Korea
Has thanked: 215 times
Been thanked: 638 times
Contact:

Re: OdroidC2 - RJ45/Ethernet wont get detected

Post by tobetter »

DEV wrote:
Wed Nov 20, 2019 1:06 pm
Hello ,
As per suggestion, I have prepare the SD card with latest UBUNTU mate 18.04.
This SD card is used with OdroidC2 on which ethernet wont get detected.
Done the IP setting, still ethernet wont get detected / connected.

Attached the logs of dmesg.

DEV
I am not able to find out a clue in the kernel log attached, please do ping in U-boot if you have a USB-to-debug serial board. And please let us know when you have purchased them.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests