Issue with external HDD and torrents

Post Reply
SanyaIV
Posts: 4
Joined: Sun Mar 10, 2019 5:21 am
languages_spoken: english
ODROIDs: ODROID C2
Has thanked: 0
Been thanked: 0
Contact:

Issue with external HDD and torrents

Unread post by SanyaIV » Sun Mar 10, 2019 5:44 am

Hi!

I've been having an issue on and off with my ODROID-C2. It seems to resolve itself sometimes to then eventually crop up again. This time it seems rather permanent though as I haven't been able to get it to work reliably for over a week.

Basically the issue is this: I use my ODROID-C2 as a torrent server, tried Deluge and qBittorrent, this has worked fine generally but often when downloading torrents it'll grind to an almost halt at around ~10KiB/s download. When using the 'top' command I can see a 'kworker/u8:?' command take anywhere from 20 to 70 %CPU. The slow download always coincides with this command taking a lot of %CPU.

This has been an issue both with the official ubuntu image, as well as with CoreELEC. I've used two different SD-cards as well and the issue occurs with both of them. I've also had issues with Kodi on the ubuntu image, haven't had that issue with CoreELEC though.

My setup:

Connected to ODROID C2:
Sony Wireless Dualshock Adapter
Bluetooth adapter for wireless keyboard
Powered USB-hub (https://www.kjell.com/se/sortiment/dato ... ags-p69306)
Power-Supply (I have the jumper removed)
Gigabit Ethernet Cable
HDMI-cable

Connected to USB-hub:
2 x Western Digital 2.5" hard-drives at 3TB and 4TB using ext4 filesystem.

I've tried with just one drive connected to the USB-hub as well but the issue still occurs with just the one drive.

I'm not really sure what to do at this point, any ideas?

Image

User avatar
rooted
Posts: 6543
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 50 times
Been thanked: 15 times
Contact:

Re: Issue with external HDD and torrents

Unread post by rooted » Sun Mar 10, 2019 10:55 am

What is the output of dmesg when the issue happens?

Please use pastebin or a similar site and link her.

SanyaIV
Posts: 4
Joined: Sun Mar 10, 2019 5:21 am
languages_spoken: english
ODROIDs: ODROID C2
Has thanked: 0
Been thanked: 0
Contact:

Re: Issue with external HDD and torrents

Unread post by SanyaIV » Sun Mar 10, 2019 5:05 pm

rooted wrote:
Sun Mar 10, 2019 10:55 am
What is the output of dmesg when the issue happens?

Please use pastebin or a similar site and link her.
Here's the pastebin: https://pastebin.com/qnC2cmnQ

Edit: I googled the error message for EXT4-fs that shows up (mind you I know near nothing about this so I don't know if what I've found is correct or not) and it seems from what I could find that it's probably an issue with the filesystem or the drive itself. I'm really hoping it's not the drive itself but I did use fsck and it did find errors, I didn't really understand the utility though so I used the "Check" option in gparted which checked and fixed the issues with the filesystem. I'm currently testing to see if the issue has persisted after fixing the filesystem.

User avatar
rooted
Posts: 6543
Joined: Fri Dec 19, 2014 9:12 am
languages_spoken: english
Location: Gulf of Mexico, US
Has thanked: 50 times
Been thanked: 15 times
Contact:

Re: Issue with external HDD and torrents

Unread post by rooted » Mon Mar 11, 2019 12:30 am

That's the issue, see if repairing the filesystem did the trick.

If not we can check the condition of the drive with smartmontools (maybe).

SanyaIV
Posts: 4
Joined: Sun Mar 10, 2019 5:21 am
languages_spoken: english
ODROIDs: ODROID C2
Has thanked: 0
Been thanked: 0
Contact:

Re: Issue with external HDD and torrents

Unread post by SanyaIV » Mon Mar 11, 2019 1:10 am

rooted wrote:
Mon Mar 11, 2019 12:30 am
That's the issue, see if repairing the filesystem did the trick.

If not we can check the condition of the drive with smartmontools (maybe).
I also figured out that my USB-hub only provided 0.5A per port. If I understand correctly USB 3.0 2.5" external hard-drives prefer 0.9A(?) Not sure if that could have caused the issue but I've now returned that USB-hub and ordered another one which should in theory work better.

Regarding smartmontools, I tried looking at the S.M.A.R.T data earlier but couldn't get it to work in Ubuntu. I do have an NTFS partition on that drive though so I connected it to my Windows desktop and used Crystal Disk Info which claimed it was in good condition, I don't know if S.M.A.R.T data is per drive or partition though.

I'll do more tests once the new USB-hub arrives. The one I've ordered is this one btw, from what I can tell the individual ports *should* support external hard-drives.

User avatar
mad_ady
Posts: 6145
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 120 times
Been thanked: 83 times
Contact:

Re: Issue with external HDD and torrents

Unread post by mad_ady » Mon Mar 11, 2019 1:16 am

It's a powered hub, so it should be fine.
SMART data refers to the whole drive, not a partition

SanyaIV
Posts: 4
Joined: Sun Mar 10, 2019 5:21 am
languages_spoken: english
ODROIDs: ODROID C2
Has thanked: 0
Been thanked: 0
Contact:

Re: Issue with external HDD and torrents

Unread post by SanyaIV » Thu Mar 14, 2019 1:00 am

I've gotten the new USB-hub and I've set it up. I'll be testing it for a while and see if the issue reappears.

Edit: So far it seems to be stable, haven't had any issues.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 1 guest