ODROID-X2 suddenly wont boot with BT connected?

Post Reply
sonicxtacy02
Posts: 60
Joined: Thu May 30, 2013 5:08 am
languages_spoken: english
ODROIDs: X-2
Has thanked: 0
Been thanked: 0
Contact:

ODROID-X2 suddenly wont boot with BT connected?

Unread post by sonicxtacy02 » Sat Aug 01, 2015 2:47 am

Have an odd problem which has occured seemingly out of the blue. My ODROID-x2 running Android (whatever kernel/system that originally came with the device) will no longer boot with the USB BT adapter purchased from hardkernel installed. I get just the "Android" boot screen in a continuous loop with the device inserted. As soon as it's removed, the system will boot as normal. If I insert the BT adapter while the system is running I instantly get thrown to the same boot loop. I've had this ODROID installed in the car for about 2 years now, same devices, same power supply, and this problem started after a typical soft off/restart cycle. Prior to this issue, bluetooth has worked flawlessly.

Where should I begin to diagnose the problem?

User avatar
odroid
Site Admin
Posts: 31852
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 89 times
Been thanked: 255 times
Contact:

Re: ODROID-X2 suddenly wont boot with BT connected?

Unread post by odroid » Sat Aug 01, 2015 2:47 pm

I think you need to install the latest image.
http://odroid.com/dokuwiki/doku.php?id= ... se_android

sonicxtacy02
Posts: 60
Joined: Thu May 30, 2013 5:08 am
languages_spoken: english
ODROIDs: X-2
Has thanked: 0
Been thanked: 0
Contact:

Re: ODROID-X2 suddenly wont boot with BT connected?

Unread post by sonicxtacy02 » Tue Aug 04, 2015 1:39 am

odroid wrote:I think you need to install the latest image.
http://odroid.com/dokuwiki/doku.php?id= ... se_android

I have not updated the image on my Odroid since getting it, and it came preloaded on my eMMC. Forgive my question... i've tried to figure this update process out:

How do i know which version i have? I read on the downloads pages "First of all, You must install the Beta 2.0 or higher Image to update to Beta 2.9.1", then you need "First of all, You must install the Alpha 3.4 or higher Image to update to Alpha 4.2", but I have no clue what build i actually have. The build listed on my x2 is odroidx2-eng 4.1.2.jz054k eng.codewalker.20130424-171514. I'm under the distinct impression that I cant just use the "X2 Update Image" in my case correct?

sonicxtacy02
Posts: 60
Joined: Thu May 30, 2013 5:08 am
languages_spoken: english
ODROIDs: X-2
Has thanked: 0
Been thanked: 0
Contact:

Re: ODROID-X2 suddenly wont boot with BT connected?

Unread post by sonicxtacy02 » Tue Aug 04, 2015 3:48 am

Ok, so I think i understand.. the date code on my build indicates I'm running beta 1.6, so here's my approach as I understand it (correct me if i'm wrong)

-get beta 2.0 from http://dn.odroid.com/4412/Android/4.1.2 ... ODROID-X2/
-flash it to my emmc (i'll get a compatible emmc/sd converter)
-update to Alpha 3.4 according to instructions here http://com.odroid.com/sigong/nf_file_bo ... g=&bid=216
-lastly, update to Alpha 4.7 from your link (http://odroid.com/dokuwiki/doku.php?id= ... se_android)

Am I missing something in the process?

sonicxtacy02
Posts: 60
Joined: Thu May 30, 2013 5:08 am
languages_spoken: english
ODROIDs: X-2
Has thanked: 0
Been thanked: 0
Contact:

Re: ODROID-X2 suddenly wont boot with BT connected?

Unread post by sonicxtacy02 » Wed Aug 05, 2015 10:02 am

updated to the very latest image via the ODROID update utility and now my BT is back and working. Now I just have to remember how I fixed the kernel to make my Xenarc 700CSH work properly.. sign

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 1 guest