Page 1 of 1

ODROID-C2 black screen

Posted: Tue Jun 11, 2019 6:56 pm
by Yoz
Hello,

I have an ODROID-C2 with eMMC card 16GB, I tried to overclock my CPU on Ubuntu 18.04.2 and then it would not start, I just have a black screen without bios or anything else.
So, I bought an USB - eMMC card adaptor and I formated the eMMC card but it doesn't boot, i just have a black screen but when I install Android 3.8 it starts well.
I tried Lubuntu, OpenELEC and I have a black screen again... the blue light doesn't appear. Then I tried to remove the J1 as I readed on this forum but it is the same.

Could I flash BIOS as it is explain here https://www.howtogeek.com/136987/how-to ... usb-drive/ but I don't find the files ? Or something else ?
That is the 3rd day I search again and again a solution but I don't find anything. Should I do that with a Linux PC on cmd ?

Please could someone help me ?

Sorry for my english i try to do my best.

Re: ODROID-C2 black screen

Posted: Wed Jun 12, 2019 8:35 am
by joy
Hi Yoz,
It looks wrong OS image may be used.
Can you try this Ubuntu image?
https://wiki.odroid.com/odroid-c2/os_images/ubuntu/v3.0

And there is no BIOS menu and you will have Ubuntu desktop display if your C2 boots up well and blue LED will blink periodically.

If C2's blue LED works well but still you have blank screen, please share your monitor's specification.

Re: ODROID-C2 black screen

Posted: Wed Jun 12, 2019 9:36 pm
by Yoz
Thank you for your answer, maybe i'll try with another card (SD or eMMC when I'll can buy one) but right now i have installed Android 5.1 with some apps like FE File Explorer and it works very well... I can watch 1080p video easy from my NAS, and I would try with 4K video because my TV is an UHD 4K.

Anyway I don't think this is an OS image issue but... maybe. :)

I'll try to buy a card as soon as possible and then I'll answer you.