C2 crashes/freezing -> no boot -> defect

Moderators: mdrjr, odroid

C2 crashes/freezing -> no boot -> defect

Unread postby SG-HLZ » Wed Aug 29, 2018 4:54 pm

Hello Hardkernel,

I purchased a C2, a VU7 and some other things directly from Hardkernel some weeks ago.

Now my C2 is defect after only one month of using. In the first days it worked well with the Hardkernel-Android on eMMC and the touchscreen. But after some days, there where sudden crashes with blue screen, or other colors, sometimes loud sounds via the speakers, or black screen, or freezing. The only solution to get it back running was to interrupt the power supply once or several times. After that, the board boots again and worked for some minutes or hours, sometimes days. But now - after some more crashes, it doesn't boot anymore. PWR-Led is on and all VCCs are there, reset is in high state, but no boot. The ALIVE-Led is off. Also tried to reinstall the Android in newest version using Etcher. No function. From my point of view the controller itself doesn't start anymore.

It is very disappointing to order it directly at Hardkernel and now the C2 is defect after such a short time. First i tried to order it via Pollin in Germany, but Pollin is not able to purchase the VU7, so i ordered all items from Hardkernel. Naturally it doesn't make sense to send it back to South-Korea. This is much to expensive and buying it directly at Hardkernel, i had to pay additionally 70 Euros of customs dues - very annoying.

So my question is: can you help me? Maybe you have some hints to get the C2 running. I found out, that the board isn't the latest release. Mine is hardware revision 0.2 - the actual is 0.3. Which problems are known with rev.0.2? Why didn't i receive the latest hardware revision? Couldn't understand that.

I hope to get support from you.
Thank you very much!

Best regards,
Stefan
SG-HLZ
 
Posts: 4
Joined: Wed Aug 29, 2018 4:46 pm
languages_spoken: english, german
ODROIDs: C2, VU7plus

Re: C2 crashes/freezing -> no boot -> defect

Unread postby tobetter » Wed Aug 29, 2018 5:34 pm

Sorry to hear your ODROID-C2 is abnormal, do you have a UART-serial kit which can connect between ODROID-C2 and PC?
User avatar
tobetter
 
Posts: 2411
Joined: Mon Feb 25, 2013 10:55 am
Location: Paju, South Korea
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1

Re: C2 crashes/freezing -> no boot -> defect

Unread postby SG-HLZ » Wed Aug 29, 2018 5:45 pm

Hello tobetter,

sadly i have no UART-serial kit to connect to pc.
SG-HLZ
 
Posts: 4
Joined: Wed Aug 29, 2018 4:46 pm
languages_spoken: english, german
ODROIDs: C2, VU7plus

Re: C2 crashes/freezing -> no boot -> defect

Unread postby tobetter » Wed Aug 29, 2018 5:56 pm

SG-HLZ wrote:Hello tobetter,

sadly i have no UART-serial kit to connect to pc.

What PSU do you use?
What memory card do you use? Have you tried to boot with other SD card or eMMC?
Have you tried to boot after detaching all cables from ODROID-C2?
Are you able to measure the current at DC jack when ODROID-C2 is powered on?

Since Alive-LED keeps off, possible options are 1) the board has defected 2) the board cannot fetch the bootloader from a memory card.
User avatar
tobetter
 
Posts: 2411
Joined: Mon Feb 25, 2013 10:55 am
Location: Paju, South Korea
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1

Re: C2 crashes/freezing -> no boot -> defect

Unread postby SG-HLZ » Wed Aug 29, 2018 6:04 pm

- 5V/2A power supply from Hardkernel
- eMMC with Android from Hardkernel
- even when all cabels/VU7 are detached from C2: no boot
- the 5V DC-supply is stable
- eMMC was flashed new using etcher and newest android self-installation-image from Hardkernel. Did this after all these crashes because i thought maybe this will solve the problem. But didn't. I don't know, if the flashing worked correctly and how to check if the self-installtion-image work?
SG-HLZ
 
Posts: 4
Joined: Wed Aug 29, 2018 4:46 pm
languages_spoken: english, german
ODROIDs: C2, VU7plus

Re: C2 crashes/freezing -> no boot -> defect

Unread postby tobetter » Wed Aug 29, 2018 6:09 pm

SG-HLZ wrote:- 5V/2A power supply from Hardkernel
- eMMC with Android from Hardkernel
- even when all cabels/VU7 are detached from C2: no boot
- the 5V DC-supply is stable
- eMMC was flashed new using etcher and newest android self-installation-image from Hardkernel. Did this after all these crashes because i thought maybe this will solve the problem. But didn't. I don't know, if the flashing worked correctly and how to check if the self-installtion-image work?

I would suggest you try a flash the self-install image to SD card instead of eMMC to see if your ODROID-C2 can fetch the bootloader. If possible, please try with Sandisk SD card for sure.
User avatar
tobetter
 
Posts: 2411
Joined: Mon Feb 25, 2013 10:55 am
Location: Paju, South Korea
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1

Re: C2 crashes/freezing -> no boot -> defect

Unread postby SG-HLZ » Wed Aug 29, 2018 6:19 pm

I will try get a SD card and additionally a USB-UART-kit...
Will come back here later to keep you informed...
Thanks for your hints!
SG-HLZ
 
Posts: 4
Joined: Wed Aug 29, 2018 4:46 pm
languages_spoken: english, german
ODROIDs: C2, VU7plus

Re: C2 crashes/freezing -> no boot -> defect

Unread postby tobetter » Wed Aug 29, 2018 6:29 pm

SG-HLZ wrote:I will try get a SD card and additionally a USB-UART-kit...
Will come back here later to keep you informed...
Thanks for your hints!

No problem, let me know. If you try an SD card, you would check if your ODROID-C2 can boot from it. And if you can try a USB-UART kit, please capture the logs and share with me.
User avatar
tobetter
 
Posts: 2411
Joined: Mon Feb 25, 2013 10:55 am
Location: Paju, South Korea
languages_spoken: Korean, English
ODROIDs: X, X2, U2, U3, XU3, C1

Re: C2 crashes/freezing -> no boot -> defect

Unread postby mad_ady » Wed Aug 29, 2018 7:47 pm

You can get any usb-serial dongle that has 3.3V if you can't source the HK part with the custom connector.
User avatar
mad_ady
 
Posts: 4593
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1

Re: C2 crashes/freezing -> no boot -> defect

Unread postby rooted » Thu Aug 30, 2018 12:52 am

mad_ady wrote:You can get any usb-serial dongle that has 3.3V if you can't source the HK part with the custom connector.
Just be 100% that you connect to 3.3v and not 5v, most support both voltages.
User avatar
rooted
 
Posts: 5601
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1, C1+, C2
XU3 Lite, XU4
N1
VU7+
HiFi Shield 2
Smart Power (original)


Return to Hardware and peripherals

Who is online

Users browsing this forum: No registered users and 3 guests