Could not get PHY for ethernet

Post Reply
habiloid
Posts: 2
Joined: Fri Feb 19, 2021 5:52 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Could not get PHY for ethernet

Post by habiloid »

When I boot (Armbian 21.02.2 Buster) the first thing that appears on screen is "could not find PHY for ethernet". Later on there are lost of messages:

[12909.357550] meson8b-dwmac c9410000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19)
[12909.387062] meson8b-dwmac c9410000.ethernet eth0: no phy at addr -1

I can't get to my ethernet connection. I have tried booting from both SD and eMMC

Any ideas?

Ta

igorpec
Posts: 959
Joined: Sat Dec 12, 2015 4:34 pm
languages_spoken: english,german,slovene
ODROIDs: XU4, HC1, C2, C1+
Has thanked: 56 times
Been thanked: 135 times
Contact:

Re: Could not get PHY for ethernet

Post by igorpec »

Bugs resolving procedure: https://www.armbian.com/bugs/

This problem used to be around, but haven't seen it for a while. My test C2 works O.K., logs http://ix.io/2PXO

Code: Select all

[    9.654907] systemd-journald[1635]: Received client request to flush runtime journal.
[   12.779626] meson8b-dwmac c9410000.ethernet eth0: PHY [stmmac-0:00] driver [RTL8211F Gigabit Ethernet] (irq=46)
[   12.785581] meson8b-dwmac c9410000.ethernet eth0: No Safety Features support found
[   12.785601] meson8b-dwmac c9410000.ethernet eth0: PTP not supported by HW
[   12.785973] meson8b-dwmac c9410000.ethernet eth0: configuring for phy/rgmii link mode
[   16.250088] meson8b-dwmac c9410000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   16.250138] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   33.764801] VCC3V3: disabling
Power cycle, different cable?
ARMBIAN
Linux for ARM development boards
What is Armbian?

habiloid
Posts: 2
Joined: Fri Feb 19, 2021 5:52 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Could not get PHY for ethernet

Post by habiloid »

Thanks for that.

I installed ArchLinux instead and everything worked fine.

Definitely an Armbian problem

igorpec
Posts: 959
Joined: Sat Dec 12, 2015 4:34 pm
languages_spoken: english,german,slovene
ODROIDs: XU4, HC1, C2, C1+
Has thanked: 56 times
Been thanked: 135 times
Contact:

Re: Could not get PHY for ethernet

Post by igorpec »

habiloid wrote:
Sat Feb 20, 2021 2:52 am
Definitely an Armbian problem
Certainly not.
ARMBIAN
Linux for ARM development boards
What is Armbian?

cert_
Posts: 23
Joined: Sun Mar 20, 2016 9:16 pm
languages_spoken: english
Has thanked: 0
Been thanked: 0
Contact:

Re: Could not get PHY for ethernet

Post by cert_ »

same problem here, did a apt update and apt upgrade today

meson8b-dwmac c9410000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19)
meson8b-dwmac c9410000.ethernet eth0: no phy at addr -1

how can i get it back?

Post Reply

Return to “Hardware and peripherals”

Who is online

Users browsing this forum: No registered users and 3 guests