Do the red eMMC modules work?

Moderators: odroid, mdrjr

Do the red eMMC modules work?

Unread postby XNeo » Thu Mar 17, 2016 5:35 am

In the C2 announcement there is a footnote saying that the new eMMC Black modules won't work with the XU4.

I have the opposite question, though: Do the (red PCB) XU4 eMMC Modules work with the C2?
Both claim eMMC5.0 HS400 compatibility?

(Reason I'm asking: The eMMC Black modules are currently unavailable in Germany :(
Pollin.de seems reeeeally slow on anything C2 and selling lots of RPi3 in the meantime)
XNeo
 
Posts: 6
Joined: Sat Aug 15, 2015 1:18 am
languages_spoken: german,english

Re: Do the red eMMC modules work?

Unread postby phaseshifter » Thu Mar 17, 2016 6:17 am

the black modules will only work on the C-2

the red modules will work on all odroids
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2841
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Do the red eMMC modules work?

Unread postby odroid » Thu Mar 17, 2016 9:39 am

Phaseshifter's answer is very correct.

BTW, I heard Pollin will start to sell the C2 and peripherals within a few days even we already shipped their orders 2~3 weeks ago. ;)
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby XNeo » Thu Mar 17, 2016 2:43 pm

Thanks to both of you!

(Pollin did start selling the C2 yesterday. But no sign of new eMMCs…)
XNeo
 
Posts: 6
Joined: Sat Aug 15, 2015 1:18 am
languages_spoken: german,english

Re: Do the red eMMC modules work?

Unread postby phaseshifter » Wed Mar 30, 2016 3:20 pm

i find this rather interesting i flashed a red emmc that come with my c2 with 15.10 it failed to start up ...on my xu4 .
is there a difference in the boot blocks between c2 chip that i was supplied
or was it just a faulty flash
i only tried to flash it once ..maybe i will again in the future but as for now there is no need...
odroid N-1 16Gb emmc orange..
phaseshifter
 
Posts: 2841
Joined: Fri May 08, 2015 9:12 am
languages_spoken: english
ODROIDs: N-1..c1+ ..c-2..xu3 lite,xu4...u-3..
u-2...other odroid acc`s as well

Re: Do the red eMMC modules work?

Unread postby odroid » Wed Mar 30, 2016 5:10 pm

You needed to flashed the boot sectors via XU4 recovery process.
viewtopic.php?f=53&t=6173
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby Claudi » Sat Apr 02, 2016 12:44 am

May I ask what is the reason to offer red eMMC which work with all and black which only work with C2?
Is it "better" to use the black ones for the C2?
Claudi
 
Posts: 14
Joined: Sat Apr 02, 2016 12:41 am
languages_spoken: english

Re: Do the red eMMC modules work?

Unread postby mad_ady » Sat Apr 02, 2016 2:21 am

The black ones are a bit cheaper. Also, the C2 can't boot from the red emmc.
User avatar
mad_ady
 
Posts: 3836
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Do the red eMMC modules work?

Unread postby odroid » Sun Apr 03, 2016 12:21 pm

@Claudi
The Samsung eMMC memory chip on the black eMMC module doesn't support the hidden-block API for the Exynos-CPU boot ROM ironically .
So the black eMMC can be used with only C1/C2 series.

@mad_ady
C2 can boot from the red eMMC when you flash the C2 OS correctly.
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby mad_ady » Sun Apr 03, 2016 1:14 pm

Thanks for the clarification, odroid!
User avatar
mad_ady
 
Posts: 3836
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Do the red eMMC modules work?

Unread postby seba1970 » Mon Apr 11, 2016 11:13 pm

odroid wrote:@Claudi
The Samsung eMMC memory chip on the black eMMC module doesn't support the hidden-block API for the Exynos-CPU boot ROM ironically .
So the black eMMC can be used with only C1/C2 series.

@mad_ady
C2 can boot from the red eMMC when you flash the C2 OS correctly.

how to proper reimage red emmc for C2,
seba1970
 
Posts: 8
Joined: Sat Apr 02, 2016 4:20 pm
languages_spoken: english
ODROIDs: odroid C2

Re: Do the red eMMC modules work?

Unread postby odroid » Tue Apr 12, 2016 8:39 am

Just flash the OS image with Win32DiskImager or dd command.
http://odroid.com/dokuwiki/doku.php?id= ... hing_tools
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby seba1970 » Thu Apr 14, 2016 10:20 pm

thanks, very easy even reformating isn't necessary,DONE
seba1970
 
Posts: 8
Joined: Sat Apr 02, 2016 4:20 pm
languages_spoken: english
ODROIDs: odroid C2

Re: Do the red eMMC modules work?

Unread postby Kiralina » Thu Jan 19, 2017 1:02 am

I just got the red eMMC and I tried to write LE image for odroid C2 on it from a Mac, using LE USB-SD creator. It doesn't boot and I get a lot of errors. Please help. I don't have a windows machine .

Later edit. Tried from windows with the tutorial linked above and it still doesn't work.

Thank you.
Last edited by Kiralina on Thu Jan 19, 2017 2:43 am, edited 1 time in total.
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby mad_ady » Thu Jan 19, 2017 2:42 am

You can try writing the image with http://etcher.io
User avatar
mad_ady
 
Posts: 3836
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Do the red eMMC modules work?

Unread postby Kiralina » Thu Jan 19, 2017 3:27 am

Doesn't matter how I flash the eMMC, I always get this error sh: can't access tty; job control turned off

How can this be fixed. I got the eMMC from somebody that used it with a Linux on XU4. I don't know what was installed before. The eMMC arrived already formatted.

Thanks.
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby mad_ady » Thu Jan 19, 2017 3:33 am

I am not familiar with the image you're using. You can try flashing a ubuntu image to make sure it boots correctly. The message you are getting comes from a shell (probably busybox) and is generally benign. Do you get other output before that? Pressing enter should get you to a prompt.
User avatar
mad_ady
 
Posts: 3836
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Do the red eMMC modules work?

Unread postby Kiralina » Thu Jan 19, 2017 3:50 am

mad_ady wrote:I am not familiar with the image you're using. You can try flashing a ubuntu image to make sure it boots correctly. The message you are getting comes from a shell (probably busybox) and is generally benign. Do you get other output before that? Pressing enter should get you to a prompt.


I try to boot LibreElec, a small linux distro that boots directly in Kodi.

When it tries to boot error is:

***Error in mount_storage: mount_common: Could not mount /dev//mmcb1k0p2***

Final edit :) :) :)

Solved it. I erased the partition table with this ""sudo diskutil partitionDisk /dev/disk3 1 MBR "Free Space" "%noformat%" 100%"" and wrote the image once again in terminal. Now it boots fine :)
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby Kiralina » Fri Jan 20, 2017 2:17 am

Kiralina wrote:
mad_ady wrote:I am not familiar with the image you're using. You can try flashing a ubuntu image to make sure it boots correctly. The message you are getting comes from a shell (probably busybox) and is generally benign. Do you get other output before that? Pressing enter should get you to a prompt.


I try to boot LibreElec, a small linux distro that boots directly in Kodi.

When it tries to boot error is:

***Error in mount_storage: mount_common: Could not mount /dev//mmcb1k0p2***

Final edit :) :) :)

Solved it. I erased the partition table with this ""sudo diskutil partitionDisk /dev/disk3 1 MBR "Free Space" "%noformat%" 100%"" and wrote the image once again in terminal. Now it boots fine :)


I thought I fixed it, but didn't. Booted once and after powering off didn't want to boot. Got the same errors as before. Strange thing is that if I just cut the power and replug sometimes it boots.
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby mad_ady » Fri Jan 20, 2017 2:47 am

This usually means that something does not properly unmount the partition(s), but it's hard to say without a serial cable
User avatar
mad_ady
 
Posts: 3836
Joined: Wed Jul 15, 2015 5:00 pm
Location: Bucharest, Romania
languages_spoken: english
ODROIDs: XU4, C1+, C2

Re: Do the red eMMC modules work?

Unread postby Kiralina » Fri Jan 20, 2017 3:06 am

mad_ady wrote:This usually means that something does not properly unmount the partition(s), but it's hard to say without a serial cable


You lost me at serial cable. I tried different builds of libreelec. They all do the same. Can the eMMC be faulty , or is just that it is not designed for the C2 ?
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby odroid » Fri Jan 20, 2017 12:12 pm

Try Formatter4 and FFT with the eMMC to check whether your have a damaged eMMC or not.
http://odroid.com/dokuwiki/doku.php?id= ... e_shooting

BTW, did you use "VERIFY" button when you flashed the OS image?
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby Kiralina » Fri Jan 20, 2017 8:25 pm

odroid wrote:Try Formatter4 and FFT with the eMMC to check whether your have a damaged eMMC or not.
http://odroid.com/dokuwiki/doku.php?id= ... e_shooting

BTW, did you use "VERIFY" button when you flashed the OS image?


Used the verify button.

I'll also try the trouble shooting tool if it will still make problems.
For now, I think, just think, I'll know for sure in a day or two that I have identified the culprit.

Thank you.
Kiralina
 
Posts: 25
Joined: Wed Aug 31, 2016 2:00 am
Location: Romania
languages_spoken: english,romanian,italian,french
ODROIDs: ODROID C2

Re: Do the red eMMC modules work?

Unread postby al15 » Sat Dec 09, 2017 7:54 am

Hello,

i have the exact same issue - i own a C2 and a red 64GB emmc after the 2nd or 3rd reboot i got the message:
Error in mount_storage: mount_common_ Could not mount /dev/mmcblk0p2

I tried a total formating as well as multiple times a flash with different tools but have always the same error.

Anyone has an hint why this is not working - the original black 8GB card is working well in the device

Thanks
lg
AL
al15
 
Posts: 3
Joined: Sat Dec 09, 2017 7:51 am
languages_spoken: english
ODROIDs: C2

Re: Do the red eMMC modules work?

Unread postby odroid » Sat Dec 09, 2017 12:58 pm

@al15
Which OS image and Kernel do you use?
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby al15 » Sat Dec 09, 2017 7:00 pm

Hi

The card was originally in an u4 and i formated (FULL) it and flashed libreelec 8.2.1 on it. After that the system started one time successfully but then stuck at reboots.
Already flashed 4 times always same behaviour.
The black 8gb card is working with the same image!

Found also this post which indicates the same issue:
viewtopic.php?f=144&t=25543&p=176444&hilit=Could+not+mount#p176444

Thanks
Lg
AL

Gesendet von meinem SM-G935F mit Tapatalk
al15
 
Posts: 3
Joined: Sat Dec 09, 2017 7:51 am
languages_spoken: english
ODROIDs: C2

Re: Do the red eMMC modules work?

Unread postby odroid » Sun Dec 10, 2017 10:21 am

Try the latest Ubuntu image to narrow down the root causes.
https://wiki.odroid.com/odroid-c2/os_images/ubuntu/v2.4

Use "Etcher" for flashing OS image.
https://wiki.odroid.com/troubleshooting ... s#flashing

Do you have a compatible card reader?
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby al15 » Mon Dec 11, 2017 12:55 am

Hi,

thanks for the feedback! Here my comments:

Try the latest Ubuntu image to narrow down the root causes.
https://wiki.odroid.com/odroid-c2/os_images/ubuntu/v2.4
Will try but as mentioned the same image with the balck card (8GB) is working fine - also tried another 64GB red card - same issue
Update: tried the ubuntu mate image - this is working fine (reboots, shutdown restart) - so i think its something in the libreelec image any hint what i could tell the creators of the image to solve this issue? It must be some special handling need of the red card...
I tried this image files:
LibreELEC-Odroid_C2.aarch64-8.2.1.img.gz
LibreELEC-Odroid_C2.arm-8.2-rb-krypton19.img.gz


Use "Etcher" for flashing OS image.
https://wiki.odroid.com/troubleshooting ... s#flashing
Using etcher already

Do you have a compatible card reader?
viewtopic.php?f=53&t=2725
Using a USB 3.0 - Transcend TS-RDF8K which is working with the back 8GB as well as for the red 64GB for the Odorid U4

Thanks
lg
AL
al15
 
Posts: 3
Joined: Sat Dec 09, 2017 7:51 am
languages_spoken: english
ODROIDs: C2

Re: Do the red eMMC modules work?

Unread postby odroid » Mon Dec 11, 2017 9:30 am

Thank you for the test and we can say your red eMMC was not broken at least.

Do you have a USB-UART kit to help LibreELEC developers to find what's wrong in their system software?
How is the blue LED? Was it blinking like a heartbeat? or solid-on? or completely off?
User avatar
odroid
Site Admin
 
Posts: 27984
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Do the red eMMC modules work?

Unread postby thatchunkylad1989 » Mon Dec 25, 2017 8:36 am

I have the 16gb red eMMC and it's working just fine with my C2. I saved it when I threw out my XU4 because it was faulty, never RMA'd it though. I must've knew I'd get the C2 because I saved the eMMC, normally I put stuff like that in the bin when I have no use for it, lol.
thatchunkylad1989
 
Posts: 163
Joined: Sun Dec 24, 2017 12:29 am
languages_spoken: english
ODROIDs: C2


Return to Hardware and peripherals

Who is online

Users browsing this forum: No registered users and 2 guests