LibreELEC 7.0.2 - Kodi Jarvis 16.1 - Archived - LE Tips HERE

Moderators: mdrjr, odroid, Raybuntu, wrxtasy

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby infinity85 » Wed Jun 08, 2016 9:38 am

@agbart and teeace

After seeing your attached pictures I can confirm this dead pixel on my Philips LCD. I assume now that everybody has it. It is indeed exactly the pixel in the corner at the outer edge which behaves strangely.
My Odroid-C2 rev0.2 20160226 is according to odroid-wiki the latest revision.


milanp wrote:@infinity85
Go to page 14 of this thread. Look at my posts and wrxtasy's answers.
At the end,it GPIO IR works for me.


So... it works now, thank you very much again :)

You mentioned it only worked for you if you use an autostart.sh even though wrxtasy claimed it should work without autostart.sh. Well wrxtasy was correct once again :D. It does indeed work without autostart.sh. According to modprobe manual I managed to do it this way (mini guide):

How to enable GPIO-IR receiver (and disable Odroids built-in IR receiver)

1. Create a gpio-ir-recv.conf with the necessary gpio-ir modules to load at startup in directory .config/modules-load.d/:

Code: Select all
nano .config/modules-load.d/gpio-ir-recv.conf

paste following modules:
Code: Select all
gpio-ir-recv
gpioplug-ir-recv

CTRL+O to save, CTRL+X to close file

2. Create a blacklist-meson-ir_set-gpio-ir-nr.conf for blacklisting meson-ir as well as defining the now used GPIO-number in directory .config/modprobe.d/:

Code: Select all
nano .config/modprobe.d/blacklist-meson-ir_set-gpio-ir-nr.conf

paste following lines:
Code: Select all
blacklist meson-ir
options gpioplug-ir-recv gpio_nr=238 active_low=1

CTRL+O to save, CTRL+X to close file

3. Reboot the device

Remarks:
- Of course one can use another gpio_nr
- to check if modules are loaded properly, just type in "ir-keytable"
Code: Select all
LibreELEC:~ # ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event2) with:
        Driver gpio-rc-recv, table rc-empty
        Supported protocols: lirc rc-5 jvc sony nec sanyo mce-kbd rc-6
        Enabled protocols: lirc rc-5 jvc sony nec sanyo mce-kbd rc-6
        Name: gpio_ir_recv
        bus: 25, vendor/product: 0001:0001, version: 0x0100
        Repeat delay = 200 ms, repeat period = 125 ms


Works like a charm :)
Last edited by infinity85 on Thu Jun 09, 2016 2:15 am, edited 2 times in total.
infinity85
 
Posts: 337
Joined: Tue May 24, 2016 4:26 am
languages_spoken: english, german
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 12:08 pm

Nice mini guide there infinity85. :)
I will start a Mini Guide section on Page #1 linking any posts like the one above to allow everyone to find them easily.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby crashoverride » Wed Jun 08, 2016 12:23 pm

RE: stuck pixel

A possible cause of that is the /dev/fb1 (note: not /dev/fb0) overlay. Its typical purpose is to serve as a mouse cursor. It is logically stacked on top of the main frame buffer which is logically stacked on top of the video layer. It should be possible to disable (blank) it from its sysfs entry. If disabling does not work, it should also be possible to "clear" it memory so that its transparent.
crashoverride
 
Posts: 3060
Joined: Tue Dec 30, 2014 8:42 pm
languages_spoken: english
ODROIDs: C1

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Wed Jun 08, 2016 1:05 pm

Will yesterday's release of the S905 datasheet help with LibreELEC development on the C2?
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby crossover » Wed Jun 08, 2016 1:17 pm

Hey ODROID admin!
I guess a lot of users own C2 board for their media player application.
So this amazing thread is too much crowded and it is terribly hard to trace the mixed issues/ideas.
It has almost 1000 posts. :o

So we really want to have a dedicated sub-forum only for LibreELEC users and developers.
Heavily consider this suggestion.
crossover
 
Posts: 105
Joined: Wed Jul 22, 2015 2:23 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, USB-IO, Tinkering kits

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 3:17 pm

crashoverride wrote:RE: stuck pixel

A possible cause of that is the /dev/fb1 (note: not /dev/fb0) overlay. Its typical purpose is to serve as a mouse cursor. It is logically stacked on top of the main frame buffer which is logically stacked on top of the video layer. It should be possible to disable (blank) it from its sysfs entry. If disabling does not work, it should also be possible to "clear" it memory so that its transparent.

As a test, whenever anyone see this pixel problem would be to blank frame buffer 1:
Code: Select all
echo 1 > /sys/class/graphics/fb1/blank

And report back...

@crossover,
Yes agreed, this LibreELEC thread is a now victim of its own popularity and has become so large and unmanageable that it actually does need its own Sub-Forum.
Trying to find information without endless repetition or searching is becoming a BIG problem...
I will ask for something to be done by HK and I will try and gather a few moderators for it as well.
Mr RB may be keen ... ;)
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Raybuntu » Wed Jun 08, 2016 3:25 pm

@wrxtasy: why not move most of the LE support stuff over to our LE forum?
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1163
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 3:46 pm

If this build had its own dedicated Sub-Forum that would work as well.
I see kszaq has his own AML S805 Subforum so I could ask Chewitt or lrusak for a ODROID-C2 one.

My only concern is having to flip between this forum and the LE one. Its either one or the other but not both as it becomes to unmanageable. I'm open to user feedback on the idea ?
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby odroid » Wed Jun 08, 2016 4:00 pm

crossover wrote:Hey ODROID admin!
I guess a lot of users own C2 board for their media player application.
So this amazing thread is too much crowded and it is terribly hard to trace the mixed issues/ideas.
It has almost 1000 posts. :o

So we really want to have a dedicated sub-forum only for LibreELEC users and developers.
Heavily consider this suggestion.


I fully agreed and made a sub-forum for the LE project.
User avatar
odroid
Site Admin
 
Posts: 24354
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 4:05 pm

Thx. Justin, that will help all of us LE Kodi users :)

From this point onwards can I ask all users to post specific issues in their own newly created threads and I will keep this one for New Releases and experimental testing purposes and feedback.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby odroid » Wed Jun 08, 2016 4:09 pm

wrxtasy wrote:Thx. Justin, that will help all of us LE Kodi users :)

You are welcome ! :D
User avatar
odroid
Site Admin
 
Posts: 24354
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Raybuntu » Wed Jun 08, 2016 4:12 pm

wrxtasy wrote:If this build had its own dedicated Sub-Forum that would work as well.
I see kszaq has his own AML S805 Subforum so I could ask Chewitt or lrusak for a ODROID-C2 one.

My only concern is having to flip between this forum and the LE one. Its either one or the other but not both as it becomes to unmanageable. I'm open to user feedback on the idea ?


You're right but we'd have more control over there with our own moderators etc. But this is fine too.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1163
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby teeace » Wed Jun 08, 2016 4:28 pm

wrxtasy wrote:As a test, whenever anyone see this pixel problem would be to blank frame buffer 1:
Code: Select all
echo 1 > /sys/class/graphics/fb1/blank

And report back...


GREAT! I've just test it and it works: no pixel in calibrate page, no pixel during and after movie.
Of course, it comes back after reboot : is there an easy way to make it permanent?
Attachments
ok.JPG
(37.53 KiB) Downloaded 4096 times
teeace
 
Posts: 7
Joined: Tue May 31, 2016 6:11 pm
languages_spoken: french + english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Raybuntu » Wed Jun 08, 2016 4:33 pm

You can put it in autostart.sh. Or a systemd one-shot. But we have a subforum now so please open a new thread for your issue ;)

EDIT: The best solution should be tmpfiles.d imho
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1163
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 4:36 pm

Yes autostart.sh for those who want an immediate fix. I will put it in platform_init as a permanent fix with the next release.
Thx. crashoverride for the tip :)

https://github.com/wrxtasy/LibreELEC.tv ... m_init#L52

Also if users are not using a mouse, this will likely work as well:
Settings > System > Input devices > Enable mouse and touchscren support > Disable
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby teeace » Wed Jun 08, 2016 5:30 pm

wrxtasy wrote:Yes autostart.sh for those who want an immediate fix. I will put it in platform_init as a permanent fix with the next release.
Thx. crashoverride for the tip :)

https://github.com/wrxtasy/LibreELEC.tv ... m_init#L52

Also if users are not using a mouse, this will likely work as well:
Settings > System > Input devices > Enable mouse and touchscren support > Disable


If it can help, I can tell you that the mouse solution doesn't change anything :(
So I created an autostart.sh and it works for me :D
teeace
 
Posts: 7
Joined: Tue May 31, 2016 6:11 pm
languages_spoken: french + english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Wed Jun 08, 2016 9:13 pm

Thx. for the feedback.

I've been working on providing a greater number of Resolutions for those with connected monitors. Those resolution as found in this list:
https://github.com/wrxtasy/LibreELEC.tv ... m_init#L28

So long as there is a valid Extended Display Identification Data (EDID) handshake between the C2 and a monitor, those extra display modes should now work. Note this is all untested as I don't have the required displays and you may actually have to Hard select a Resolution in Kodi to get the Video scaling correct for non-TV displays.
Also be aware the boot.ini file has no effect when selecting a different Kodi resolution, its all handled internally when Kodi starts up.

Also included in this test version:
- all the additions from the Experimental version on Page #1
- a fix for the Single Top left pixel problem
- Raybuntu's latest CEC patch to turn HDMI CEC control off completely if you select the disable option in the boot.ini file on the SD card (setenv hdmi_cec "0"). To disable CEC completely you will still have to disable the CEC Adapter in Kodi as well.

LibreELEC-Odroid_C2.aarch64-7.0.1.Resolutions.HDMI-CEC.tar

A Kodi.log would be very handy for me from those users with C2's connected to non-TV displays for development use stating the Monitor name as well:
Code: Select all
paste .kodi/temp/kodi.log
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Ballistic » Wed Jun 08, 2016 11:30 pm

Hi all,

I am running the C2 connected to a Panasonic AX800 TV. When setting the output at 4k@60Hz i often get no image. After a couple of tries it works fine.
Then after rebooting the device, again no image. But when i turn off my TV and turn it back on again, the image is fine at 4k60Hz.

Any clues?

Startup log:
http://pastebin.com/S14DQjB1
Ballistic
 
Posts: 4
Joined: Wed Jun 08, 2016 11:27 pm
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby teeace » Wed Jun 08, 2016 11:47 pm

So, I installed LibreELEC 7.0.1 - Kodi Jarvis 16.1 NEW:28.May.2016, the one with DTS-MA
I updated it with your last file (LibreELEC-Odroid_C2.aarch64-7.0.1.Resolutions.HDMI-CEC.tar)
I can tell you that your "fix for the Single Top left pixel problem" doesn't work here.
teeace
 
Posts: 7
Joined: Tue May 31, 2016 6:11 pm
languages_spoken: french + english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Exist2Resist » Thu Jun 09, 2016 1:41 am

wrxtasy wrote:If this build had its own dedicated Sub-Forum that would work as well.
I see kszaq has his own AML S805 Subforum so I could ask Chewitt or lrusak for a ODROID-C2 one.

My only concern is having to flip between this forum and the LE one. Its either one or the other but not both as it becomes to unmanageable. I'm open to user feedback on the idea ?


I would keep it here.
As this is the first place I came to look for alternate OS for my C2.
Prior to that I didn't even know LE existed.
Also LE does not list C2 as a supported device on their site.
Exist2Resist
 
Posts: 40
Joined: Sat May 28, 2016 3:08 am
Location: Great White North
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Marvin27 » Thu Jun 09, 2016 3:49 am

Marvin27
 
Posts: 38
Joined: Tue Mar 08, 2016 4:02 am
Location: Poland
languages_spoken: english, polish
ODROIDs: ODROID C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby xblackdemonx » Thu Jun 09, 2016 4:35 am

Ballistic wrote:Hi all,

I am running the C2 connected to a Panasonic AX800 TV. When setting the output at 4k@60Hz i often get no image. After a couple of tries it works fine.
Then after rebooting the device, again no image. But when i turn off my TV and turn it back on again, the image is fine at 4k60Hz.

Any clues?

Startup log:
http://pastebin.com/S14DQjB1


Same issue here with a Vizio 4K TV.
xblackdemonx
 
Posts: 53
Joined: Tue Mar 15, 2016 5:13 am
languages_spoken: english

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby jurand » Thu Jun 09, 2016 5:09 am

wrxtasy wrote:Also included in this test version:
- all the additions from the Experimental version on Page #1
- a fix for the Single Top left pixel problem
- Raybuntu's latest CEC patch to turn HDMI CEC control off completely if you select the disable option in the boot.ini file on the SD card (setenv hdmi_cec "0"). To disable CEC completely you will still have to disable the CEC Adapter in Kodi as well.

LibreELEC-Odroid_C2.aarch64-7.0.1.Resolutions.HDMI-CEC.tar


Are you sure all the "Experimental" patches are there? "Auto switch back" problem is back..
jurand
 
Posts: 66
Joined: Fri May 06, 2016 7:55 pm
Location: Poznań, Poland
languages_spoken: english
ODROIDs: XU XU-3 XU-4 C1+ C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Thu Jun 09, 2016 6:42 am

ok, quick infos:
i use the latest update from today by wrxtasy >>> LibreELEC-Odroid_C2.aarch64-7.0.1.Resolutions.HDMI-CEC.tar

1. no pixel in top left corner ( i have also disable mouse support )

2. i have update my 3D Report on Page 18 !

3. i had connected my C2 today on my Onkyo receiver to test the 3D stuff and the other stuff i dont have in my bedroom with my normal TV and i notice, that i dont have any DTS-HD options when i connect it to my ONKYO Receiver ( it can play DTS-HD 5.1 or 7.1 - i use it with my Windows AMD A6 player all the time ) - so when i DISABLE the DTS mode in audio setting, i dont get DTS at all - when i activate it i get "just" normal DTS as output ... did i miss something, or is it again a "onkyo" compatible problem ? ( i think there was something similar with the PI2 )

4. Still have sometimes a MYSQL problem ( need to go to settings and disable/enable mysql to see my library ) - not always - when i check the logs, i can see that LE cant find any database ( 101 )
will make a fresh log when it happens again more often ;) - would be cool when i disable the option inside KODI settings, it would be used the AS settings - never had problems with AS-Mysql ...
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Thu Jun 09, 2016 9:58 am

I had some luck flashing libreelec onto my 8gb emmc card.
Bought a sandisk reader from office work for you Aussies.

Probably been discussed, but anyone having some lag and tearing during menu navigation? Using confluence.

The 8gb emmc should be plenty fast.

Pretty snappy performance apart from a little gui tearing.

Cheers all
Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby infinity85 » Thu Jun 09, 2016 10:02 am

richpags wrote:
[...]
Probably been discussed, but anyone having some lag and tearing during menu navigation? Using confluence.
[...]


Sounds like the refresh rate is too low. Can you check which refresh rate your TV is operating at, while you see the tearing? I encounter tearing if I force the menu to be 24Hz (which is actually only meant for movie playback). The GUI should usually run at 60Hz without any tearing hmmm...
infinity85
 
Posts: 337
Joined: Tue May 24, 2016 4:26 am
languages_spoken: english, german
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Thu Jun 09, 2016 10:49 am

infinity85 wrote:
richpags wrote:
[...]
Probably been discussed, but anyone having some lag and tearing during menu navigation? Using confluence.
[...]


Sounds like the refresh rate is too low. Can you check which refresh rate your TV is operating at, while you see the tearing? I encounter tearing if I force the menu to be 24Hz (which is actually only meant for movie playback). The GUI should usually run at 60Hz without any tearing hmmm...


Cheers for that,

Display is set to 60Hz.

I wouldn't call it major tearing. More of a slight lag when navigating.

Don't think its an emmc issues as it should be fast enough.

Thanks
Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Thu Jun 09, 2016 11:55 am

wrxtasy wrote:Also included in this test version:
- all the additions from the Experimental version on Page #1
- a fix for the Single Top left pixel problem
- Raybuntu's latest CEC patch to turn HDMI CEC control off completely if you select the disable option in the boot.ini file on the SD card (setenv hdmi_cec "0"). To disable CEC completely you will still have to disable the CEC Adapter in Kodi as well.

LibreELEC-Odroid_C2.aarch64-7.0.1.Resolutions.HDMI-CEC.tar

I can confirm that the top-left-pixel issue appears to be resolved. However, this build no longer bitstreams DTS-HD MA or Dolby TrueHD. In fact, those options are missing entirely from System --> Audio Output. Only AC3, AC3 Transcoding and DTS are available for selection.
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Thu Jun 09, 2016 3:27 pm

MidnightWatcher wrote:
wrxtasy wrote:I can confirm that the top-left-pixel issue appears to be resolved. However, this build no longer bitstreams DTS-HD MA or Dolby TrueHD. In fact, those options are missing entirely from System --> Audio Output. Only AC3, AC3 Transcoding and DTS are available for selection.


i am confused now... on official Kodi forum is this:

ODROID C2 LibreELEC HDMI Audio support list:
+ Passthrough of AC3/DD/DTS 5.1 (Lossy)
+ Passthrough of Dolby True HD 5.1 and 7.1 / ATMOS (Lossless)
+ Passthrough of DTS-HD MA/HRA 5.1 and 7.1 (Lossless)
+ Passthrough of DTS 96/24
~ 5.1 / 7.1 DTS-HD MA/HRA - the 5.1 Core will be output if you deselect DTS-HD capable receiver in settings Fixed !

is it temporary disabled again or removed completely ?!
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Thu Jun 09, 2016 7:25 pm

No confusion at all..
Test build, some code inadvertently broke something else and that is why the very recent .tar is not posted up on page #1 where the pretty stable stuff belongs.
Just use any of the other versions and update again to fix audio issues.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby pandaadnap » Fri Jun 10, 2016 12:35 am

Hi

Your distrib is great (the only one I found that works on my 4K TV).

Will you upstream your changes to the libreelec main repo and adapt them to Libreelec 8.0?

Thanks
pandaadnap
 
Posts: 8
Joined: Sat May 28, 2016 5:34 pm
languages_spoken: english, french
ODROIDs: c2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Fri Jun 10, 2016 12:44 am

pandaadnap wrote:Hi

Your distrib is great (the only one I found that works on my 4K TV).

Will you upstream your changes to the libreelec main repo and adapt them to Libreelec 8.0?

Thanks

https://libreelec.tv/2016/06/libreelec- ... 001-alpha/
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Fri Jun 10, 2016 2:20 am

wrxtasy wrote:No confusion at all..
Test build, some code inadvertently broke something else and that is why the very recent .tar is not posted up on page #1 where the pretty stable stuff belongs.
Just use any of the other versions and update again to fix audio issues.


Thx buddy - didnt know that
after go back to "regular" version i have DTS-HD Options again :)

thx
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby infinity85 » Fri Jun 10, 2016 8:01 am

schimi2k wrote:Hey wrxtasy,
i have tested around a bit with my 3D-Material what i have here and i have noticed something:
using >>> LibreELEC-Odroid_C2.aarch64-7.0.1.3D.ISO.MySQL.tar

1. i have just test it on my Grundig LED TV yet. Will keep testing with my main Eqipment here in my Livingroom the next days (Onkyo Receiver, Samsung LED TV and Benq Projector )
2. You have to config Kodi like this:
Settings >> System Settings >> Video Output > -Preferred mode: Same as Movie
Settings >> Video Settings >> Playback > Playbackmode of Stereoscopic 3D Videos: Ask Me ( important ! ) - if i choose "Preferred Mode" it doesnt work !!!
Settings >> Video Settings >> Bluray playback Mode: Show simplified Menu

ok, i tested some 3D-Isos and MVC files out of those 3D-Isos ( with makemkv )

3D-Isos: ( i have test this with 6 different 3D-Iso files - full screen, cartoons, 16:9 etc )
name it like this ( for example ) : Dredd (2012).bluray.3DFP.iso >>> i have read in another Board about this "FP" after the 3D
- click on the file
- contextmenu is popping up - choose "Play in 3D"
- ok, on this point i have sometimes different results:
1. you see a TAB screen ! ( Top and Bottom ) - you have to go to OSD Options > 3D and choose again TAB ! - RESULT: Kodi switch to 3D mode AND my TV switch to the right 3D Mode TOO !!!! ( picture is kind of blurry ) - If you are using CONFLUENCE you have to choose "activate 3D mode"
2. You will ask what mode you will use - i choose TAB and Kodi and TV goes direct to right 3D Mode

Means: 3D Isos are working here like a charm AND TV switch direct to the right 3D Mode

MVC.mkv files: ( i have test this with 3 MVC movies )
name it like this ( for example ) : Cars 2 (2011).bluray.3DFP.mkv ( This one with Headermode:3 - others with 13 by default by Makemkv )
- click on the file
- contextmenu is popping up - choose "TAB"
Kodi and TV is switching direct to the right 3D Mode without any skip frames or so - plays normal without any problems!!!!
when i stop the movie 3D Mode stops too ( i have set it up in settings to do so !! )

!!!PROBLEM !!! sometimes i get a strange resolution after i stop the movie ! realy strange ones ( dont write it down, but something like 1201x402 or such weird numbers ) - when i click on the file again, i get the contextmenu again - start the movie in right 1920x1080 res and after another stop it was okay again ... happens 3 times i think

Means: 3D MVCs are working here too AND TV switch direct to the right 3D Mode
here is a SAMPLE of "Cars 2" mvc: >>> DOWNLOAD HERE <<<


EDIT 1: 08.06.2016
i have tested now also on my Samsung TV and on my Benq 1070+ Projector - same results - Movies start direct in 3D with the options i have post above this text on those devices

i also test some FULL-SBS and FULL-TAB files ( edit the header video display to show it in right aspect ) - same results - after start, kodi and TV switch to the right 3D Mode
( and this time i think its real full HD... movie info shows my 1920x2180 on TAB ) - but maybe i am wrong again ... but i think the full-sbs/tab movies are a lill bit sharper ( with double the file size !!! )


Sorry for quoting the while post, but it might be better having everything on first sight...

I followed all your descriptions and can not reproduce the TV autoswitch to 3D no matter how many files and times I try. Also tried enabling auto adjust of display framerate and so on (which was off by default). Also all your mentioned settings are the default settings. If you changed something, perhaps you mixed something in your settings description? I also tested with your provided cars sample file :/

Or better... could you make a backup of your settings (in LibreELEC program) and provide me the zip-file? I'd like to test it with your configuration.

My odroid is connected directly to my Philips LED TV (2012 Series 42PFL6907K).

EDIT:
As I have the identical TX-NR616 Onkyo AVR I hooked the odroid to it and ended with same results, no 3D autoswitch :/
infinity85
 
Posts: 337
Joined: Tue May 24, 2016 4:26 am
languages_spoken: english, german
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Fri Jun 10, 2016 10:36 am

Hey

Anyone experiencing when playing content, the video starts around 10sec in and not the beginning?

Strange stuff.

Thanks
Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Fri Jun 10, 2016 11:02 am

richpags wrote:Hey

Anyone experiencing when playing content, the video starts around 10sec in and not the beginning?

Strange stuff.

Thanks
Richie

Yes. It seems to either skip or immediately sputter/fast-forward to begin smooth playback closer to the 7-second mark, almost like it were trying to sync audio/video somehow. Happens on virtually every video, except for some very short 10-15 second video bumpers. Share your setup and settings. Here is mine:

C2 @ 1080p/60 (Adjust refresh rate is OFF)
C2 > Pioneer VSX824 > Epson 5030UB Projector
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Fri Jun 10, 2016 11:29 am

My settings:

1080p/60Hz
Adjust refresh rate: Always
Pause during refresh rate change: Off
Sync playback to display: Checked

Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby MidnightWatcher » Fri Jun 10, 2016 11:32 am

Is your C2 connected directly to a receiver or HDTV?
MidnightWatcher
 
Posts: 52
Joined: Wed Mar 02, 2016 1:50 am
languages_spoken: english
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby richpags » Fri Jun 10, 2016 11:50 am

MidnightWatcher wrote:Is your C2 connected directly to a receiver or HDTV?


No receiver.

Direct to HDTV with Yamaha soundbar.

Richie
Richard Pagliaro
Reel Movie Posters
https://reelmovieposters.com.au
richpags
 
Posts: 20
Joined: Mon Jun 06, 2016 8:10 pm
Location: Melbourne, Victoria, Australia
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby ditronics » Fri Jun 10, 2016 3:32 pm

richpags wrote:Hey

Anyone experiencing when playing content, the video starts around 10sec in and not the beginning?

Strange stuff.

Thanks
Richie


Yep I have the same issue.

The C2 is connected to a sound blaster x fi pro 5.1

Very laggy playback when passthough is activated and clics and noise when is not. I have a RPI3 running LibreELEC 7..0.1 working fine connected to the same devices.

Saludos.
ditronics
 
Posts: 4
Joined: Sun May 22, 2016 7:09 pm
languages_spoken: english, spanish
ODROIDs: C2 + XU4

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Fri Jun 10, 2016 3:59 pm

same here ( had it on my pi2 too )
time skip between 7-10 secs
1920x1080
24,50,60 fps - doesnt matter
Adjust refresh rate: Always
Pause during refresh rate change: Off ( tested also some numbers... 2sec,and some other )
Sync playback to display: Checked

connected direct to tv ( Grundig TV )
connected over Onkyo AV Receiver to Samsung TV and Benq Projector
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby schimi2k » Fri Jun 10, 2016 4:05 pm

infinity85 wrote:
i skip the other quotes ;)

I followed all your descriptions and can not reproduce the TV autoswitch to 3D no matter how many files and times I try. Also tried enabling auto adjust of display framerate and so on (which was off by default). Also all your mentioned settings are the default settings. If you changed something, perhaps you mixed something in your settings description? I also tested with your provided cars sample file :/

Or better... could you make a backup of your settings (in LibreELEC program) and provide me the zip-file? I'd like to test it with your configuration.

My odroid is connected directly to my Philips LED TV (2012 Series 42PFL6907K).

EDIT:
As I have the identical TX-NR616 Onkyo AVR I hooked the odroid to it and ended with same results, no 3D autoswitch :/


dont know where to save my settings ?! i just can make a backup of my system - but this will give me a 2.8gb tar file ;)
maybe my guisettings.xml can help you ? just send me a PM ( i think in German would be easier )
just quick check:
did you use the experimental 3D.Iso version from page 1 ? ( not the regular one )
are your files named like i wrote ?
are your header set to the right method ? ( sbs or tab )
Onkyo 616 - Samsung UE46 D6200 - Benq 1070+ - Hama VRC-1100 - odroid c2+le+madnox
schimi2k
 
Posts: 22
Joined: Fri Jun 03, 2016 4:32 pm
languages_spoken: english, German
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby stajlus » Fri Jun 10, 2016 5:54 pm

ditronics wrote:
richpags wrote:Hey

Anyone experiencing when playing content, the video starts around 10sec in and not the beginning?

Strange stuff.

Thanks
Richie


Yep I have the same issue.

The C2 is connected to a sound blaster x fi pro 5.1

Very laggy playback when passthough is activated and clics and noise when is not. I have a RPI3 running LibreELEC 7..0.1 working fine connected to the same devices.

Saludos.


Hi there.

First of all: a big thank you to wrxtasy for some really great work, almost everything works perfectly.

Yes, I also have the same issue, videos starts at 7-10 seconds in.
I run at 1080p/60 and adjust refresh rate is OFF.

Since this has been going on for a while I did some tests;
If I revert to release "LibreELEC-Odroid_C2.aarch64-7.0.0.Add.CEC.remote.ms.options" everything plays back perfectly, no skips at all.
If I use any newer version then it skips and starts at 7-10 seconds in.
If I use any newer version and disable amcodec HW-acceleration then everything plays back fine.

I hope that this can steer you guys in the right direction.
stajlus
 
Posts: 3
Joined: Fri Jun 10, 2016 5:33 pm
languages_spoken: english
ODROIDs: C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby peak3d » Fri Jun 10, 2016 6:45 pm

@wrxtasy: Are there plans to provide either git access to your work or an alpha version with kodi 17 and inputstream binary addons?
I would like to switch to libreelec, but this fork does not seem to have these addons included.

I could update my kodi 17 branch (https://github.com/mapfau/xbmc, branch c1_master) wich contains most of the oversun changes for AMLogic.
Still waiting for one more fix of codesnake regarding stream sync, but if this works you should give it a try to let people wattch amazon / skygo (and in a few days youtube HD) again.
peak3d
 
Posts: 267
Joined: Wed Jan 28, 2015 8:12 pm
languages_spoken: english,german
ODROIDs: XU3,C1

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby peak3d » Fri Jun 10, 2016 7:14 pm

@wrxtasy: have you ever tried to activate amlogics "deinterlace" driver instead using kodi's s/w pendants?
I'm not sure if amlogic drivers activates this deinterlace driver automagically, you could try to activate it echoing it to the default vfm map path (/sys/class/vfm/map)
peak3d
 
Posts: 267
Joined: Wed Jan 28, 2015 8:12 pm
languages_spoken: english,german
ODROIDs: XU3,C1

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby Raybuntu » Fri Jun 10, 2016 7:38 pm

pandaadnap wrote:Hi

Your distrib is great (the only one I found that works on my 4K TV).

Will you upstream your changes to the libreelec main repo and adapt them to Libreelec 8.0?

Thanks

Thats the plan. But there are some issues with krypton and codesnake is working on a new amlogic adapter to work with krypton.
BTC: 13M7sUBpS9uVpo4mzukV9CH8HGg7vDUC7Y
Raybuntu
 
Posts: 1163
Joined: Mon Nov 30, 2015 4:23 pm
languages_spoken: english, german
ODROIDs: C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Fri Jun 10, 2016 7:40 pm

- Adjust Refresh Rate Should be set to Start / Stop
- Sync Playback to display should be Off
- Pause is dependent on TV refresh rate switching speed.

I have not even looked at Krypton in great detail yet as amcodec playback was not reliable at all, due to master clock timing changes in Kodi and a bunch of other issues. WeTeK have the skills to fix this, namely Codesnake. Expect broken releases if anything with no support till major playback issues get fixed.
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby infinity85 » Fri Jun 10, 2016 10:42 pm

wrxtasy wrote:[...]
- Pause is dependent on TV refresh rate switching speed.
[...]


I doubt this is true, though you mentioned it a few times now. Some users mentioned this problem here in this thread already and I have it also sporadically in one out of 10 times perhaps. The point is: I can certainly say that my TV is not switching the refreshrate in those cases as I see the refreshrate switch just before this black screen appears. My TV is flashing (because of refresh rate switch) and switches successfully (no flashing anymore) and outputs a clear black picture (not turned off backlit) whereas I can even press pause and see no picture but do have sound. Then the picture appears suddenly somewhen without any typical refreshrate-switch-flashing of backlit. There is some kind of odd thing about it, it is certainly not just a long refreshrateswitch (this takes about 1s on my TV and I always set this 1s as a delay in settings).
infinity85
 
Posts: 337
Joined: Tue May 24, 2016 4:26 am
languages_spoken: english, german
ODROIDs: Odroid C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby wrxtasy » Sat Jun 11, 2016 4:57 am

Ok I have now seen the approx. 10 second lag in video startup with Audio Playing in the background, this fixed it for me:

Settings > System > Audio Output > Keep Audio Device Alive > Do NOT select "Always" ;)
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: LibreELEC 7.0.1 - Kodi Jarvis 16.1

Unread postby stajlus » Sat Jun 11, 2016 6:00 am

wrxtasy wrote:Ok I have now seen the approx. 10 second lag in video startup with Audio Playing in the background, this fixed it for me:

Settings > System > Audio Output > Keep Audio Device Alive > Do NOT select "Always" ;)



Great find! Playback starts instantly with the newest stable "May 28" release now.

I did however need to set mine to "Never", had it on "1 min" from the very beginning and that didn't work.
stajlus
 
Posts: 3
Joined: Fri Jun 10, 2016 5:33 pm
languages_spoken: english
ODROIDs: C2

PreviousNext

Return to LibreELEC - Kodi Project for C1/C2

Who is online

Users browsing this forum: No registered users and 3 guests