[SOLVED in v2.3] Multiple USB devices problem

Post Reply
krzysztofek
Posts: 32
Joined: Mon Dec 07, 2015 10:00 pm
languages_spoken: english, polish
ODROIDs: C1, C1+, C2, U3, XU4
Has thanked: 0
Been thanked: 0
Contact:

[SOLVED in v2.3] Multiple USB devices problem

Post by krzysztofek »

Hello,

I have a problem with 5.1.1. It's common bug for Android 5.x: I can't work with 2 serial USB devices. I found thats the Android 5.x bug. On 4 and 6 all works ok.

See that topic, also fix is available: https://code.google.com/p/android/issue ... ?id=159897

Is it possible to add patch in next release of your software? Or I need to do this myself? (I never compiled Android so It's a little problem for me :) )

If you have tutorial for how to build for example your version v 2.2 also would be great, I'm trying to know something :)

Best regards, Christopher.
Last edited by krzysztofek on Tue Oct 04, 2016 6:59 pm, edited 2 times in total.

Luke.go
Posts: 522
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 59 times
Been thanked: 60 times
Contact:

Re: Multiple USB devices problem

Post by Luke.go »

Hi there!

Thanks for your help!

This bug fix will be patched next release!..maybe :D

I think you can apply it.

How to:
1) Download services.jar and services.odex files from below.

http://dn.odroid.com/S905/temp/

2) push the files by adb

Code: Select all

$> adb shell mount -o remount,rw /system
$> adb push services.jar /system/framework/
$> adb push services.odex /system/framework/arm/
$> adb reboot
after reboot, you can check the result.

I hope it work!

krzysztofek
Posts: 32
Joined: Mon Dec 07, 2015 10:00 pm
languages_spoken: english, polish
ODROIDs: C1, C1+, C2, U3, XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Multiple USB devices problem

Post by krzysztofek »

Thanks for the reply!

After normal reeboot command I have a problem with android starting. Only after pushing files and adb reboot all starting normal. After normal reboot waiting 20 minutes on Android loading logo and nothing or sometimes start, showing optimizing apps and then start. When I have connected my devices it won't start even after 30 minutes. Now i try without connected devices and connect them after adb reboot, but I need time because I need to go home where i cant check this. I tested on 2.1 and fresh 2.2. Always need to wait long time to start system if not pushing and adb reboot

Luke.go
Posts: 522
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 59 times
Been thanked: 60 times
Contact:

Re: Multiple USB devices problem

Post by Luke.go »

Hi!
That is very weird. I haven't that problem.
Can you get log by using 'logcat' or 'dmesg'?
And here is original files that wasn't patched.

http://dn.odroid.com/S905/temp/services_original/

By the way, patch is worked? or not? I want to know that result.

krzysztofek
Posts: 32
Joined: Mon Dec 07, 2015 10:00 pm
languages_spoken: english, polish
ODROIDs: C1, C1+, C2, U3, XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Multiple USB devices problem

Post by krzysztofek »

Ok, finally I tested with my devices.

Worked fine! With no problems.

But there is still a problem with booting the system. Checked on adb Linux, and windows, 3 different C2. On fresh install only boots up normally once after adb reboot. Next reboot or plug-out, plug-in and I see only Android logo.

Working to give you dmesg and logcat.

Also original services don't helped. The same result. Maybe something wrong with the command?

Edit: attaching dmesg and logcat(cancelled writing because see that this is infinite)

Edit 2: tried to manually copy the files on sd card - the same result. For the first time: optimizing app of 72, all works ok. After plug-out-plug-in: Android logo
Attachments
logcat.txt
(1.08 MiB) Downloaded 71 times
dmesg.txt
(56.53 KiB) Downloaded 59 times

Luke.go
Posts: 522
Joined: Mon May 30, 2016 1:55 pm
languages_spoken: english
Has thanked: 59 times
Been thanked: 60 times
Contact:

Re: Multiple USB devices problem

Post by Luke.go »

Hi, krzysztofek!

In my opinion, services.jar had some problem by pushing command. But it's not our fault.
Android system sometimes made problem like this.
Unfortunately, You have to reinstall Android OS to fix the long time booting. I'm sorry about it. :(
And, please wait next android (maybe v2.3). It contains the patches.

krzysztofek
Posts: 32
Joined: Mon Dec 07, 2015 10:00 pm
languages_spoken: english, polish
ODROIDs: C1, C1+, C2, U3, XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Multiple USB devices problem

Post by krzysztofek »

Hi,

If you not encountered this problem, maybe you can create .img file of your sd card with working patched version? Then compress and send me a link. For now it would be very helpful for me.

I saw that some guys, some time ago have the same problem, it could be useful also for them.

For what version of android your .odex .jar file are?

Best regards, Christopher.

User avatar
odroid
Site Admin
Posts: 34943
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 959 times
Been thanked: 775 times
Contact:

Re: Multiple USB devices problem

Post by odroid »

We have a plan to release a new update in the middle of next week.
Please be patient.

krzysztofek
Posts: 32
Joined: Mon Dec 07, 2015 10:00 pm
languages_spoken: english, polish
ODROIDs: C1, C1+, C2, U3, XU4
Has thanked: 0
Been thanked: 0
Contact:

Re: Multiple USB devices problem

Post by krzysztofek »

Thank you very much.
So I'm waiting :)
Edit:
PROBLEM SOLVED in software version 2.3.
Thank you Odroid Team! Your are great! :)

Post Reply

Return to “Android”

Who is online

Users browsing this forum: No registered users and 2 guests