window drag laggin

Post Reply
ntc
Posts: 11
Joined: Thu May 01, 2014 5:28 pm
languages_spoken: english, polish
ODROIDs: 3x Odroid-U3
Has thanked: 0
Been thanked: 0
Contact:

window drag laggin

Unread post by ntc » Fri Jun 28, 2019 3:36 am

Hi,
I just got my C2 with Ubuntu Mate 18.04.2 LTS aarch64, Kernel: 3.16.68-41. Clean, then I did update & upgrade & reboot.

And it's slooooow, here's how slow it is:
https://youtu.be/i85aAKAVPlg

Not mentioning chrome + youtube videos ;)

CPU governor is set to performance with 1.54 GHz speed.

And my glmark results seems slow as well /with SceneTerrain error/:

Code: Select all

=======================================================
    glmark2 2014.03+git20150611.fa71af2d
=======================================================
    OpenGL Information
    GL_VENDOR:     ARM
    GL_RENDERER:   Mali-450 MP
    GL_VERSION:    OpenGL ES 2.0
=======================================================
[build] use-vbo=false: FPS: 107 FrameTime: 9.346 ms
[build] use-vbo=true: FPS: 153 FrameTime: 6.536 ms
[texture] texture-filter=nearest: FPS: 166 FrameTime: 6.024 ms
[texture] texture-filter=linear: FPS: 161 FrameTime: 6.211 ms
[texture] texture-filter=mipmap: FPS: 167 FrameTime: 5.988 ms
[shading] shading=gouraud: FPS: 137 FrameTime: 7.299 ms
[shading] shading=blinn-phong-inf: FPS: 142 FrameTime: 7.042 ms
[shading] shading=phong: FPS: 124 FrameTime: 8.065 ms
[shading] shading=cel: FPS: 123 FrameTime: 8.130 ms
[bump] bump-render=high-poly: FPS: 99 FrameTime: 10.101 ms
[bump] bump-render=normals: FPS: 163 FrameTime: 6.135 ms
[bump] bump-render=height: FPS: 161 FrameTime: 6.211 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 122 FrameTime: 8.197 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 84 FrameTime: 11.905 ms
[pulsar] light=false:quads=5:texture=false: FPS: 166 FrameTime: 6.024 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 69 FrameTime: 14.493 ms
[desktop] effect=shadow:windows=4: FPS: 135 FrameTime: 7.407 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 41 FrameTime: 24.390 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 62 FrameTime: 16.129 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 44 FrameTime: 22.727 ms
[ideas] speed=duration: FPS: 124 FrameTime: 8.065 ms
[jellyfish] <default>: FPS: 126 FrameTime: 7.937 ms
Error: SceneTerrain requires Vertex Texture Fetch support, but GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS is 0
[terrain] <default>: Unsupported
[shadow] <default>: FPS: 125 FrameTime: 8.000 ms
[refract] <default>: FPS: 39 FrameTime: 25.641 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 170 FrameTime: 5.882 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 137 FrameTime: 7.299 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 156 FrameTime: 6.410 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 156 FrameTime: 6.410 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 129 FrameTime: 7.752 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 151 FrameTime: 6.623 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 151 FrameTime: 6.623 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 147 FrameTime: 6.803 ms
=======================================================
                                  glmark2 Score: 126 
=======================================================
At least comparing to viewtopic.php?f=169&t=32918

Any suggestions what should I do to make it work in more civil way? :)
Thank you

User avatar
mad_ady
Posts: 6136
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 118 times
Been thanked: 81 times
Contact:

Re: window drag laggin

Unread post by mad_ady » Fri Jun 28, 2019 4:26 am

Disable compositor, check you are using fbturbo driver.

ntc
Posts: 11
Joined: Thu May 01, 2014 5:28 pm
languages_spoken: english, polish
ODROIDs: 3x Odroid-U3
Has thanked: 0
Been thanked: 0
Contact:

Re: window drag laggin

Unread post by ntc » Fri Jun 28, 2019 5:08 am

so I ran

Code: Select all

mate-tweak
to disable compositor.
But ruinig it I got:

Code: Select all

mate-tweak 
MESA-LOADER: failed to retrieve device information
libGL error: unable to load driver: mali_drm_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: mali_drm
Window Manager is: marco
Current layout: familiar
also

Code: Select all

glxinfo |grep -i opengl
MESA-LOADER: failed to retrieve device information
libGL error: unable to load driver: mali_drm_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: mali_drm
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 7.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.2.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.2.8
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
also

Code: Select all

sudo apt install xserver-xorg-video-fbdev xserver-xorg-video-fbturbo
Reading package lists... Done
Building dependency tree       
Reading state information... Done
xserver-xorg-video-fbdev is already the newest version (1:0.4.4-1build6).
xserver-xorg-video-fbturbo is already the newest version (2:6.4.0+2018-06-13-hk1ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
what should I do?

User avatar
mad_ady
Posts: 6136
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1, H2, N2
Location: Bucharest, Romania
Has thanked: 118 times
Been thanked: 81 times
Contact:

Re: window drag laggin

Unread post by mad_ady » Fri Jun 28, 2019 6:00 am

Not having opengl support is normal. You have gles.
Try reinstalling mali as well: sudo apt-get install --reinstall mali-x11

User avatar
odroid
Site Admin
Posts: 31297
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Has thanked: 44 times
Been thanked: 179 times
Contact:

Re: window drag laggin

Unread post by odroid » Fri Jun 28, 2019 9:26 am

Did you set "Marco (No compositor)" option in Mate-Tweak windows menu?

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 2 guests