Youtube Addon on kodi 17.3 crashing kodi

Moderators: mdrjr, odroid

Youtube Addon on kodi 17.3 crashing kodi

Unread postby nethawk80 » Thu Sep 28, 2017 8:26 pm

Hello All,


I did a fresh install of Ubuntu 16.4 on C2 and upgraded ubuntu and kodi to 17.3.I see that the youtube addon is frequently crashing entire kodi and falling back to desktop.
I can play videos in 1080p videos in kodi and it is playing properly.

The kodi log does not have anything.

Has anyone experienced this? or any suggestion to troubleshoot?
nethawk80
 
Posts: 3
Joined: Thu Sep 28, 2017 9:33 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby odroid » Fri Sep 29, 2017 8:29 am

Update the system and you will have Kodi 17.4.
Code: Select all
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install linux-image-c2
sudo reboot

And try Youtube plugin again.

If you use your own account instead of "odroid", you might need to change the privileges.
https://wiki.odroid.com/odroid-c2/troub ... celeration
User avatar
odroid
Site Admin
 
Posts: 28532
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby nethawk80 » Fri Sep 29, 2017 9:32 am

Hi Odroid,

I had done this before, but any ways did it again and all were up to date.
But I still see the kodi verion is 17.3. Kodi was not updated.


Thanks
nethawk80
 
Posts: 3
Joined: Thu Sep 28, 2017 9:33 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby mdrjr » Mon Oct 02, 2017 8:18 am

Try again.. I double checked and 17.4 package is there :( Maybe you were too fast?
mdrjr
Site Admin
 
Posts: 11686
Joined: Fri Feb 22, 2013 11:34 pm
Location: Brazil
languages_spoken: english, portuguese
ODROIDs: -

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby nethawk80 » Sat Oct 07, 2017 2:55 pm

Yeah, I got it now. Thanks.
But my original problem is still present.
Youtube addon is frequently crashing kodi.
Any one else facing this problem, or is it just me?
nethawk80
 
Posts: 3
Joined: Thu Sep 28, 2017 9:33 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby rpcameron » Sun Oct 08, 2017 12:45 am

You could try the Kodi forums, or the GitHib repo of the addon to see if there are issues.

Also, I'll mirror the Kodi forum and say without a complete debug log, help will only be guesses.
rpcameron
 
Posts: 277
Joined: Sat Apr 30, 2016 7:24 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby Sherinkapotein » Tue Jan 02, 2018 1:48 am

same here.. No joy!! :(
Seems my entire point of getting the XU4 is lost
Sherinkapotein
 
Posts: 6
Joined: Sat Nov 11, 2017 1:20 am
languages_spoken: english

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby odroid » Tue Jan 02, 2018 10:09 am

Old openSSL related packages in Ubuntu 16.04 seem to crash the Kodi Youtube add-on.
https://bugs.launchpad.net/ubuntu/+sour ... ug/1636573

I've manually downloaded some packages and installed with following steps and Kodi Youtube addon is working on my ODROID-XU4 now. C1-series user can use this guide too.
Code: Select all
wget http://archive.ubuntu.com/ubuntu/pool/main/p/pyopenssl/python-openssl_16.1.0-1_all.deb                                                                     
wget http://turul.canonical.com/pool/main/p/python-cryptography/python-cryptography_1.7.1-2_armhf.deb
sudo apt install python-setuptools
sudo dpkg -i --force-breaks python-cryptography_1.7.1-2_armhf.deb python-openssl_16.1.0-1_all.deb
sudo dpkg --configure --force-breaks python-cryptography python-openssl


If you are an ODROID-C2 user, you need to download/install an arm64 package instead of armhf package.
Code: Select all
wget http://archive.ubuntu.com/ubuntu/pool/main/p/pyopenssl/python-openssl_16.1.0-1_all.deb                                                                     
wget http://turul.canonical.com/pool/main/p/python-cryptography/python-cryptography_1.7.1-2_arm64.deb
sudo apt install python-setuptools
sudo dpkg -i --force-breaks python-cryptography_1.7.1-2_arm64.deb python-openssl_16.1.0-1_all.deb
sudo dpkg --configure --force-breaks python-cryptography python-openssl
User avatar
odroid
Site Admin
 
Posts: 28532
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby Sherinkapotein » Fri Jan 05, 2018 8:01 pm

Thanks !! Will try it out

EDIT: IT WORKS!!!!
Sherinkapotein
 
Posts: 6
Joined: Sat Nov 11, 2017 1:20 am
languages_spoken: english

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Wed Feb 07, 2018 7:32 am

Hi,
I've tried your installation on ODROID-C2, but packages have different versions now, and it seems to fail (I used most probable next version guesses)...
Could you help? :|

# dpkg -i --force-breaks python-cryptography_1.9-1_arm64.deb python-openssl_16.2.0-1_all.deb
dpkg: regarding python-cryptography_1.9-1_arm64.deb containing python-cryptography:
python-cryptography breaks python-openssl (<< 16.0.0)
python-openssl (version 0.15.1-2build1) is present and installed.

dpkg: warning: ignoring breakage, may proceed anyway!
(Reading database ... 212357 files and directories currently installed.)
Preparing to unpack python-cryptography_1.9-1_arm64.deb ...
Unpacking python-cryptography (1.9-1) over (1.2.3-1ubuntu0.1) ...
Preparing to unpack python-openssl_16.2.0-1_all.deb ...
Unpacking python-openssl (16.2.0-1) over (0.15.1-2build1) ...
dpkg: dependency problems prevent configuration of python-cryptography:
python-cryptography depends on python-asn1crypto; however:
Package python-asn1crypto is not installed.
python-cryptography depends on python-idna (>= 2.1); however:
Version of python-idna on system is 2.0-3.

dpkg: error processing package python-cryptography (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-openssl:
python-openssl depends on python-cryptography (>= 1.3.4); however:
Package python-cryptography is not configured yet.

dpkg: error processing package python-openssl (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
python-cryptography
python-openssl
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby esco27 » Fri Feb 09, 2018 10:36 pm

try the following:

Code: Select all
wget http://de.archive.ubuntu.com/ubuntu/pool/main/p/python-idna/python-idna_2.5-1_all.deb
wget http://de.archive.ubuntu.com/ubuntu/pool/main/a/asn1crypto/python-asn1crypto_0.22.0-1_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/p/pyopenssl/python-openssl_16.2.0-1_all.deb
wget http://turul.canonical.com/pool/main/p/python-cryptography/python-cryptography_1.9-1_arm64.deb

dpkg --install python-asn1crypto_0.22.0-1_all.deb python-idna_2.5-1_all.deb python-cryptography_1.9-1_arm64.deb python-openssl_16.2.0-1_all.deb


Afterwards restart your odroid-c2:

Code: Select all
sync; systemctl reboot

In a short test afterwards I was able to use the youtube plugin without a crash.
esco27
 
Posts: 2
Joined: Thu May 04, 2017 6:07 pm
languages_spoken: english,german
ODROIDs: odroid-c2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Sat Feb 10, 2018 6:31 am

Thanks esco27,
but unfortunately this doesn't fix the problem that I have with live youtube videos... There seems to be some problem with the codec.
For example: https://youtu.be/y3niFzo5VLI whilst it is live... (If it is converted to an "archived" video it runs smoothly: https://youtu.be/aBr2kKAHN6M).

It's true that TLS may be involved:
Code: Select all
22:02:56.667 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The TLS connection was non-properly terminated.
22:02:56.667 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The specified session has been invalidated for some reason.
22:03:25.506 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The TLS connection was non-properly terminated.
22:03:25.517 T:547171635152    INFO: ffmpeg[7F65F88FD0]: [hls,applehttp] No longer receiving playlist 0
22:03:25.520 T:547171635152   DEBUG: Open - avformat_find_stream_info starting


Though I also see some strange codec problems, for example a framerate of 90000!:
Code: Select all
22:03:25.525 T:547171635152   DEBUG: Dll libamplayer.so was not found in path
22:03:25.525 T:547171635152 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
22:03:25.525 T:547171635152   DEBUG: SECTION:LoadDLL(libamcodec.so)
22:03:25.525 T:547171635152   DEBUG: Loading: libamcodec.so
22:03:25.527 T:547171635152    INFO: DVDVideoCodecAmlogic: Opened Amlogic Codec
22:03:25.527 T:547171635152   DEBUG: FactoryCodec - Video: am-h264 - Opened
22:03:25.527 T:547171635152   DEBUG: CVideoPlayerVideo::OpenStream - open stream with codec id: 28
22:03:25.527 T:547171635152   ERROR: CVideoPlayerVideo::OpenStream - Invalid framerate 90000, using forced 25fps and just trust timestamps
22:03:25.527 T:547171635152  NOTICE: Creating video thread
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby rpcameron » Sat Feb 10, 2018 10:48 am

After reading a thread at misc@openbsd.org, it seems the problem might be related to OpenSSL 1.1, and the incompatibilities it has with LibreSSL. The older python crypto libraries are built against LibreSSL, which is compatible with OpenSSL 1.0, but 1.1 breaks this compatibility. Newer python crypto libraries don't have this problem, but the issues seem to stem from trying to maintain compatibility with some projects that haven't updated yet. While the original source was Alpine Linux, I believe it affects most distros in trying to maintain compatibility with the greatest number of packages.

https://marc.info/?t=151818130200002
rpcameron
 
Posts: 277
Joined: Sat Apr 30, 2016 7:24 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Sat Feb 10, 2018 9:57 pm

That seems very plausible!
I had also problems with inputstream.rtmp addon in the past, and I'm using kodinerds version which for some reason seems to be linked to libressl 2.4 instead of openssl 1.0.2g that is the one installed on odroid-c2 :shock:
Now I don't know if this is the usual odroid-c2 + kodi 17.3 out-of-the-package configuration.

Nonetheless, openssl 1.1 is not available for using with odroid-c2 (Ubuntu 16.04), is it?

This problem does not seem to have an easy solution... :cry:
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby esco27 » Sat Feb 10, 2018 10:25 pm

you could try to compile openssl 1.1 by yourself.

https://www.c-rieger.de/installupdate-openssl/
esco27
 
Posts: 2
Joined: Thu May 04, 2017 6:07 pm
languages_spoken: english,german
ODROIDs: odroid-c2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Mon Feb 12, 2018 6:08 am

Yeah, I could - there're even quickly installable .deb packages (haven't tested them yet)...
The problem is that if previous odroid recipe is good, that is, if python-cryptography and python-openssl are the ones that fix the problem, then we have also to find versions of them compiled against openssl1.1.0: the last one I tested following the recipe was python-cryptography_1.9-1 and it contains one library that is compiled against openssl1.0.0:
Code: Select all
# dpkg -L python-cryptography|grep .so|xargs ldd
...
/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/_openssl.aarch64-linux-gnu.so:
        linux-vdso.so.1 => 
        libssl.so.1.0.0 => /lib/aarch64-linux-gnu/libssl.so.1.0.0
        libcrypto.so.1.0.0 => /lib/aarch64-linux-gnu/libcrypto.so.1.0.0
        libpthread.so.0 => /lib/aarch64-linux-gnu/libpthread.so.0
        libc.so.6 => /lib/aarch64-linux-gnu/libc.so.6
        /lib/ld-linux-aarch64.so.1
        libdl.so.2 => /lib/aarch64-linux-gnu/libdl.so.2
...

A simple replacement with an openssl 1.1.0 library probably won't run well... that haven't worked for me in the past (cores) :?
I think I should have to install openssl 1.1.0 and compile python-cryptography against it...
I'm not sure if this is feasible / the right path... Sounds good?
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby rpcameron » Mon Feb 12, 2018 7:05 am

circulosmeos wrote:Yeah, I could - there're even quickly installable .deb packages (haven't tested them yet)...
The problem is that if previous odroid recipe is good, that is, if python-cryptography and python-openssl are the ones that fix the problem, then we have also to find versions of them compiled against openssl1.1.0: the last one I tested following the recipe was python-cryptography_1.9-1 and it contains one library that is compiled against openssl1.0.0:
Code: Select all
# dpkg -L python-cryptography|grep .so|xargs ldd
...
/usr/lib/python2.7/dist-packages/cryptography/hazmat/bindings/_openssl.aarch64-linux-gnu.so:
        linux-vdso.so.1 => 
        libssl.so.1.0.0 => /lib/aarch64-linux-gnu/libssl.so.1.0.0
        libcrypto.so.1.0.0 => /lib/aarch64-linux-gnu/libcrypto.so.1.0.0
        libpthread.so.0 => /lib/aarch64-linux-gnu/libpthread.so.0
        libc.so.6 => /lib/aarch64-linux-gnu/libc.so.6
        /lib/ld-linux-aarch64.so.1
        libdl.so.2 => /lib/aarch64-linux-gnu/libdl.so.2
...

A simple replacement with an openssl 1.1.0 library probably won't run well... that haven't worked for me in the past (cores) :?
I think I should have to install openssl 1.1.0 and compile python-cryptography against it...
I'm not sure if this is feasible / the right path... Sounds good?

OpenSSL 1.1 is not ABI compatible with 1.0 or LibreSSL. If you replace OpenSSL, then everything that is built against it would need to be updated/changed, too. That's a lot of software ...
rpcameron
 
Posts: 277
Joined: Sat Apr 30, 2016 7:24 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Tue Feb 13, 2018 1:51 am

Well, I'm not planning to replace openssl 1.0.0: as you say that's infeasible!
I wouldn't even install openssl binary - I'd just install openssl 1.1.0 libraries (libcrypto.so.1.1, libssl.so.1.1) which can peacefully live with the previous version as the names are different.
Then I'd try to compile python-cryptography against those new libraries - if the problem is just python-cryptography, and so it directly uses openssl libraries throu its _openssl.aarch64-linux-gnu.so library, then this should suffice.
Problem is that I'm not sure if my problem with kodi can be reduced to just python-cryptography... :roll:
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby rpcameron » Tue Feb 13, 2018 2:09 am

circulosmeos wrote:Well, I'm not planning to replace openssl 1.0.0: as you say that's infeasible!
I wouldn't even install openssl binary - I'd just install openssl 1.1.0 libraries (libcrypto.so.1.1, libssl.so.1.1) which can peacefully live with the previous version as the names are different.
Then I'd try to compile python-cryptography against those new libraries - if the problem is just python-cryptography, and so it directly uses openssl libraries throu its _openssl.aarch64-linux-gnu.so library, then this should suffice.
Problem is that I'm not sure if my problem with kodi can be reduced to just python-cryptography... :roll:

The problem is that you haven't given a proper and full debug log from Kodi, and so I, not sure anyone can say what the root of your problem is. Also, what do they say in the Kodi forums? Surely you've sought help from the providers of the software you're actually having problems with, right ...
rpcameron
 
Posts: 277
Joined: Sat Apr 30, 2016 7:24 am
languages_spoken: english
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Sat Feb 17, 2018 9:15 am

Hi!

Also, what do they say in the Kodi forums? Surely you've sought help from the providers of the software you're actually having problems with, right ...


providers of the software? :?: No! - that would ruin all the funny of the lonely research, recode and patching!

No, seriously, I didn't find in internet the exact problem I had, and last messages here seemed near of what I described - in short: live streams in youtube didn't play well (stop, slow, close).

the problem that I have with live youtube videos... There seems to be some problem with the codec.
For example: https://youtu.be/y3niFzo5VLI whilst it is live... (If it is converted to an "archived" video it runs smoothly: https://youtu.be/aBr2kKAHN6M).

It's true that TLS may be involved:

Code: Select all
22:02:56.667 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The TLS connection was non-properly terminated.
    22:02:56.667 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The specified session has been invalidated for some reason.
    22:03:25.506 T:547171635152   ERROR: ffmpeg[7F65F88FD0]: [tls] The TLS connection was non-properly terminated.
    22:03:25.517 T:547171635152    INFO: ffmpeg[7F65F88FD0]: [hls,applehttp] No longer receiving playlist 0
    22:03:25.520 T:547171635152   DEBUG: Open - avformat_find_stream_info starting


Though I also see some strange codec problems, for example a framerate of 90000!:

Code: Select all
22:03:25.525 T:547171635152   DEBUG: Dll libamplayer.so was not found in path
    22:03:25.525 T:547171635152 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead
    22:03:25.525 T:547171635152   DEBUG: SECTION:LoadDLL(libamcodec.so)
    22:03:25.525 T:547171635152   DEBUG: Loading: libamcodec.so
    22:03:25.527 T:547171635152    INFO: DVDVideoCodecAmlogic: Opened Amlogic Codec
    22:03:25.527 T:547171635152   DEBUG: FactoryCodec - Video: am-h264 - Opened
    22:03:25.527 T:547171635152   DEBUG: CVideoPlayerVideo::OpenStream - open stream with codec id: 28
    22:03:25.527 T:547171635152   ERROR: CVideoPlayerVideo::OpenStream - Invalid framerate 90000, using forced 25fps and just trust timestamps
    22:03:25.527 T:547171635152  NOTICE: Creating video thread


Well, this is just to inform anyone who could reach this thread with the same problem, that it can be circumvented using a (newer) version of inputstream.adaptive addon:
I had the one from https://github.com/kodinerds/binary-repo/tree/master/offline/Odroid_C2/inputstream.adaptive: 1.0.7.
I've compiled version 2.0.19 from source ;)
and changed mode in youtube addon to MPEG-DASH in order to use it.
This way the live streams play correctly.
Any other combination didn't.

The exact cause of the problem remains unknown for me (it still may be related to some openssl problem as suggested in this thread).

Unfortunately youtube addon + DASH isn't as fluid as the default method for forwarding/rewinding videos (there are little holes without sound after doing that), so I won't use it for everyday use (probably things will get better in next versions), but at least I'll be able to use it for future live youtube events.
And yes, the last event I couldn't follow on TV because of this was the live launch of the Falcon Heavy.

Thanks all for your time!

PS: inputstream.adaptive-2.0.19.zip for ODROID-C2 + Kodi 17.6

PS2: nonetheless, MPEG-DASH have the advantage that youtube addon can play 1080p videos :P whilst the options without MPEG-DASH allow only for 1080p Live/ 720p (HD) (so 720p in general).

PS3: edited to correct source of inputstream.adaptive 1.0.7 and the real cause of the problem, which remains unknown.
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Wed Feb 21, 2018 4:53 am

After all the testing, now I'm almost convinced that python-cryptography compiled against openssl 1.1 could solve the problem.
And python-cryptography, following this:
https://cryptography.io/en/latest/installation/#static-wheels
could be made available to all odroid-c2 users as a static package without any openssl dependencies from the OS... :!:
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby circulosmeos » Mon Feb 26, 2018 5:12 am

Hi,
This is just to inform that the python-cryptography module (2.1.4) compiled against openssl 1.1.0f libraries on ODROID-C2 (Ubuntu 16.04.2) doesn't solve the problem of connectivity with live streams using the Kodi (17.6) youtube addon (v1.5.1) to play livestream videos...
Now I'm puzzled, 'cause the problem seems to be something (but not openssl related (?)) that inputstream.adaptive can do but the default connection method cannot ( :?: )
circulosmeos
 
Posts: 8
Joined: Tue Jul 25, 2017 2:34 am
languages_spoken: english
ODROIDs: ODROID-C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby odroid » Mon Feb 26, 2018 10:42 am

I hope the strange dependencies will be fixed in Ubuntu 18.04 a couple of months later.
Meanwhile, we have to force to install the openssl/cryptography packages manually.
User avatar
odroid
Site Admin
 
Posts: 28532
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby odroid » Mon Jun 11, 2018 11:19 am

Our Ubuntu 18.04 Mate image has no issue with Youtube Addon on Kodi 17.6 now.
User avatar
odroid
Site Admin
 
Posts: 28532
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby dante6913 » Tue Jun 12, 2018 1:34 am

odroid wrote:Our Ubuntu 18.04 Mate image has no issue with Youtube Addon on Kodi 17.6 now.


Odroid, when ubuntu 18.04 for odroid c2 will be available for download? :D
dante6913
 
Posts: 75
Joined: Sat Oct 01, 2016 7:16 am
languages_spoken: english, Portuguese
ODROIDs: C2

Re: Youtube Addon on kodi 17.3 crashing kodi

Unread postby odroid » Tue Jun 12, 2018 1:33 pm

My previous comment was based on XU4 Ubuntu 18.04 image.
I think C2 18.04 image will be ready 2~3 weeks later if everything goes well.
User avatar
odroid
Site Admin
 
Posts: 28532
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 3 guests