How can i turn off gpio RX/TX echo mode

Post Reply
Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

How can i turn off gpio RX/TX echo mode

Post by Won »

I'm using TX/RX (pins 8 and 10) port as UART on GPIO.
Odroid-C2's os is Android.

https://wiki.odroid.com/odroid-c2/appli ... /gpio/uart

PC -> Odroid-C2 sending a message, returns this message.

How can i turn off this return message?

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

There is no echo feature in the UART device driver.
It seems that you need to change the configuration in your host PC terminal program.
Otherwise, Tx and Rx pins are tied accidentally.

Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by Won »

odroid wrote:
Fri Aug 14, 2020 8:42 pm
There is no echo feature in the UART device driver.
It seems that you need to change the configuration in your host PC terminal program.
Otherwise, Tx and Rx pins are tied accidentally.
I tried another host PC terminal program and tried tied again, but the same thing happens.

1. odrioid : cat /dev/ttyS1
2. pc -> odroid send "testing", odroid -> pc, return "testing"

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

Which terminal program did run on your host PC?
Did you disable the local-echo function?

Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by Won »

odroid wrote:
Tue Aug 18, 2020 2:00 pm
Which terminal program did run on your host PC?
Did you disable the local-echo function?

I used several serial terminal programs for Windows. There is no local-echo function.

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

We couldn't reproduce the issue.
Can you show me a full picture of your wire connections between the C2 and the your PC?
Do you have an oscilloscope to see the data signal on the pin 8 and the pin 10?

Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by Won »

odroid wrote:
Tue Aug 18, 2020 5:54 pm
We couldn't reproduce the issue.
Can you show me a full picture of your wire connections between the C2 and the your PC?
Do you have an oscilloscope to see the data signal on the pin 8 and the pin 10?
Connected board chip is ft232rl.
Power is being supplied by the OTG pin.
Attachments
hardware.jpg
hardware.jpg (734.02 KiB) Viewed 369 times
com.PNG
com.PNG (19.06 KiB) Viewed 369 times
echo.PNG
echo.PNG (20.47 KiB) Viewed 369 times

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

Thank you for the pictures and oscilloscope capture. There seems to be a unexpected echo string obviously.
We will check it on the latest Android OS image with a C2 board tomorrow.

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

We've just tested with our official CP2104 based USB-UART cable and there was no echo issue at all.
We used the same C2 Android OS image.

Remove the Rx wire from the C2 board and capture the C2 Tx/Rx signal with the oscilloscope again.
It will tell use whether the ft232rl chip has an internal echo function or not.

BTW, do you run Android 5.1.1? or 6.0.1?

Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by Won »

odroid wrote:
Wed Aug 19, 2020 7:06 pm
We've justed test with our official CP2104 based USB-UART cable and there was no echo issue at all.
We used the same C2 Android OS image.

Remove the Rx wire from the C2 board and capture the C2 Tx/Rx signal with the oscilloscope again.
It will tell use whether the ft232rl chip has an internal echo function or not.

BTW, do you run Android 5.1.1? or 6.0.1?
I tried both versions(Android 5.1.1 and 6.0.1) yesterday. But the same thing happened.

1. Remove the Rx wire from the C2 board and capture the C2 Tx/Rx signal with the oscilloscope -> There was no return value.

2. Remove the Tx wire from the C2 board and capture the C2 Tx/Rx signal with the oscilloscope -> There was return value.
Attachments
connect.jpg
connect.jpg (431.54 KiB) Viewed 329 times
PCtoC2.PNG
PCtoC2.PNG (15.39 KiB) Viewed 329 times

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

We used selfinstall-odroidc2-eng-s905_6.0.1_master-122-v5.7.img for the test.

Anyway, is your picture showing "Remove the Rx wire"?
Rx and Tx are confusing.


Image

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

Did you install any application/service on the C2 Android?
We tested it just after freshly installing the OS image.

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

We could reproduce the issue only when we ran "cat" command to see the Rx strings.
That strange Android "cat" command returned the received string with 'LF' dummy via TX pin. :o

You might need to find or make an Android app to access the "/dev/ttyS1" node directly.

Won
Posts: 7
Joined: Fri Dec 28, 2018 2:50 pm
languages_spoken: english
ODROIDs: XU4, C2
Has thanked: 0
Been thanked: 0
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by Won »

odroid wrote:
Thu Aug 20, 2020 3:24 pm
Did you install any application/service on the C2 Android?
We tested it just after freshly installing the OS image.
I also used it just after freshly installing the OS image and access the "/dev/ttyS1" node directly from android terminal.

After booting, if you enter the 'cat' command at least once, the value is returned.

How can i solve this problem?

User avatar
odroid
Site Admin
Posts: 35266
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English, Korean, Japanese
ODROIDs: ODROID
Has thanked: 1074 times
Been thanked: 821 times
Contact:

Re: How can i turn off gpio RX/TX echo mode

Post by odroid »

You might need to find the source code of 'cat' command in the Android SDK.
But it might not be a simple task if you don't have any experience of building full Android OS source code.

Normally, other users made an Android app with a serial port API something like this.
https://code.google.com/archive/p/andro ... ult/source

Post Reply

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 1 guest