Android 4.4.4 UI Lags A Lot

Post Reply
brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Fri Nov 07, 2014 7:48 am

I recently flashed the 9/23 build of Android (odroidu-eng 4.4.4 KTU84Q) and all the benchmarks for everything say it is running fine, yet the GUI will be choppy and lag while transitioning between apps or scrolling through the settings, which is very annoying considering how powerful this board is. I have the board's CPU OC'd to 1.7 GHz and using the performance governor, I'm not sure what the GPU clock is set at though. I have it connected to my 40" flatscreen TV running at 1920x1032@160DPI

Also for some reason my overclock settings don't stick beyond reboot while using trickstermod to set them, any idea why?

User avatar
robroy
Posts: 3399
Joined: Mon Feb 25, 2013 2:29 am
languages_spoken: English
ODROIDs: Q2, X, X2, U2, U3, XU-E, XU3, XU4, C1, C1+, C2
Location: San Francisco, California
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by robroy » Fri Nov 07, 2014 8:12 am

Are you using an SD card? Android is very disk intensive and is tuned to run from eMMC at least 25 MB/s.
Rob Roy, Editor-in-Chief of ODROID Magazine (submit an article | make a donation)

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Fri Nov 07, 2014 9:15 am

Nope, forgot to mention that. I'm using the EMMC.

3DMark Benchmark scores using IceStorm Unlimited
Score: 3588
Graphics Score: 2988
Physics Score: 11758
Graphics Test 1: 9.6 FPS
Graphics Test 2: 20.3 FPS
Physics Test: 37.3 FPS

AndroBench Scores
Sequential Read: 25.16 MB/sec
Sequential Write: 3 MB/sec
Random Read: 5.38 MB/sec, 1379.42 IOPS (4K)
Randon Write: 0.14 MB/sec, 35.87 IOPS (4K)
SQLite Insert: 18.9 TPS, 15.87 seconds
SQLite Update: 23.65 TPS, 12.68 seconds
SQLite Delete: 35.84 TPS, 8.36 sec
Browser: 367.75 miliseconds
Market: 677.25 miliseconds
Camera: 576.5 miliseconds
Camcorder: 1884.5 miliseconds

Quadrant Scores
Total: 6344
CPU: 17220
Memory: 3667
I/O: 7377
2D: 1014
3D: 2480

mdrjr
Site Admin
Posts: 11698
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by mdrjr » Fri Nov 07, 2014 9:22 am

AndroBench Scores
Sequential Read: 25.16 MB/sec
Sequential Write: 3 MB/sec
This is _VERY_ wrong... And I'm almost sure its the cause of your issue.
What is the color of the PCB of your eMMC module?
How did you flashed the eMMC?

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Fri Nov 07, 2014 9:34 am

The color is green. I believe I wrote image using dd in Linux: sudo dd if=image.img of=/dev/sdg bs=2M

I did this about two weeks ago so I don't really remember. I was looking for the bootstrap image but couldn't find it because the links no longer work for goo.im

After getting it working I found that I have the CM11 bootstrap image on my RAID set, but didn't re-burn it to the EMMC.

Edit: I just ran androbench on my Galaxy Note 3 running AOSP for comparison and my seq read is 111.87 MB/sec and my Seq write is 3.11 MB/sec using the NOOP IO Scheduler. The UI barely lags at all, it is also running Android 4.4.4.

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Fri Nov 07, 2014 10:13 am

We will try about 3 different benchmark apps with the eMMC 4.5 8GB board on the U3 and the post the result here.

As far as I remember, the Quadrant 5.x score should be 30,000 at least.

Edit! Oops! I was confused the Quadrant & Antutu..
Quadrant score should be 6K~7K...

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Fri Nov 07, 2014 12:20 pm

Here are our test results with our official 4.4.4 image.

3DMark Benchmark scores using IceStorm Unlimited
Score: 3539
Graphics Score: 2978
Physics Score: 10395
Graphics Test 1: 9.4 FPS
Graphics Test 2: 20.7 FPS

AndroBench Scores
Sequential Read: 21.03 MB/sec
Sequential Write: 7.28 MB/sec
Random Read: 1157.43 IOPS (4K)
Randon Write: 168.42 IOPS (4K)

Quadrant Scores
Total: 6142
CPU: 16786
Memory: 4099
I/O: 7025
2D: 189
3D: 1611

Your scores are higher than our stock image due to your over-clocking.
But your eMMC write speed is slower significantly.

Try this utility (or dd with zero) to Wipe your eMMC.
http://forum.odroid.com/viewtopic.php?f=53&t=947

BTW, when did you purchase your eMMC module?
How did you connect the eMMC module to ODROID? via eMMC reader board? or directly?

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Fri Nov 07, 2014 12:40 pm

I'll wipe it with dd and then write the official image again using dd. I bought my Odroid at the end of March in 2013, it has only seen maybe a total of 6-9 months usage. The eMMC is connected directly to the Odroid.

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Tue Nov 11, 2014 1:39 pm

wiped it with dd and wrote pocket rocket 4.4 to it and ran AndroBench

Noop
SR: 28.01 MB/sec
SW: 1.79 MB/sec
RR: 10.92 MB/sec (2797.07 IOPS 4K)
RW: 0.21 MB/sec (56.16 IOPS 4K)


Deadline
SR: 27.86 MB/sec
SW: 3.87 MB/sec
RR: 10.62 MB/sec (2720.47 IOPS 4K)
RW: 0.12 MB/sec (32.97 IOPS 4K)

SIO
SR: 28.21 MB/sec
SW: 7.78 MB/sec
RR: 11.01 MB/sec (2,819.72 IOPS 4K)
RW: 0.2 MB/sec (52.86 IOPS 4K)

BFQ
SR: 27.86 MB/sec
SW: 7.37 MB/sec
RR: 10.77 MB/sec (2758.22 IOPS 4k)
RW: 0.22 MB/sec (57.04 IOPS 4k)


I switched the governor to SIO and it is a lot better but it still lags a little here and there.
Last edited by brando56894 on Wed Nov 12, 2014 3:08 am, edited 1 time in total.

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Tue Nov 11, 2014 5:48 pm

It seems to be improved a lot.

What is the IOPS values of RR&RW on SIO governor?

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Wed Nov 12, 2014 3:09 am

I added them above for all

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Wed Nov 12, 2014 10:04 am

Oh.. SIO governor made a lot of improvement.
But I think your eMMC has still lower random write performance and it might cause the intermittent lags.. probably.

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Wed Nov 12, 2014 10:13 am

so....it's defective?

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Wed Nov 12, 2014 2:59 pm

No. It might be just an old generation of eMMC technology.
When we launched the ODROID-U2/X2, we sold "eMMC 4.41" based eMMC module.
When we launched the ODROID-U3, we sold "eMMC 4.5" based eMMC module.
When we launched the ODROID-XU3, we sold "eMMC 5.0" based eMMC module.

brando56894
Posts: 101
Joined: Wed Apr 24, 2013 12:18 am
languages_spoken: english
ODROIDs: Odroid-U2, Odroid-XU4
Location: Hoboken, NJ
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by brando56894 » Wed Nov 12, 2014 3:54 pm

Oh ok, will the emmc 5 work with the u2?

User avatar
odroid
Site Admin
Posts: 29750
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Android 4.4.4 UI Lags A Lot

Unread post by odroid » Wed Nov 12, 2014 5:41 pm

Yes... Exynos4412 eMMC host controller is 4.41.
But the eMMC 5.0 is backward compatible.
I will post the AndroBench IOPS scores of eMMC 5.0 on U2/U3 within a couple of hours.

Edit :
AndroBench Scores with eMMC 5.0 16GB with Stock Android 4.4.4 ROM
Sequential Read: 23.13 MB/sec
Sequential Write: 13.18 MB/sec
Random Read: 4.1MB/s, 1050.03 IOPS (4K)
Randon Write: 0.63MB/s, 162.27 IOPS (4K)

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 13 guests