Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Post Reply
rspt1967
Posts: 4
Joined: Thu Jun 27, 2019 4:35 pm
languages_spoken: english
ODROIDs: Odroid XU4, Ocam 5CRO-U
Location: Philippines
Has thanked: 0
Been thanked: 0
Contact:

Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Unread post by rspt1967 » Thu Jun 27, 2019 4:46 pm

Good day,

I am currently using two oCAM-5CRO cameras for stereo capture datagathering. I found that the auto exposure on both cameras do not behave in the same manner. Sometimes, the other camera overcompensates by overly decreasing the exposure resulting in a very dark unusable image. Sample images below. Please help :(

Is there anyway to set a fixed exposure setting on the cameras? I tried to use the opencv_basic code for the 5CRO-U camera from withrobot's github, however they do not have any provision for exposure setting like in the CGN and MGN cameras.
Attachments
1030_6_imright.jpg
Overdecrease in exposure level (Right Camera)
1030_6_imright.jpg (25.21 KiB) Viewed 548 times
1030_6_imleft.jpg
Correctly exposed image (Left Camera)
1030_6_imleft.jpg (46.21 KiB) Viewed 548 times

WITHROBOT
Posts: 141
Joined: Mon Mar 14, 2016 1:54 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Unread post by WITHROBOT » Mon Jul 01, 2019 12:37 pm

We have identified the issue and are investigating into it.
We will update our result here once it is ready.

rspt1967
Posts: 4
Joined: Thu Jun 27, 2019 4:35 pm
languages_spoken: english
ODROIDs: Odroid XU4, Ocam 5CRO-U
Location: Philippines
Has thanked: 0
Been thanked: 0
Contact:

Re: Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Unread post by rspt1967 » Mon Jul 01, 2019 4:36 pm

WITHROBOT wrote:
Mon Jul 01, 2019 12:37 pm
We have identified the issue and are investigating into it.
We will update our result here once it is ready.
Thank you :) Looking forward to your reply.

WITHROBOT
Posts: 141
Joined: Mon Mar 14, 2016 1:54 pm
languages_spoken: english
ODROIDs: Odroid-C2
Has thanked: 0
Been thanked: 0
Contact:

Re: Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Unread post by WITHROBOT » Wed Jul 17, 2019 6:23 pm

We have identified that sometimes the auto exposure function does behave differently from our expectation.
Namely, with very similar input scenes, the exposures are set much differently by the auto exposure function.

The only way to resolve this issue is to override the auto exposure function of the internal ISP which is always ON by default.
We are trying to find a way to turn on/off this function manually, but unfortunately it is expected to take some time.

We will update the status when we have some progress.

rspt1967
Posts: 4
Joined: Thu Jun 27, 2019 4:35 pm
languages_spoken: english
ODROIDs: Odroid XU4, Ocam 5CRO-U
Location: Philippines
Has thanked: 0
Been thanked: 0
Contact:

Re: Exposure Setting 5CRO-U camera (Includes sample images) Opencv Ocam 5MP

Unread post by rspt1967 » Mon Sep 30, 2019 3:22 pm

Thank you, looking forward to it :)

Post Reply

Return to “oCAM USB 3.0 Camera”

Who is online

Users browsing this forum: No registered users and 1 guest