Disabling HDMI audio at runtime

Post Reply
User avatar
mad_ady
Posts: 5226
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Disabling HDMI audio at runtime

Unread post by mad_ady » Wed Jun 27, 2018 2:55 pm

For whatever reason (I think I messed with it too much), I'd like to temporarily disable HDMI audio (and have it disappear), either on boot (via a kernel parameter or dtb change), or at runtime so that I can run audio through the boom box. Any ideas what dtb nodes I need to change? Also booting ewithout a hdmi cable should accomplish the same thing, right?

User avatar
odroid
Site Admin
Posts: 29651
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Disabling HDMI audio at runtime

Unread post by odroid » Wed Jun 27, 2018 3:04 pm

XU4? or C2/C1?

User avatar
mad_ady
Posts: 5226
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: Disabling HDMI audio at runtime

Unread post by mad_ady » Wed Jun 27, 2018 3:47 pm

C2, sorry I forgot to mention

User avatar
odroid
Site Admin
Posts: 29651
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: Disabling HDMI audio at runtime

Unread post by odroid » Wed Jun 27, 2018 4:10 pm

I have no idea how to disable "ODROIDHDMI" node in device-tree.

Code: Select all

odroid@odroid64:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ODROIDHDMI [ODROID-HDMI], device 0: I2S.27 dit-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ODROIDDAC [ODROID-DAC], device 0: I2S.27 pcm5102-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
But, if you change vout mode to "dvi" in boot.ini file, HDMI sound must be disabled.
https://github.com/mdrjr/c2_bootini/blo ... ot.ini#L91

User avatar
mad_ady
Posts: 5226
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: Disabling HDMI audio at runtime

Unread post by mad_ady » Wed Jun 27, 2018 4:29 pm

I'll try, thanks!

User avatar
mad_ady
Posts: 5226
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: Disabling HDMI audio at runtime

Unread post by mad_ady » Sun Jul 01, 2018 5:38 am

I tried the following options:
* set dvi in boot.ini and rebooted. I could still see ODROID-HDMI as a sound output both in kodi and in aplay -L. The boom bonnet still refuses to play any sound (also checked board volume and headphone output). But it does click when rebooting/changing sound output.
* unplugged HDMI and rebooted. I get the same behavior as above.

I can't understand why I can no longer output sound on the boom bonnet (the software thinks it's playing fine, but there is no sound).

Any ideas what I should try next?

User avatar
mad_ady
Posts: 5226
Joined: Wed Jul 15, 2015 5:00 pm
languages_spoken: english
ODROIDs: XU4, C1+, C2, N1
Location: Bucharest, Romania
Contact:

Re: Disabling HDMI audio at runtime

Unread post by mad_ady » Sat Jul 07, 2018 10:00 pm

I replaced the boom bonnet with a usb sound card, and even if mpd thought it was playing just fine, pulseaudio didn't show volume fluctuations in the sound control. I tried next with mplayer -ao pulse::alsa_output.usb-0d8c_C-Media_USB_Headphone_Set-00.analog-stereo test.mp3 and sound was output just fine. Next I changed my mpd configuration and used alsa instead of pulse and mpd worked again.
I moved the boom bonnet on a c1+ and it worked without issues.
So in the end it looks like it's some weird mpd glitch...

Post Reply

Return to “I2S Devices (HiFi Shield DAC and Stereo Boom Bonnet Kit)”

Who is online

Users browsing this forum: No registered users and 2 guests