RaZberry on Odroid C1

Post Reply
shubbham03
Posts: 1
Joined: Mon Sep 14, 2015 9:54 pm
languages_spoken: english
ODROIDs: ODROID-C1
Contact:

RaZberry on Odroid C1

Unread post by shubbham03 » Tue Sep 15, 2015 10:19 pm

Hi

I am trying to connect the Z-wave card (http://razberry.z-wave.me/) through the IO pins, but the card is not being detected by the ubuntu running on the board (http://odroid.com/dokuwiki/doku.php?id= ... nux_ubuntu). I tried running "dmesg" but the hardware was not being detected.

Can you please tell me if there's an effective way to connect a Z-wave card on the Odroid C1 board?

Thanks in advance. :)

mdrjr
Site Admin
Posts: 11698
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Contact:

Re: RaZberry on Odroid C1

Unread post by mdrjr » Wed Sep 16, 2015 6:55 am

Looks like it uses the UART interface...

Check if you get any data on /dev/ttyS2
Its the Serial interface on the 40pin header.

Looks like its trying to use ttyAMA0

Just modify it to use ttyS2

cff
Posts: 1
Joined: Mon Nov 02, 2015 4:28 am
languages_spoken: english,french,italian
ODROIDs: C1,C1+
Contact:

Re: RaZberry on Odroid C1

Unread post by cff » Mon Nov 02, 2015 4:41 am

Just for reference, running the latest install script (razberry.z-wave.me/install) as of 20151101 it installed the files in /opt which is not what you'd expect (should be /opt/z-way-server/). As root :
  • Code: Select all

    #cd /opt
    #mkdir tmp
    #mv * tmp/
    #mv tmp z-way-server
    
  • edit /opt/z-way-server/automation/storage/configjson-06b2d3b23dce96e1619d2b53d6c947ec.json (filename might change) and change /dev/ttyAMA0 to /dev/ttyS2
  • restart the server

    Code: Select all

    service z-way-server restart
Enjoy!

Post Reply

Return to “Projects”

Who is online

Users browsing this forum: No registered users and 2 guests