How to disable LXDE at boot

Post Reply
Ali3n0id
Posts: 15
Joined: Sat Feb 21, 2015 9:38 pm
languages_spoken: english
ODROIDs: ODROID C1
Contact:

How to disable LXDE at boot

Unread post by Ali3n0id » Sat Feb 21, 2015 10:44 pm

I understand the ubuntu image doesn't use grub to boot so I can't change the '/etc/default/grub' file, what's the process of disabling GUI at boot time? Also within the console is it possible to start kodi or other GUI programs without LXDE running?

mdrjr
Site Admin
Posts: 11698
Joined: Fri Feb 22, 2013 11:34 pm
languages_spoken: english, portuguese
ODROIDs: -
Location: Brazil
Contact:

Re: How to disable LXDE at boot

Unread post by mdrjr » Sun Feb 22, 2015 1:00 am

Run odroid utility.. it allows you to disable xorg.

Ali3n0id
Posts: 15
Joined: Sat Feb 21, 2015 9:38 pm
languages_spoken: english
ODROIDs: ODROID C1
Contact:

Re: How to disable LXDE at boot

Unread post by Ali3n0id » Sun Feb 22, 2015 2:16 am

Thanks - I guess I run startx to run manually then.

Found another thread to see how to run kodi at boot.

cdhinrichs
Posts: 6
Joined: Sun Sep 11, 2016 5:24 pm
languages_spoken: english
ODROIDs: XU4, VU7+
Location: East Palo Alto, CA, USA
Contact:

Re: How to disable LXDE at boot

Unread post by cdhinrichs » Wed Nov 16, 2016 4:15 pm

The odroid manual says there's supposed to be an "ODROID Utility" on the desktop. (p. 28) There is not.

I found and downloaded an "odroid-utility.sh" from https://github.com/mdrjr/odroid-utility. In the menu it gives the option to disable Xorg. It says "You need to reboot your board to the new modifications take effects". I reboot. Xorg still loads.

How else do I disable Xorg?

Thanks

User avatar
odroid
Site Admin
Posts: 30028
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID
Contact:

Re: How to disable LXDE at boot

Unread post by odroid » Wed Nov 16, 2016 6:27 pm

The manual was written with Ubuntu 14.04 and the odroid-utility obsoleted.
So many things should be updated with 16.04. We consider making the manual 2nd edition.

Do you run Ubuntu Mate 16.04 image? or 14.04 LXDE image?

If your 16.04, try sudo systemctl disable lightdm.service on the CLI.

Post Reply

Return to “Ubuntu”

Who is online

Users browsing this forum: No registered users and 1 guest