[SOLVED] Ubuntu mate login loop

Moderators: odroid, mdrjr

[SOLVED] Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 10:41 am

Hello I have C1+ and a new user of odroid and after update of ubuntumate 16.04 LTS (the latest one) it is stock on login loop. Pressing the login will show blackscreen then will return to login screen again.

TIA.

Here is my xsession errors

openConnection: connect: No such file or directory
cannot connect to brltty at :0
/usr/bin/mate-session: 1: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 2: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 3: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 4: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 5: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 6: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 7: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 8: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 9: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 10: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 11: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 12: /usr/bin/mate-session: enum: not found
/usr/bin/mate-session: 13: /usr/bin/mate-session: Desktop: not found/usr/bin/mate-session: 12: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 14: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 15: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 16: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 17: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 18: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 19: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 20: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 21: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 22: /usr/bin/mate-session: Desktop: not found
/usr/bin/mate-session: 23: /usr/bin/mate-session: Syntax error: "(" unexpected


Here is my X.org.1.log when i press startx

[ 5223.358]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[ 5223.369] X Protocol Version 11, Revision 0
[ 5223.372] Build Operating System: Linux 4.4.0-97-generic armv7l Ubuntu
[ 5223.376] Current Operating System: Linux odroid 3.10.107-190 #1 SMP PREEMPT Mon Sep 4 20:41:37 UTC 2017 armv7l
[ 5223.376] Kernel command line: root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait ro console=tty0 console=ttyS0,115200n8 no_console_suspend fsck.repair=yes vdaccfg=0xa000 logo=osd1,loaded,0x7900000,720p,full dmfc=3 cvbsmode=576cvbs hdmimode=1360x768p60hz m_bpp=32 vout=hdmi disableuhs disablehpd=true monitor_onoff=false max_freq=1536 usbhid.quirks=0x0eef:0x0005:0x0004
[ 5223.392] Build Date: 13 October 2017 01:59:44PM
[ 5223.396] xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.com/support)
[ 5223.401] Current version of pixman: 0.33.6
[ 5223.409] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 5223.409] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 5223.427] (==) Log file: "/home/odroid/.local/share/xorg/Xorg.1.log", Time: Mon Nov 20 07:58:57 2017
[ 5223.432] (==) Using config file: "/etc/X11/xorg.conf"
[ 5223.436] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 5223.437] (==) No Layout section. Using the first Screen section.
[ 5223.437] (==) No screen section available. Using defaults.
[ 5223.437] (**) |-->Screen "Default Screen Section" (0)
[ 5223.437] (**) | |-->Monitor "<default monitor>"
[ 5223.438] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[ 5223.438] (**) | |-->Device "Mali-Fbdev"
[ 5223.438] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 5223.438] (**) Option "NoTrapSignals" "true"
[ 5223.438] (**) Option "DontZap" "false"
[ 5223.438] (**) Option "BlankTime" "0"
[ 5223.438] (**) Option "StandbyTime" "0"
[ 5223.439] (**) Option "SuspendTime" "0"
[ 5223.439] (**) Option "OffTime" "0"
[ 5223.439] (==) Automatically adding devices
[ 5223.439] (==) Automatically enabling devices
[ 5223.439] (==) Automatically adding GPU devices
[ 5223.439] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 5223.439] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 5223.439] Entry deleted from font path.
[ 5223.439] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 5223.439] Entry deleted from font path.
[ 5223.439] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 5223.439] Entry deleted from font path.
[ 5223.439] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 5223.439] Entry deleted from font path.
[ 5223.439] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 5223.439] Entry deleted from font path.
[ 5223.439] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 5223.439] (==) ModulePath set to "/usr/lib/arm-linux-gnueabihf/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 5223.439] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 5223.439] (II) Loader magic: 0xb6fe3f70
[ 5223.439] (II) Module ABI versions:
[ 5223.439] X.Org ANSI C Emulation: 0.4
[ 5223.439] X.Org Video Driver: 20.0
[ 5223.440] X.Org XInput driver : 22.1
[ 5223.440] X.Org Server Extension : 9.0
[ 5223.442] (++) using VT number 2

[ 5223.450] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c8
[ 5223.452] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 5223.454] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 1
[ 5223.454] (EE) Error systemd-logind returned paused fd for drm node
[ 5223.454] (II) systemd-logind: releasing fd for 226:0
[ 5223.455] (II) config/udev: Ignoring already known drm device (/dev/dri/card0)
[ 5223.456] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 5223.457] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 9 paused 0
[ 5223.458] (II) no primary bus or device found
[ 5223.458] falling back to /sys/devices/platform/mali_drm.1/drm/card1
[ 5223.458] (II) LoadModule: "glx"
[ 5223.459] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 5223.464] (II) Module glx: vendor="X.Org Foundation"
[ 5223.464] compiled for 1.18.4, module version = 1.0.0
[ 5223.464] ABI class: X.Org Server Extension, version 9.0
[ 5223.464] (==) AIGLX enabled
[ 5223.464] (II) LoadModule: "mali"
[ 5223.465] (II) Loading /usr/lib/xorg/modules/drivers/mali_drv.so
[ 5223.466] (II) Module mali: vendor="X.Org Foundation"
[ 5223.466] compiled for 1.18.3, module version = 0.4.2
[ 5223.466] ABI class: X.Org Video Driver, version 20.0
[ 5223.466] (EE) Error: MaliSetup
[ 5223.466] (EE) Error: MaliIdentify
[ 5223.466] (II) MALI: driver for Mali Framebuffer: mali
[ 5223.466] (WW) Falling back to old probe method for mali
[ 5223.466] (EE) Error: MaliProbe
[ 5223.466] (EE) Error: MaliHWProbe
[ 5223.466] (II) MALI(0): using /dev/fb0

[ 5223.466] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 5223.466] (II) MALI(0): [MaliPreInit:1351]: Entering
[ 5223.466] (II) MALI(0): [MaliGetRec:471]: Entering
[ 5223.467] (II) MALI(0): [MaliHWInit:1133]: Entering
[ 5223.467] (II) MALI(0): [MaliHWGetDepth:1165]: Entering
[ 5223.467] (II) MALI(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 5223.467] (==) MALI(0): Depth 24, (==) framebuffer bpp 32
[ 5223.467] (==) MALI(0): RGB weight 888
[ 5223.467] (==) MALI(0): Default visual is TrueColor
[ 5223.467] (==) MALI(0): Using gamma correction (1.0, 1.0, 1.0)
[ 5223.467] (II) MALI(0): [MaliHWGetVidmem:1183]: Entering
[ 5223.467] (II) MALI(0): [MaliHWGetName:1191]: Entering
[ 5223.467] (II) MALI(0): hardware: OSD FB (video memory: 24576kB)

[ 5223.467] (**) MALI(0): Option "HWCursor" "false"
[ 5223.467] (**) MALI(0): Option "SWCursor" "true"
[ 5223.467] (**) MALI(0): Option "DRI2" "true"
[ 5223.467] (**) MALI(0): Option "DRI2_PAGE_FLIP" "false"
[ 5223.467] (**) MALI(0): Option "DRI2_WAIT_VSYNC" "false"
[ 5223.467] (**) MALI(0): Option "UMP_CACHED" "true"
[ 5223.467] (**) MALI(0): Option "UMP_LOCK" "false"
[ 5223.467] (**) MALI(0): DRI Fullscreen page flip disabled. No support in config file
[ 5223.467] (**) MALI(0): DRI Fullscreen page flip VSYNC disabled
[ 5223.467] (**) MALI(0): Use cached UMP memory
[ 5223.467] (**) MALI(0): Don't use umplock across processes
[ 5223.535] (EE) MALI(0): [mali_drm_open_master:1326] Error: mali_drm_open_master DRM OPEN (fd: 0xb)

[ 5223.535] (EE) MALI(0): [mali_drm_open_master:1337] Error: mali_drm_open_master DRM failed to interface version

[ 5223.535] (EE) MALI(0): [MaliPreInit:1453] Error: Failed to be master of DRM!
[ 5223.535] (II) UnloadModule: "mali"
[ 5223.535] (EE) Screen(s) found, but none have a usable configuration.
[ 5223.536] (EE)
Fatal server error:
[ 5223.536] (EE) no screens found(EE)
[ 5223.536] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 5223.536] (EE) Please also check the log file at "/home/odroid/.local/share/xorg/Xorg.1.log" for additional information.
[ 5223.536] (EE)
[ 5223.558] (EE) Server terminated with error (1). Closing log file.
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: Ubuntu mate login loop

Unread postby odroid » Tue Nov 21, 2017 10:51 am

User avatar
odroid
Site Admin
 
Posts: 27730
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 11:03 am

Yes that image, works well then after update and reboot this happens. I used the win32disk imager. Thank you for fast reply.
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: Ubuntu mate login loop

Unread postby odroid » Tue Nov 21, 2017 11:29 am

I will try to reproduce the issue.
Do you use an SD card? or an eMMC?
User avatar
odroid
Site Admin
 
Posts: 27730
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 11:47 am

A sd card.
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: Ubuntu mate login loop

Unread postby joshua.yang » Tue Nov 21, 2017 3:15 pm

It seems to be fine on my C1+ with 8G MicroSD card. I used the latest image ubuntu-16.04.3-mate-odroid-c1-20170908.img.xz.
After installation, I used
Code: Select all
sudo apt update && sudo apt full-upgrade -y


Could you re-burn the latest image using the latest Etcher and try it again?

C1+ Ubuntu Mate: https://wiki.odroid.com/odroid-c1/os_images/ubuntu/v2.2
Etcher: https://etcher.io/
joshua.yang
 
Posts: 62
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: English
ODROIDs: XU4, XU4Q + Cloudshell2

Re: Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 3:23 pm

joshua.yang wrote:It seems to be fine on my C1+ with 8G MicroSD card. I used the latest image ubuntu-16.04.3-mate-odroid-c1-20170908.img.xz.
After installation, I used
Code: Select all
sudo apt update && sudo apt full-upgrade -y


Could you re-burn the latest image using the latest Etcher and try it again?

C1+ Ubuntu Mate: https://wiki.odroid.com/odroid-c1/os_images/ubuntu/v2.2
Etcher: https://etcher.io/


I just followed the commands on the site.
I'll try again. Thanks for support.

Quoted

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install linux-image-c1
sudo reboot
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: Ubuntu mate login loop

Unread postby joshua.yang » Tue Nov 21, 2017 3:53 pm

infinityx wrote:I just followed the commands on the site.
I'll try again. Thanks for support.

Quoted

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt install linux-image-c1
sudo reboot


Actually, there's no difference between the commands I used and them. Both commands perform same function.
apt's dist-upgrade is being for compatibility of apt-get's, full-upgrade is proper.
For more information: https://askubuntu.com/questions/445384/ ... nd-apt-get

So I think maybe there's something wrong when you were preparing your C1+ :o
joshua.yang
 
Posts: 62
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: English
ODROIDs: XU4, XU4Q + Cloudshell2

Re: Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 4:16 pm

So I think maybe there's something wrong when you were preparing your C1+ :o


How about the linux-image-c1?

I'm now updating it. My internet is slow so might take some time. :D
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+

Re: Ubuntu mate login loop

Unread postby joshua.yang » Tue Nov 21, 2017 5:01 pm

infinityx wrote:How about the linux-image-c1?


That's been for updating the kernel on your C1+.
You should update using that command if the update is available. :)
joshua.yang
 
Posts: 62
Joined: Fri Sep 22, 2017 5:54 pm
languages_spoken: English
ODROIDs: XU4, XU4Q + Cloudshell2

Re: Ubuntu mate login loop

Unread postby infinityx » Tue Nov 21, 2017 5:39 pm

It's all working now. Don't know what happened to the installation before. Thanks for the help guys! Awesome community!
infinityx
 
Posts: 6
Joined: Tue Nov 21, 2017 10:29 am
languages_spoken: english
ODROIDs: Odroid C1+


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 1 guest