Issue with HEVC HW Decoding

Moderators: mdrjr, odroid

Issue with HEVC HW Decoding

Unread postby ammuj » Mon Dec 07, 2015 2:39 pm

Hi Community,

Platform : Odroid C1+, latest Ubuntu

I am using C1+ to do 1080p/30fps HEVC RTSP streaming. I am using LIVE555 for rtsp client and esplayer from AMLogic to call decoder.
What I see is that the HW decoder hangs randomly after few frames, sometimes it works if I buffer the input data.
I am not sure what is the reason for its hang and I could not find any supporting document for the decoder.

Any insights,

note:
1. I am not using kodi as I dont need any UI
2. The same setup works fine for H.264 streaming with about 400ms latency.
ammuj
 
Posts: 6
Joined: Wed Nov 11, 2015 3:24 pm
languages_spoken: english

Re: Issue with HEVC HW Decoding

Unread postby wrxtasy » Mon Dec 07, 2015 4:19 pm

Likely related to the Known problem with various HEVC video files.

Hardkernel are aware of this HEVC playback problem, and have known for some time now. They need to modify the official C1 Kernel, ask kindly and maybe mdrjr or someone may do it sometime, maybe :?:
There is a HEVC Kernel patch here:
viewtopic.php?f=112&t=15158&start=250#p115025
LibreELEC Krypton C1(+) HERE
LibreELEC Krypton C2 HERE
User avatar
wrxtasy
 
Posts: 1288
Joined: Wed May 13, 2015 1:59 pm
Location: Australia
languages_spoken: english
ODROIDs: C1, C1+, C2

Re: Issue with HEVC HW Decoding

Unread postby ammuj » Mon Dec 07, 2015 4:26 pm

wrxtasy,
Thanks for your reply, I will apply the patch and try again
ammuj
 
Posts: 6
Joined: Wed Nov 11, 2015 3:24 pm
languages_spoken: english

Re: Issue with HEVC HW Decoding

Unread postby ammuj » Wed Dec 09, 2015 2:58 pm

wrxtasy,

I applied the patch to the kernel as you mentioned and build the kernel. I followed the steps explained in http://odroid.com/dokuwiki/doku.php?id= ... ing_kernel.
I could only update the firmware and modules part of the kernel, could you please tell me how to update amlogic decoder drivers - amports.
ammuj
 
Posts: 6
Joined: Wed Nov 11, 2015 3:24 pm
languages_spoken: english

Re: Issue with HEVC HW Decoding

Unread postby ammuj » Wed Dec 09, 2015 3:39 pm

Sorry.. Updated zImage
ammuj
 
Posts: 6
Joined: Wed Nov 11, 2015 3:24 pm
languages_spoken: english

Re: Issue with HEVC HW Decoding

Unread postby ammuj » Wed Dec 09, 2015 7:30 pm

Hi,
I have applied the HEVC patch mentioned in viewtopic.php?f=112&t=15158&start=250#p115025 but still its same, HEVC decoding in RTSP streaming hangs. HEVC decoding is fine with playback but not with RTSP streaming.

Can someone please help me?
ammuj
 
Posts: 6
Joined: Wed Nov 11, 2015 3:24 pm
languages_spoken: english

Re: Issue with HEVC HW Decoding

Unread postby XeoSal » Wed Dec 09, 2015 9:33 pm

ammuj wrote:Hi,
I have applied the HEVC patch mentioned in viewtopic.php?f=112&t=15158&start=250#p115025 but still its same, HEVC decoding in RTSP streaming hangs. HEVC decoding is fine with playback but not with RTSP streaming.

Can someone please help me?

Try using a Debian distro for KODI, I've been testing it on Odrobian and it's much more stable than ubuntu, this patch and more are already applied on our kernel. :)
User avatar
XeoSal
 
Posts: 924
Joined: Sun Aug 30, 2015 11:21 pm
languages_spoken: English
ODROIDs: C1, C1+, C2 & XU4


Return to Ubuntu

Who is online

Users browsing this forum: No registered users and 3 guests