MyAHRS+ Monitor does not detect device

Moderators: mdrjr, odroid

MyAHRS+ Monitor does not detect device

Unread postby mcajkovs » Fri Mar 10, 2017 6:47 am

When I PLUG MyAHRS device into USB port and click on binoculars icon in MyAHRS+ Monitor 1.02 nothing happens. When I UNPLUG MyAHRS device from USB port and click on binoculars icon in MyAHRS+ Monitor 1.02 I get following:

If I click on binocular icon when MyAHRS device is UNPLUGGED and then PLUG MyAHRS device and select Scan MyAHRS+ then I got the message saying "Can not find any sensor in your system":

But test_myahrs_plus.exe 1 COM5 is working for me. LED diode is red with flashing yellow. I'm running 64-bit Windows 10 with latest updates and MyAHRS+ Monitor 1.02 is launched under administrator. I've also noticed that serial port is not using with MyAHRS monitor nor with test_myahrs_plus.exe 1 COM5 which guess is OK and instead USB is used. Interesting is that MyAHRS monitor does not accessing USB (maybe it is but only for short period of time and I was unable to find it via process explorer):

I've tried also MyAHRS+ Monitor 1.02 on different machine running 64-bit Windows 7 but I got:
Code: Select all
Can't start myAHRS+ Monitor. ver1.02.
-NameError ("global name 'pyqtgraph' is not defined",)

I've found in this post that it might be caused by old version of OpenGL. But I guess I'm not able to get new one because it is the old HP Compaq 6710b laptop. However on this machine the test_myahrs_plus.exe 1 COM5 also works (it required installing Virtual COM Port Driver mentioned here and messing with mfc120u.dll msvcp120.dll and msvcr120.dll but it works). I'm trying to say that MyAHRS+ device is 100% correct because it also worked on my friend PC under myAHRS+ Monitor. I've also added issue on github

Thanks you.
Posts: 1
Joined: Fri Mar 10, 2017 4:25 am
languages_spoken: english
ODROIDs: myAhrs+

Return to myAHRS+ and Biscuit (Motion sensors)

Who is online

Users browsing this forum: No registered users and 5 guests