[SOLVED] VU8C not powering properly/black screen

Moderators: odroid, mdrjr

[SOLVED] VU8C not powering properly/black screen

Unread postby tblanton » Thu Feb 08, 2018 12:39 am

I'd like to preface this post by saying that I don't have an extensive background in hardware or software and have only been working with ODROID products for about a month, so I'm aware that my lack of experience may be at the root of my issues.

With that being said, I've recently purchased 4 C2's with VU8C displays as well as eMMC's pre-flashed with Android from ODROID and WiFi/GPS/Bluetooth dongles connected to a USB hub. I assembled all 4 of the VU8C's exactly as instructed and am having mixed results with their usability. 2 of the units work flawlessly and I am very happy with them, however, there seems to be an issue with the other 2. When I turn them on I get a black screen that never makes it to the HardKernel startup screen. The backlight is working, there just isn't any display. The issue is identical on both of the ones that aren't working properly.

I've taken them both apart and plugged the C2's into a monitor and they are working fine. I've reassembled the VU8Cs and double checked all of my connections, but am still facing the same problem with both of them. Is there something I'm missing?

Willing to post any pics/vids/etc that may help. Thanks for any help!
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Thu Feb 08, 2018 9:48 am

Mostly the 40pin FPCB cable assembly issue. Please check this picture.
Image
This guide should be helpful.
https://wiki.odroid.com/accessory/displ ... bling_vu8c
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Fri Feb 09, 2018 2:00 am

I assembled each of the units exactly the same and using the same guide that you linked. I have checked the 40 pin FPCB connection on both of the units that aren't working properly multiple times, and that hasn't solved the issue. Anything else I can try?
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Fri Feb 09, 2018 1:18 pm

I see. Let's try to narrow down root causes.
Can you swap the HDMI bridge boards with working one?
Can you show me a picture of FPCB connection for those two non-working units?
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Tue Feb 13, 2018 12:22 am

I have attached pictures of the FPCB cables but realized that is not the issue. I believe the issue is somewhere between the C2 itself and the VU8C.

I have attached 2 other pictures of the C2's. One photo has the 2 that aren't working, and the other has the unit that is working.
Here is what I have found after replacing the C2's in different VU8Cs:

The C2 with the 32 GB eMMC works just fine in all 3 VU8Cs. That is why I believe there is no issue with the FPCB connections.

Neither C2 with a 16GB eMMC works in any of the 3 VU8Cs. However, both power on just fine when plugged into a TV monitor via HDMI and a power cable running directly into the C2.
Attachments
rsz_img_20180209_095502.jpg
rsz_img_20180209_095502.jpg (86.36 KiB) Viewed 916 times
rsz_img_20180209_095627.jpg
rsz_img_20180209_095627.jpg (88.17 KiB) Viewed 916 times
rsz_1img_20180209_095701.jpg
rsz_1img_20180209_095701.jpg (91.98 KiB) Viewed 916 times
rsz_img_20180209_123414.jpg
Non-functional C2's
rsz_img_20180209_123414.jpg (138.72 KiB) Viewed 916 times
rsz_img_20180209_123426.jpg
Functional C2
rsz_img_20180209_123426.jpg (183.73 KiB) Viewed 916 times
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Tue Feb 13, 2018 11:17 am

The OS or Kernel should be outdated in the 16Gb eMMC probably.
Boot the C2 with a HDMI monitor and run the following commands to update the system software.
https://wiki.odroid.com/odroid-c2/os_im ... and_system

Or, manually modify the boot.ini file.
https://wiki.odroid.com/accessory/displ ... e_settings
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Tue Feb 13, 2018 11:27 pm

I just want to confirm before I attempt to make any significant changes. I'm using Android as my OS and the Android version is 6.0.1 on all 3 units. The Kernel version is 3.14.29 on all 3, but the security patch level and build number are different. The security patch level date for the C2 that is working is Nov 6 2017. The patch level date for the 2 that are not working is Sep 6 2016. Would this be the root cause?
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby tblanton » Wed Feb 14, 2018 1:30 am

I updated the android version on the 16GB eMMCs using the ODROID Utility as pictured below. Now it is showing the same Android/Kernel version and security patch level. I have also attached a picture I am seeing on the 16GB eMMCs which I am almost certain is the cause of the issue. When I open ODROID Utility I am seeing a message that reads "Not found boot.ini". Picture attached. Please advise on how to proceed.
Attachments
rsz_1img_20180213_101925.jpg
rsz_1img_20180213_101925.jpg (54.55 KiB) Viewed 891 times
screenshot_2016-04-25-07-43-39.png
screenshot_2016-04-25-07-43-39.png (40.2 KiB) Viewed 891 times
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Wed Feb 14, 2018 11:12 am

Go to "SCREEN" tab and choose "Vu8" or "1024x768" resolution with "DVI" option.
After proper shutdown, connect the C2 to your Vu8 again for testing.

The latest update might have a problem with EDID auto-detection.
We will check it later.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Thu Feb 15, 2018 5:23 am

That seems to have solved the issue, but not entirely. The first time I plugged in both units I got a screen looking like the one in the picture attached. I disconnected and reconnected the power supply and they powered up correctly. I've unplugged/plugged them back up a few times since and they are still not powering correctly every time, but overall the results have been much better. Is there any known reason why they wouldn't power correctly every time?
Attachments
rsz_img_20180214_111817.jpg
rsz_img_20180214_111817.jpg (114.13 KiB) Viewed 870 times
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Thu Feb 15, 2018 11:11 am

Can you find "boot.ini" file in your SD card FAT partition?
If yes, post it and we will review it.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Thu Feb 15, 2018 10:41 pm

I am not able to find the boot.ini anywhere. I am looking in Storage Settings in ODROID Utility. Have searched all through Internal storage and SD Card and see no reference to FAT or boot.ini
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Fri Feb 16, 2018 10:01 am

Please check "/storage/internal/".
If it doesn't exist, we will help you early next week since we are having a vacation for Lunar new year holidays from yesterday.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Fri Feb 16, 2018 11:19 pm

It does not exist.
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Sat Feb 17, 2018 2:50 pm

Can you create this boot.ini file in that folder?
https://wiki.odroid.com/odroid-c2/os_im ... ce_bootini

If yes, change setenv hdmimode "1080p60hz" to setenv hdmimode "1024x768p60hz".
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Wed Feb 21, 2018 2:35 am

I am not sure how to create a boot.ini file. I have attached screenshots trying to find the file in the terminal emulator.
Attachments
Screenshot_19691231-212100.png
Screenshot_19691231-212100.png (42.38 KiB) Viewed 810 times
Screenshot_19691231-211946.png
Screenshot_19691231-211946.png (37.49 KiB) Viewed 810 times
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby joy » Wed Feb 21, 2018 5:04 pm

Hi tblanton,
Here is a sample boot.ini to set display mode for VU8C.
Code: Select all
ODROIDC2-UBOOT-CONFIG

setenv dtbaddr 0x1000000
setenv loadaddr 0x20000000

# Resolution Configuration
# 'hdmimode' must be one of below to configure display resolution within
# supported by your TV or monitor.
#    Symbol             | Resolution
# ----------------------+-------------
#    "480x320p60hz"     | 480x320 Progressive 60Hz
#    "480p60hz"         | 720x480 Progressive 60Hz
#    "576p50hz"         | 720x576 Progressive 50Hz
#    "720p60hz"         | 1280x720 Progressive 60Hz
#    "720p50hz"         | 1280x720 Progressive 50Hz
#    "1080p60hz"        | 1920x1080 Progressive 60Hz
#    "1080p50hz"        | 1920x1080 Progressive 50Hz
#    "1080p30hz"        | 1920x1080 Progressive 30Hz
#    "1080p24hz"        | 1920x1080 Progressive 24Hz
#    "1080i60hz"        | 1920x1080 Interlaced 60Hz
#    "1080i50hz"        | 1920x1080 Interlaced 50Hz
#    "2160p60hz"        | 3840x2160 Progressive 60Hz
#    "2160p50hz"        | 3840x2160 Progressive 50Hz
#    "2160p30hz"        | 3840x2160 Progressive 30Hz
#    "2160p25hz"        | 3840x2160 Progressive 25Hz
#    "2160p24hz"        | 3840x2160 Progressive 24Hz
#    "2160p60hz420"     | 3840x2160 Progressive 60Hz YCbCr 4:2:0
#    "2160p50hz420"     | 3840x2160 Progressive 50Hz YCbCr 4:2:0
#    "640x480p60hz"     | 640x480 Progressive 60Hz
#    "800x480p60hz"     | 800x480 Progressive 60Hz
#    "800x600p60hz"     | 800x600 Progressive 60Hz
#    "1024x600p60hz"    | 1024x600 Progressive 60Hz
#    "1024x768p60hz"    | 1024x768 Progressive 60Hz
#    "1280x800p60hz"    | 1280x800 Progressive 60Hz
#    "1280x1024p60hz"   | 1280x1024 Progressive 60Hz
#    "1360x768p60hz"    | 1360x768 Progressive 60Hz
#    "1440x900p60hz"    | 1440x900 Progressive 60Hz
#    "1600x900p60hz"    | 1600x900 Progressive 60Hz
#    "1600x1200p60hz"   | 1600x1200 Progressive 60Hz
#    "1680x1050p60hz"   | 1680x1050 Progressive 60Hz
#    "1920x1200p60hz"   | 1920x1200 Progressive 60Hz
#    "2560x1080p60hz"   | 2560x1080 Progressive 60Hz
#    "2560x1440p60hz"   | 2560x1440 Progressive 60Hz
#    "2560x1600p60hz"   | 2560x1600 Progressive 60Hz
#    "3440x1440p60hz"   | 3440x1440 Progressive 60Hz
setenv hdmimode "1024x768p60hz"

setenv rootopt "root=/dev/mmcblk0p2 rw init=/init rootwait"
setenv consoleopt "console=ttyS0,115200"
setenv androidopt "androidboot.hardware=odroidc2 androidboot.serialno=${fbt_id#}"
setenv logoopt "osd1,loaded,${fb_addr},${hdmimode}"
setenv selinuxopt "androidboot.selinux=disabled"

# HDMI/DVI Mode Configuration
# This will enforce the signal type of display
# "hdmi" - For HDMI interface
# "dvi" - For DVI interface
setenv vout_mode "dvi"

# Display Auto Detection
# "false" or "true"
setenv display_autodetect "false"

# HPD enable/disable option
setenv disablehpd "false"

# Overscan offset configuration
# All offsets are zero and can be tuned by manual or ODROID Utility
setenv overscan_top "0"
setenv overscan_left "0"
setenv overscan_bottom "0"
setenv overscan_right "0"
setenv led_onoff "on"
suspend_hdmiphy=0

# Force HDMI to use RGB colorspace regardless of TV request
setenv hdmi_forcergb "0"      # Disabled
# setenv hdmi_forcergb "1"        # Enabled

# max cpu frequency in dvfs table / in MHz unit
# setenv max_freq "2016"  # 2.016GHz
# setenv max_freq "1944"  # 1.944GHz
# setenv max_freq "1920"  # 1.920GHz
# setenv max_freq "1896"  # 1.896GHz
# setenv max_freq "1752"  # 1.752GHz
# setenv max_freq "1680"  # 1.680GHz
# setenv max_freq "1656"  # 1.656GHz
# setenv max_freq "1536"  # 1.536GHz
setenv max_freq "1536"

# max cpu-cores
# setenv maxcpus "1"
# setenv maxcpus "2"
# setenv maxcpus "3"
setenv maxcpus "4"

# disable vu7
setenv disable_vu7 "false"

# invert touch screen x,y
setenv touch_invert_x "false"
setenv touch_invert_y "false"

# gpio power key : J2 (2x20) Pin#35, GPIOY.BIT3
#setenv gpiopower "214"

# usb timing tweak
setenv usbmulticam "false"

setenv hdmitx "hdmitx=${cecconfig}"
if test "${hdmi_forcergb}" = "1"; then setenv hdmitx "hdmitx=forcergb"; fi

if test "${display_autodetect}" = "true"; then usb pwren; hdmitx edid; fi
if test "${hdmimode}" = "custombuilt"; then setenv cmode "modeline=${modeline}"; fi

# Enable backlight_pwm
# disable : backlight "no"
# ODROID-VU5/7 : backlight "yes"
# ODROID-VU8 : backlight "invert"
setenv backlight_pwm "no"

showddrclk

setenv bootargs "${rootopt} ${consoleopt} hdmimode=${hdmimode} ${cmode} ${hdmitx} vout=${vout_mode} disablehpd=${disablehpd} logo=${logoopt} ${androidopt} ${selinuxopt} suspend_hdmiphy=${suspend_hdmiphy} led_onoff=${led_onoff} max_freq=${max_freq} maxcpus=${maxcpus} disable_vu7=${disable_vu7} touch_invert_x=${touch_invert_x} touch_invert_y=${touch_invert_y} usbmulticam=${usbmulticam} gpiopower=${gpiopower} backlight_pwm=${backlight_pwm} ddrclock=${ddrclock}"

save

showlogo ${hdmimode}
#usb pwren

movi read dtb 0 ${dtbaddr}
# load kernel from vat or boot partition.
movi read boot 0 ${loadaddr}
#fatload mmc 0:1 ${loadaddr} Image_android
booti ${loadaddr} - ${dtbaddr}

You can find the same file in attachment.
boot.ini
(4.85 KiB) Downloaded 51 times

Please download it and copy it into the VFAT filesystem.

1. If you try to copy the file on C2 Android, you need to find /storage/internal/ folder first and copy boot.ini into the folder.
2. Or when you use your Host PC and card reader, you can see the VFAT file system named as "VFAT" when you connect your eMMC to host PC.
Just copy this file into the folder.

[edit]
And to make sure, can I check one more?
Which Android version do you use?
Unless you're using an old version, there must be the folder, /storage/internal/. :?
Please share the version you're using.

Thanks!
joy
 
Posts: 456
Joined: Fri Oct 02, 2015 1:44 pm
languages_spoken: english
ODROIDs: ODROID-C1+, XU4, X

Re: VU8C not powering properly/black screen

Unread postby tblanton » Thu Feb 22, 2018 6:05 am

Hello, I am using Android 6.0.1 and there is no VFAT filesystem nor is there a /storage/internal/ available. The boot.ini link was downloaded but it does not open.
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Thu Feb 22, 2018 9:49 am

There many different versions on Android 6.0.1 release.
https://wiki.odroid.com/odroid-c2/os_im ... id/android

Do you have an eMMC compatible card reader?
viewtopic.php?f=53&t=2725
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby codewalker » Thu Feb 22, 2018 12:00 pm

cd "/storage/internal/" instead "/boot"
Code: Select all
shell@odroidc2:/data $ su
[ 1325.405031@3] ttyS0 use xtal 24000000 change 115200 to 115200
root@odroidc2:/ # cd /storage/internal/                                       
root@odroidc2:/storage/internal # ls
Android
Image_android
LOST.DIR
boot-logo.bmp.gz
boot.ini
display.bin
edid.bin
root@odroidc2:/storage/internal #

tblanton wrote:I am not sure how to create a boot.ini file. I have attached screenshots trying to find the file in the terminal emulator.
User avatar
codewalker
 
Posts: 481
Joined: Mon Feb 25, 2013 11:03 am
languages_spoken: english
ODROIDs: all

Re: VU8C not powering properly/black screen

Unread postby tblanton » Thu Feb 22, 2018 11:41 pm

Hi codewalker,

as mentioned before, "/storage/internal/" does not exist so I cannot change into that file.
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby tblanton » Fri Feb 23, 2018 12:52 am

odroid,

We do have an eMMC compatible card reader.

Thanks!
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: VU8C not powering properly/black screen

Unread postby odroid » Fri Feb 23, 2018 10:35 am

We are trying to fix the Vu8C plug-and-play issue.
Please give us a few more days to release a new Android image.
Once you flash the new OS image with the compatible card reader, your VU8C issue will be gone.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby odroid » Mon Feb 26, 2018 10:22 am

Flash the latest v3.7 image on your eMMC and your issue will be fixed.
https://wiki.odroid.com/odroid-c2/os_im ... allow_v3.7
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: VU8C not powering properly/black screen

Unread postby tblanton » Wed Feb 28, 2018 10:48 pm

Issue is solved with Marshmallow 3.8 flashed. Thank you for the prompt replies!
tblanton
 
Posts: 14
Joined: Thu Feb 08, 2018 12:03 am
languages_spoken: english
ODROIDs: C2

Re: [SOLVED] VU8C not powering properly/black screen

Unread postby odroid » Wed Feb 28, 2018 10:57 pm

Thank you for the confirmation.
User avatar
odroid
Site Admin
 
Posts: 27934
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID


Return to ODROID-VU

Who is online

Users browsing this forum: No registered users and 1 guest

cron