[SOLVED] No boot after switching power from otg to DC jack

Moderators: odroid, mdrjr

[SOLVED] No boot after switching power from otg to DC jack

Unread postby gb.yolo » Wed Feb 15, 2017 8:54 pm

Hi all,
I am experiencing a very annoying problem.
I always powered my Odroid C2 with a DC 5V2A PSU and a USB to microUSB cable, and always had the J1 jumper installed (as the wiki says...). I have a SanDisk microSD with Odrobian.
It worked flawlessly, never had a problem.
Yesterday I decided to buy a USB to DC jack cable because I wanted to use the Over-voltage protection feature which you don't get powering the board with the otg port. I removed the J1 jumper (again, as the wiki says...) but now the board won't boot anymore. When I power on the PSU, the red led is on and the blue led never starts blinking, so the boot process doesn't start.

Some notes:
- The PSU is the same, 5V2A stable DC, I changed only the cable (and the port on the board, from OTG to DC jack)
- I checked the voltage with a voltmeter between GPIO pins 2/6 (I got 4.7 V, ok) and 1/6 (I got 3.1 V, ok) so the voltage is ok. (http://www.hardkernel.com/main/products/prdt_info.php?g_code=G145457216438&tab_idx=2)
- Powered with NO device inserted (no usb devices, no ethernet, absolutely nothing), still not booting
- Powered with NO device inserted and with HDMI cable, no info on the screen, not booting. (This was a useless check, but you never know...)
- Installing the Jumper again, and using the old OTG cable, the board starts properly, so I assume it's not a PSU problem nor a SD card problem.
- I don't have a serial cable

Some links:
- PSU: https://www.amazon.it/gp/product/B00JWXT6BK/ref=oh_aui_detailpage_o07_s00?ie=UTF8&psc=1
- OTG power cable: https://www.amazon.it/gp/product/B01HB5EQJW/ref=oh_aui_detailpage_o07_s00?ie=UTF8&psc=1
- USB to Jack cable: https://www.amazon.it/gp/product/B00UTJGQWI/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Based on the tests above, I assume that:
- This is not a PSU fault
- not SD fault
- not OS flashing fault

I think that the USB to DC jack cable is not working, but it may be the DC power input port on the board as well.

Any ideas?

Thank you guys, this is driving me crazy.
Last edited by gb.yolo on Fri Feb 17, 2017 1:19 am, edited 1 time in total.
gb.yolo
 
Posts: 3
Joined: Wed Feb 15, 2017 8:33 pm
languages_spoken: english,italian
ODROIDs: odroid c2

Re: [Help] No boot when switching power from otg port to DC

Unread postby rooted » Thu Feb 16, 2017 10:27 am

Someone else just had this problem, it was a bad cable which was new and not from HK.

Check the cable with your DMM.
User avatar
rooted
 
Posts: 3292
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1
C1+
C2
XU3 Lite
XU4
VU7+
HiFi Shield 2
Smart Power (original)

Re: [Help] No boot when switching power from otg port to DC

Unread postby odroid » Thu Feb 16, 2017 10:38 am

If the voltage is 4.7Volt when the board doesn't work, the PSU or DC cable should be a problem as 'rooted' mentioned.
When the normal voltage is 5.2Volt (without heavy load), it could down to 4.9Volt when the booting process needs in-rush current.
User avatar
odroid
Site Admin
 
Posts: 21842
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: [Help] No boot when switching power from otg port to DC

Unread postby gb.yolo » Thu Feb 16, 2017 5:34 pm

Thank you, I'll try with a new cable.

Sent from my ONEPLUS A3003
gb.yolo
 
Posts: 3
Joined: Wed Feb 15, 2017 8:33 pm
languages_spoken: english,italian
ODROIDs: odroid c2

Re: [Help] No boot when switching power from otg port to DC

Unread postby gb.yolo » Fri Feb 17, 2017 1:13 am

gb.yolo wrote:Thank you, I'll try with a new cable.

Sent from my ONEPLUS A3003

Tried another cable and it's working.
Thank you again.

Sent from my ONEPLUS A3003
gb.yolo
 
Posts: 3
Joined: Wed Feb 15, 2017 8:33 pm
languages_spoken: english,italian
ODROIDs: odroid c2

Re: [SOLVED] No boot after switching power from otg to DC ja

Unread postby rooted » Fri Feb 17, 2017 7:15 am

Glad you got it resolved.
User avatar
rooted
 
Posts: 3292
Joined: Fri Dec 19, 2014 9:12 am
Location: Gulf of Mexico, US
languages_spoken: english
ODROIDs: C1
C1+
C2
XU3 Lite
XU4
VU7+
HiFi Shield 2
Smart Power (original)


Return to General Chat

Who is online

Users browsing this forum: No registered users and 3 guests