Error while using oCAM with sample code in Ubuntu 16.04

Moderators: odroid, mdrjr

Error while using oCAM with sample code in Ubuntu 16.04

Unread postby robroy » Sat Mar 11, 2017 4:51 am

The instructions to install the prerequisites and the viewer can be found at http://bit.ly/2lMJMMI, and listed below are the recommended commands:

Code: Select all
$ sudo apt-get install qt4-default libv4l-dev libudev-dev
$ cd ~ && mkdir ocam && cd ocam
$ svn export https://github.com/withrobot/oCam/trunk/Software/oCam_viewer_Linux
$ cd ./oCam_viewer_Linux
$ mkdir build
$ cd ./build
$ qmake ..
$ make release

$ ./oCam-viewer


The above run command has the following behavior:
    When connected to USB3, the camera is not detected
    When connected to USB2, it is detected, but there is no picture.
Rob Roy, Editor-in-Chief of ODROID Magazine (submit an article | make a donation)
User avatar
robroy
 
Posts: 3294
Joined: Mon Feb 25, 2013 2:29 am
Location: San Francisco, California
languages_spoken: English
ODROIDs: Q2, X, X2, U2, U3, XU-E, XU3, XU4, C1, C1+, C2

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby odroid » Sat Mar 11, 2017 1:42 pm

Can you find the webcam deviceID 04b4:00f9 Cypress Semiconductor Corp. from "lsusb" output?
User avatar
odroid
Site Admin
 
Posts: 21746
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby venkatbo » Sun Mar 12, 2017 2:20 am

The usb info is slightly different (00f8):
Code: Select all
Bus 003 Device 003: ID 04b4:00f8 Cypress Semiconductor Corp.

I can build the viewer app. However, when I run, I see the following errors:
Code: Select all
odroid@odroid:~/zBU/ocam/oCam_viewer_Linux/build$ ./oCam-viewer
V4L2_CORE: Unable to find parent usb device [ /dev/video6 ].
V4L2_CORE: Unable to find parent usb device [ /dev/video7 ].
Device Node Path      : /dev/video0
VID/PID               : 04b4 / 00f8
Product [menufacturer]: oCam-1MGN-U [ WITHROBOT Inc. ]
serial                : SN_27425109
busnum                : 3
devnum                : 3

The UI does not dislay any image.
1.png
1.png (36.79 KiB) Viewed 152 times
User avatar
venkatbo
 
Posts: 423
Joined: Mon Feb 25, 2013 3:10 pm
Location: Bay Area, California
languages_spoken: english
ODROIDs: C0/C1+/C2 U3+ XU3-Lite/XU4 VU/VU7+ Touchscreen Show TFT Cloudshell SmartPower mAHRS DAC GPS Multiscope

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby odroid » Sun Mar 12, 2017 1:17 pm

Ok. I will request some help from WITHROBOT people.
User avatar
odroid
Site Admin
 
Posts: 21746
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby robroy » Tue Mar 21, 2017 11:40 am

odroid wrote:Ok. I will request some help from WITHROBOT people.

Did they have any suggestions on updating our code, or does this need to be resolved with a kernel update?
Rob Roy, Editor-in-Chief of ODROID Magazine (submit an article | make a donation)
User avatar
robroy
 
Posts: 3294
Joined: Mon Feb 25, 2013 2:29 am
Location: San Francisco, California
languages_spoken: English
ODROIDs: Q2, X, X2, U2, U3, XU-E, XU3, XU4, C1, C1+, C2

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby odroid » Tue Mar 21, 2017 12:24 pm

WITHROBOT engineers will check this issue soon.
User avatar
odroid
Site Admin
 
Posts: 21746
Joined: Fri Feb 22, 2013 11:14 pm
languages_spoken: English
ODROIDs: ODROID

Re: Error while using oCAM with sample code in Ubuntu 16.04

Unread postby amie » Thu Mar 23, 2017 3:14 am

I am using oCam 5CRO U with odroid XU4, Ubuntu 16.04 and hitting the same issue.

'lsusb' is giving the following output -
odroid@odroid:~$ lsusb
Bus 006 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.

odroid@odroid:~$ ls /dev | grep video
video6
video7

When I run oCam-viewer, I am getting the following error -

odroid@odroid:~/cam/oCam_viewer_Linux/build$ ./oCam-viewer
V4L2_CORE: Unable to find parent usb device [ /dev/video6 ].
V4L2_CORE: Unable to find parent usb device [ /dev/video7 ].
V4L2_CORE: Unable to find parent usb device [ /dev/video6 ].
V4L2_CORE: Unable to find parent usb device [ /dev/video7 ].

And the viewer UI is blank (like the one posted by venkatbo) -
Image
amie
 
Posts: 1
Joined: Thu Mar 23, 2017 3:07 am
languages_spoken: english
ODROIDs: Odroid XU4


Return to oCAM USB 3.0 Camera

Who is online

Users browsing this forum: No registered users and 1 guest